summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Jones <carpaski@gentoo.org>2003-02-27 11:31:00 +0000
committerNicholas Jones <carpaski@gentoo.org>2003-02-27 11:31:00 +0000
commitdcea027666f6ecb4eb8665699593edb95a36757a (patch)
tree14d88cecb814c6e03e3d95923eb1016e130d118e
parent... (diff)
downloadportage-cvs-dcea027666f6ecb4eb8665699593edb95a36757a.tar.gz
portage-cvs-dcea027666f6ecb4eb8665699593edb95a36757a.tar.bz2
portage-cvs-dcea027666f6ecb4eb8665699593edb95a36757a.zip
mostly type fixes.
distcc fix
-rwxr-xr-xbin/ebuild.sh4
-rwxr-xr-xbin/emerge4
-rwxr-xr-xbin/emergehelp.py8
-rwxr-xr-xbin/repoman4
-rw-r--r--cnf/make.conf6
-rw-r--r--cnf/make.conf.alpha4
-rw-r--r--cnf/make.conf.arm4
-rw-r--r--cnf/make.conf.hppa4
-rw-r--r--cnf/make.conf.mips4
-rw-r--r--cnf/make.conf.ppc4
-rw-r--r--cnf/make.conf.sparc4
-rw-r--r--pym/portage.py6
12 files changed, 29 insertions, 27 deletions
diff --git a/bin/ebuild.sh b/bin/ebuild.sh
index 494cb4f..e50dad1 100755
--- a/bin/ebuild.sh
+++ b/bin/ebuild.sh
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/bin/ebuild.sh,v 1.113 2003/02/26 11:24:14 carpaski Exp $
+# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/bin/ebuild.sh,v 1.114 2003/02/27 11:31:00 carpaski Exp $
if [ -n "$#" ]
then
@@ -987,8 +987,8 @@ if [ "$*" != "depend" ] && [ "$*" != "clean" ]; then
if [ -z "${PATH/*distcc*/}" ]; then
# Remove the other reference.
PATH="$(echo ${PATH} | sed 's/:[^:]*distcc[^:]*:/:/;s/^[^:]*distcc[^:]*://;s/:[^:]*distcc[^:]*$//')"
- export PATH="/usr/lib/distcc/bin:${PATH}"
fi
+ export PATH="/usr/lib/distcc/bin:${PATH}"
[ -z "${DISTCC_HOSTS}" ] && DISTCC_HOSTS="localhost"
[ ! -z "${DISTCC_LOG}" ] && addwrite "$(dirname ${DISTCC_LOG})"
export DISTCC_HOSTS
diff --git a/bin/emerge b/bin/emerge
index 9c4c889..19f571d 100755
--- a/bin/emerge
+++ b/bin/emerge
@@ -1,7 +1,7 @@
#!/usr/bin/env python2.2
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/bin/emerge,v 1.195 2003/02/26 16:21:58 alain Exp $
+# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/bin/emerge,v 1.196 2003/02/27 11:31:00 carpaski Exp $
import os,sys,portage,emergehelp,xpak,string,re,commands,time,threading,shutil,traceback
from stat import *
@@ -1673,7 +1673,7 @@ elif "unmerge"==myaction or "prune"==myaction or "clean"==myaction:
elif "depclean"==myaction:
# Kill packages that aren't explicitly merged or are required as a
- # dependancy of another package. World file is explicit.
+ # dependency of another package. World file is explicit.
print
print red("*** WARNING ***")+" : DEPCLEAN CAN SERIOUSLY IMPAIR YOUR SYSTEM. USE CAUTION."
diff --git a/bin/emergehelp.py b/bin/emergehelp.py
index 773e718..90771a2 100755
--- a/bin/emergehelp.py
+++ b/bin/emergehelp.py
@@ -1,7 +1,7 @@
#!/usr/bin/env python2.2
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/bin/Attic/emergehelp.py,v 1.10 2003/02/26 16:44:14 alain Exp $
+# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/bin/Attic/emergehelp.py,v 1.11 2003/02/27 11:31:00 carpaski Exp $
import os,sys
from output import *
@@ -65,7 +65,7 @@ def help(myaction,myopts,havecolor=1):
print " "+green("depclean")
print " Cleans the system by removing packages that are not associated"
print " with explicitly merged packages. Depclean works by creating the"
- print " full dependancy tree from the system list and the world file,"
+ print " full dependency tree from the system list and the world file,"
print " then comparing it to installed packages. Packages installed, but"
print " not associated with an explicit merge are listed as candidates"
print " for unmerging."+turquoise(" WARNING: This can seriously affect your system by")
@@ -96,7 +96,7 @@ def help(myaction,myopts,havecolor=1):
print " The argument format is the same as for the "+bold("clean")+" action."
print
print " "+green("regen")
- print " Causes portage to check and update the dependancy cache of all"
+ print " Causes portage to check and update the dependency cache of all"
print " ebuilds in the portage tree. This is not recommended for rsync"
print " users as rsync updates the cache using server-side caches."
print " Rsync users should simply 'emerge sync' to regenerate."
@@ -235,7 +235,7 @@ def help(myaction,myopts,havecolor=1):
print " "+green("--usepkgonly")+" ("+green("-K")+" short option)"
print " Like --usepkg above, except this only allows the use of binary"
print " packages, and it will abort the emerge if the package is not"
- print " available at the time of dependancy calculation."
+ print " available at the time of dependency calculation."
print
print " "+green("--verbose")+" ("+green("-v")+" short option)"
print " Tell emerge to run in verbose mode."
diff --git a/bin/repoman b/bin/repoman
index 3bb409e..b57cefa 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -2,7 +2,7 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Author: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/bin/repoman,v 1.10 2003/02/24 14:48:13 alain Exp $
+# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/bin/repoman,v 1.11 2003/02/27 11:31:00 carpaski Exp $
# Next to do: dep syntax checking in ebuilds, mask files
# Then, check to make sure deps are satisfiable (to avoid "can't find match for" problems)
@@ -271,7 +271,7 @@ for x in scanlist:
stats["ebuild.namenomatch"]=stats["ebuild.namenomatch"]+1
fails["ebuild.namenomatch"].append(x+"/"+y+".ebuild")
try:
- myaux=portage.db["/"]["porttree"].dbapi.aux_get(catdir+"/"+y,allvars,strict=1)
+ myaux=portage.db["/"]["porttree"].dbapi.aux_get(catdir+"/"+y,allvars,strict=1)
except KeyError:
stats["ebuild.syntax"]=stats["ebuild.syntax"]+1
fails["ebuild.syntax"].append(x+"/"+y+".ebuild")
diff --git a/cnf/make.conf b/cnf/make.conf
index 6af4e57..147bbf6 100644
--- a/cnf/make.conf
+++ b/cnf/make.conf
@@ -1,6 +1,6 @@
# Copyright 2000-2003 Daniel Robbins, Gentoo Technologies, Inc.
# Contains local system settings for Portage system
-# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/cnf/make.conf,v 1.54 2003/02/26 11:24:15 carpaski Exp $
+# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/cnf/make.conf,v 1.55 2003/02/27 11:31:00 carpaski Exp $
# Please review 'man make.conf' for more information.
@@ -140,7 +140,7 @@ CXXFLAGS="${CFLAGS}"
#RESUMECOMMAND="/usr/bin/wget -c -t 5 --passive-ftp \${URI} -P \${DISTDIR}"
#
# Using wget, ratelimiting downloads
-#FETCHCOMMAND="/usr/bin/wget -t 5 --passive-ftp \${URI} -P \${DISTDIR}"
+#FETCHCOMMAND="/usr/bin/wget -t 5 --passive-ftp --limit-rate=200k \${URI} -P \${DISTDIR}"
#RESUMECOMMAND="/usr/bin/wget -c -t 5 --passive-ftp --limit-rate=200k \${URI} -P \${DISTDIR}"
#
# Lukemftp (BSD ftp):
@@ -213,7 +213,7 @@ CXXFLAGS="${CFLAGS}"
#
# RSYNC_EXCLUDEFROM is a file that portage will pass to rsync when it updates
# the portage tree. Specific chucks of the tree may be excluded from
-# consideration. This may cause dependancy failures if you are not careful.
+# consideration. This may cause dependency failures if you are not careful.
# The file format is one pattern per line, blanks and ';' or '#' lines are
# comments. See 'man rsync' for more details on the exclude-from format.
#RSYNC_EXCLUDEFROM=/etc/portage/rsync_excludes
diff --git a/cnf/make.conf.alpha b/cnf/make.conf.alpha
index 7cea9bf..8707829 100644
--- a/cnf/make.conf.alpha
+++ b/cnf/make.conf.alpha
@@ -1,6 +1,6 @@
# Copyright 2000-2003 Daniel Robbins, Gentoo Technologies, Inc.
# Contains local system settings for Portage system
-# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/cnf/make.conf.alpha,v 1.15 2003/02/26 11:26:04 carpaski Exp $
+# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/cnf/make.conf.alpha,v 1.16 2003/02/27 11:31:00 carpaski Exp $
# Please review 'man make.conf' for more information.
@@ -203,7 +203,7 @@ CXXFLAGS="${CFLAGS}"
#
# RSYNC_EXCLUDEFROM is a file that portage will pass to rsync when it updates
# the portage tree. Specific chucks of the tree may be excluded from
-# consideration. This may cause dependancy failures if you are not careful.
+# consideration. This may cause dependency failures if you are not careful.
# The file format is one pattern per line, blanks and ';' or '#' lines are
# comments. See 'man rsync' for more details on the exclude-from format.
#RSYNC_EXCLUDEFROM=/etc/portage/rsync_excludes
diff --git a/cnf/make.conf.arm b/cnf/make.conf.arm
index aa6a585..c591e09 100644
--- a/cnf/make.conf.arm
+++ b/cnf/make.conf.arm
@@ -1,6 +1,6 @@
# Copyright 2000-2003 Daniel Robbins, Gentoo Technologies, Inc.
# Contains local system settings for Portage system
-# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/cnf/make.conf.arm,v 1.4 2003/02/26 11:26:04 carpaski Exp $
+# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/cnf/make.conf.arm,v 1.5 2003/02/27 11:31:00 carpaski Exp $
# Please review 'man make.conf' for more information.
@@ -207,7 +207,7 @@ CHOST="armv4l-unknown-linux-gnu"
#
# RSYNC_EXCLUDEFROM is a file that portage will pass to rsync when it updates
# the portage tree. Specific chucks of the tree may be excluded from
-# consideration. This may cause dependancy failures if you are not careful.
+# consideration. This may cause dependency failures if you are not careful.
# The file format is one pattern per line, blanks and ';' or '#' lines are
# comments. See 'man rsync' for more details on the exclude-from format.
#RSYNC_EXCLUDEFROM=/etc/portage/rsync_excludes
diff --git a/cnf/make.conf.hppa b/cnf/make.conf.hppa
index 77d8cab..3292af8 100644
--- a/cnf/make.conf.hppa
+++ b/cnf/make.conf.hppa
@@ -1,6 +1,6 @@
# Copyright 2000-2003 Daniel Robbins, Gentoo Technologies, Inc.
# Contains local system settings for Portage system
-# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/cnf/make.conf.hppa,v 1.9 2003/02/26 11:26:04 carpaski Exp $
+# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/cnf/make.conf.hppa,v 1.10 2003/02/27 11:31:00 carpaski Exp $
# Please review 'man make.conf' for more information.
@@ -200,7 +200,7 @@ CXXFLAGS="${CFLAGS}"
#
# RSYNC_EXCLUDEFROM is a file that portage will pass to rsync when it updates
# the portage tree. Specific chucks of the tree may be excluded from
-# consideration. This may cause dependancy failures if you are not careful.
+# consideration. This may cause dependency failures if you are not careful.
# The file format is one pattern per line, blanks and ';' or '#' lines are
# comments. See 'man rsync' for more details on the exclude-from format.
#RSYNC_EXCLUDEFROM=/etc/portage/rsync_excludes
diff --git a/cnf/make.conf.mips b/cnf/make.conf.mips
index a7e4cb0..b1cbd52 100644
--- a/cnf/make.conf.mips
+++ b/cnf/make.conf.mips
@@ -1,6 +1,6 @@
# Copyright 2000-2003 Daniel Robbins, Gentoo Technologies, Inc.
# Contains local system settings for Portage system
-# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/cnf/make.conf.mips,v 1.13 2003/02/26 11:26:04 carpaski Exp $
+# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/cnf/make.conf.mips,v 1.14 2003/02/27 11:31:00 carpaski Exp $
# Please review 'man make.conf' for more information.
@@ -199,7 +199,7 @@ CXXFLAGS="${CFLAGS}"
#
# RSYNC_EXCLUDEFROM is a file that portage will pass to rsync when it updates
# the portage tree. Specific chucks of the tree may be excluded from
-# consideration. This may cause dependancy failures if you are not careful.
+# consideration. This may cause dependency failures if you are not careful.
# The file format is one pattern per line, blanks and ';' or '#' lines are
# comments. See 'man rsync' for more details on the exclude-from format.
#RSYNC_EXCLUDEFROM=/etc/portage/rsync_excludes
diff --git a/cnf/make.conf.ppc b/cnf/make.conf.ppc
index 7b67eb2..943b0b5 100644
--- a/cnf/make.conf.ppc
+++ b/cnf/make.conf.ppc
@@ -1,6 +1,6 @@
# Copyright 2000-2003 Daniel Robbins, Gentoo Technologies, Inc.
# Contains local system settings for Portage system
-# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/cnf/make.conf.ppc,v 1.32 2003/02/26 11:26:04 carpaski Exp $
+# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/cnf/make.conf.ppc,v 1.33 2003/02/27 11:31:00 carpaski Exp $
# Please review 'man make.conf' for more information.
@@ -234,7 +234,7 @@ CXXFLAGS="${CFLAGS}"
#
# RSYNC_EXCLUDEFROM is a file that portage will pass to rsync when it updates
# the portage tree. Specific chucks of the tree may be excluded from
-# consideration. This may cause dependancy failures if you are not careful.
+# consideration. This may cause dependency failures if you are not careful.
# The file format is one pattern per line, blanks and ';' or '#' lines are
# comments. See 'man rsync' for more details on the exclude-from format.
#RSYNC_EXCLUDEFROM=/etc/portage/rsync_excludes
diff --git a/cnf/make.conf.sparc b/cnf/make.conf.sparc
index 0fd23b5..1546719 100644
--- a/cnf/make.conf.sparc
+++ b/cnf/make.conf.sparc
@@ -1,6 +1,6 @@
# Copyright 2000-2003 Daniel Robbins, Gentoo Technologies, Inc.
# Contains local system settings for Portage system
-# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/cnf/make.conf.sparc,v 1.17 2003/02/26 11:26:04 carpaski Exp $
+# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/cnf/make.conf.sparc,v 1.18 2003/02/27 11:31:00 carpaski Exp $
# Please review 'man make.conf' for more information.
@@ -224,7 +224,7 @@ CXXFLAGS="${CFLAGS}"
#
# RSYNC_EXCLUDEFROM is a file that portage will pass to rsync when it updates
# the portage tree. Specific chucks of the tree may be excluded from
-# consideration. This may cause dependancy failures if you are not careful.
+# consideration. This may cause dependency failures if you are not careful.
# The file format is one pattern per line, blanks and ';' or '#' lines are
# comments. See 'man rsync' for more details on the exclude-from format.
#RSYNC_EXCLUDEFROM=/etc/portage/rsync_excludes
diff --git a/pym/portage.py b/pym/portage.py
index a90e748..0d066b8 100644
--- a/pym/portage.py
+++ b/pym/portage.py
@@ -1,7 +1,7 @@
# portage.py -- core Portage functionality
# Copyright 1998-2002 Daniel Robbins, Gentoo Technologies, Inc.
# Distributed under the GNU Public License v2
-# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/pym/portage.py,v 1.299 2003/02/27 05:14:24 jhhudso Exp $
+# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/pym/portage.py,v 1.300 2003/02/27 11:31:00 carpaski Exp $
VERSION="2.0.47-r6"
@@ -3014,7 +3014,7 @@ class portdbapi(dbapi):
try:
emtime=os.stat(myebuild)[ST_MTIME]
except:
- return None
+ raise KeyError
# first, we take a look at the size of the ebuild/cache entry to ensure we
# have a valid data, then we look at the mtime of the ebuild and the
@@ -4282,6 +4282,8 @@ os.umask(022)
profiledir=None
if os.path.exists("/etc/make.profile/make.defaults"):
profiledir="/etc/make.profile"
+else:
+ print ">>> Note: /etc/make.profile/make.defaults isn't available; an 'emerge sync' will probably fix this."
#from here on in we can assume that profiledir is set to something valid
db={}