summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-20 18:05:38 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-20 18:05:38 +0000
commit15a612bc67e292d9debb2dfea92564b99bf73954 (patch)
tree456f9c06e57671756d87ba8ab263a4bd8056c773
parentadded pax-mark -p for USE=jit per bug 519068 (diff)
downloadgentoo-2-15a612bc67e292d9debb2dfea92564b99bf73954.tar.gz
gentoo-2-15a612bc67e292d9debb2dfea92564b99bf73954.tar.bz2
gentoo-2-15a612bc67e292d9debb2dfea92564b99bf73954.zip
sci-chemistry/pymol: Version Bump
(Portage version: 2.2.14/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key B9D4F231BD1558AB!)
-rw-r--r--sci-chemistry/pymol/ChangeLog8
-rw-r--r--sci-chemistry/pymol/files/pymol-9999-listing.patch17
-rw-r--r--sci-chemistry/pymol/files/pymol-9999-options.patch15
-rw-r--r--sci-chemistry/pymol/pymol-1.7.3.2.ebuild108
4 files changed, 147 insertions, 1 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index eadece7d5c3c..dc98cebe003d 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/pymol
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.119 2014/10/17 06:54:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.120 2014/10/20 18:05:38 jlec Exp $
+
+*pymol-1.7.3.2 (20 Oct 2014)
+
+ 20 Oct 2014; Justin Lecher <jlec@gentoo.org> +pymol-1.7.3.2.ebuild,
+ +files/pymol-9999-listing.patch, +files/pymol-9999-options.patch:
+ Version Bump
*pymol-1.7.3.1 (17 Oct 2014)
diff --git a/sci-chemistry/pymol/files/pymol-9999-listing.patch b/sci-chemistry/pymol/files/pymol-9999-listing.patch
new file mode 100644
index 000000000000..1b4039c560a6
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-9999-listing.patch
@@ -0,0 +1,17 @@
+ pymol/modules/pymol/plugins/repository.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/pymol/modules/pymol/plugins/repository.py b/pymol/modules/pymol/plugins/repository.py
+index 9697f68..9820fac 100644
+--- a/pymol/modules/pymol/plugins/repository.py
++++ b/pymol/modules/pymol/plugins/repository.py
+@@ -182,7 +182,8 @@ class GithubRepository(HttpRepository):
+
+ def fetchjson(self, url):
+ handle = urlopen('https://api.github.com' + url)
+- return eval(handle.read())
++ ret = handle.read().replace("false", "False")
++ return eval(ret)
+
+ class LocalRepository(Repository):
+ def __init__(self, url):
diff --git a/sci-chemistry/pymol/files/pymol-9999-options.patch b/sci-chemistry/pymol/files/pymol-9999-options.patch
new file mode 100644
index 000000000000..ce05e172e6bb
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-9999-options.patch
@@ -0,0 +1,15 @@
+ pymol/setup.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/pymol/setup.py b/pymol/setup.py
+index c446d6c..b7b353b 100644
+--- a/pymol/setup.py
++++ b/pymol/setup.py
+@@ -51,6 +51,7 @@ def CCompiler_compile(self, sources, output_dir=None, macros=None,
+ class options:
+ osx_frameworks = False
+ jobs = int(os.getenv('JOBS', 0))
++ no_libxml = False
+
+ try:
+ import argparse
diff --git a/sci-chemistry/pymol/pymol-1.7.3.2.ebuild b/sci-chemistry/pymol/pymol-1.7.3.2.ebuild
new file mode 100644
index 000000000000..8a7bfbccfbdd
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-1.7.3.2.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.7.3.2.ebuild,v 1.1 2014/10/20 18:05:38 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1 fdo-mime versionator
+
+DESCRIPTION="A Python-extensible molecular graphics system"
+HOMEPAGE="http://www.pymol.org/"
+SRC_URI="
+ http://dev.gentoo.org/~jlec/distfiles/${PN}-1.7.0.0.png.xz
+ http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz
+"
+# mirror://sourceforge/project/${PN}/${PN}/$(get_version_component_range 1-2)/${PN}-v${PV}.tar.bz2
+# git archive -v --prefix=${P}/ master -o ${P}.tar.xz
+
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="apbs web"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pmw[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ media-libs/freetype:2
+ media-libs/glew
+ media-libs/libpng
+ media-video/mpeg-tools
+ sys-libs/zlib
+ media-libs/freeglut
+ apbs? (
+ sci-chemistry/apbs
+ sci-chemistry/pdb2pqr
+ sci-chemistry/pymol-apbs-plugin[${PYTHON_USEDEP}]
+ )
+ web? ( !dev-python/webpy[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${P}/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.3.1-maeffplugin.cpp.patch
+ "${FILESDIR}"/${PN}-9999-options.patch
+ "${FILESDIR}"/${PN}-9999-listing.patch
+ )
+
+python_prepare_all() {
+ sed \
+ -e "s:\"/usr:\"${EPREFIX}/usr:g" \
+ -e "/ext_comp_args.*+=/s:\[.*\]$:\[\]:g" \
+ -e "/import/s:argparse:argparseX:g" \
+ -i setup.py || die
+
+ rm ./modules/pmg_tk/startup/apbs_tools.py || die
+
+ sed \
+ -e "s:/opt/local:${EPREFIX}/usr:g" \
+ -e '/ext_comp_args/s:\[.*\]:[]:g' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install --pymol-path="${EPREFIX}/usr/share/pymol"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ python_export python2_7 EPYTHON
+
+ # These environment variables should not go in the wrapper script, or else
+ # it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol <<- EOF
+ PYMOL_PATH="$(python_get_sitedir)/${PN}"
+ PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
+ PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
+ EOF
+
+ doenvd "${T}"/20pymol
+
+ newicon "${WORKDIR}"/${PN}-1.7.0.0.png ${PN}.png
+ make_desktop_entry ${PN} PyMol ${PN} \
+ "Graphics;Education;Science;Chemistry;" \
+ "MimeType=chemical/x-pdb;chemical/x-mdl-molfile;chemical/x-mol2;chemical/seq-aa-fasta;chemical/seq-na-fasta;chemical/x-xyz;chemical/x-mdl-sdf;"
+
+ if ! use web; then
+ rm -rf "${D}/$(python_get_sitedir)/web" || die
+ fi
+
+ rm -f "${ED}"/usr/share/${PN}/LICENSE || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}