summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-08-18 10:11:50 +0000
committerVlastimil Babka <caster@gentoo.org>2009-08-18 10:11:50 +0000
commit7cde816ce9e67810365ae0836c91d240a98e8c87 (patch)
tree845e0074875c162ceadba758b10442baf1055281
parentVersion bump, fixes JDWP threadid problems. Remove old. (diff)
downloadgentoo-2-7cde816ce9e67810365ae0836c91d240a98e8c87.tar.gz
gentoo-2-7cde816ce9e67810365ae0836c91d240a98e8c87.tar.bz2
gentoo-2-7cde816ce9e67810365ae0836c91d240a98e8c87.zip
Version bump, fixes JDWP threadid problems. Remove old.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
-rw-r--r--app-emulation/emul-linux-x86-java/ChangeLog12
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.18.ebuild100
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.19.ebuild100
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.13.ebuild110
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.16.ebuild (renamed from app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.14.ebuild)2
5 files changed, 12 insertions, 312 deletions
diff --git a/app-emulation/emul-linux-x86-java/ChangeLog b/app-emulation/emul-linux-x86-java/ChangeLog
index 2016bf55280a..668e237dc31f 100644
--- a/app-emulation/emul-linux-x86-java/ChangeLog
+++ b/app-emulation/emul-linux-x86-java/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-emulation/emul-linux-x86-java
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/ChangeLog,v 1.76 2009/08/11 05:57:35 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/ChangeLog,v 1.77 2009/08/18 10:11:50 caster Exp $
+
+*emul-linux-x86-java-1.6.0.16 (18 Aug 2009)
+
+ 18 Aug 2009; Vlastimil Babka <caster@gentoo.org>
+ -emul-linux-x86-java-1.5.0.18.ebuild,
+ -emul-linux-x86-java-1.5.0.19.ebuild,
+ -emul-linux-x86-java-1.6.0.13.ebuild,
+ -emul-linux-x86-java-1.6.0.14.ebuild,
+ +emul-linux-x86-java-1.6.0.16.ebuild:
+ Version bump, fixes JDWP threadid problems. Remove old.
11 Aug 2009; Markus Meier <maekke@gentoo.org>
emul-linux-x86-java-1.5.0.20.ebuild:
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.18.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.18.ebuild
deleted file mode 100644
index 5d1ab13482ca..000000000000
--- a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.18.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.18.ebuild,v 1.4 2009/05/29 20:34:25 caster Exp $
-
-inherit versionator pax-utils eutils java-vm-2
-
-UPDATE="$(get_version_component_range 4)"
-UPDATE="${UPDATE#0}"
-MY_PV="$(get_version_component_range 2-3)u${UPDATE}"
-
-At="jdk-${MY_PV}-dlj-linux-i586.bin"
-DESCRIPTION="Sun's Java SE Runtime Environment (32bit)"
-HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
-SRC_URI="http://download.java.net/dlj/binaries/${At}"
-
-SLOT="1.5"
-LICENSE="dlj-1.1"
-KEYWORDS="-* amd64"
-RESTRICT="strip"
-IUSE="X alsa nsplugin"
-
-JAVA_VM_NO_GENERATION1=true
-
-RDEPEND="alsa? ( app-emulation/emul-linux-x86-soundlibs )
- X? ( app-emulation/emul-linux-x86-xlibs )"
-
-JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
-
-QA_TEXTRELS_amd64="opt/${P}/lib/i386/motif21/libmawt.so
- opt/${P}/lib/i386/libdeploy.so"
-QA_DT_HASH="opt/${P}/.*"
-
-src_unpack() {
- mkdir bundled-jdk
- cd bundled-jdk
- sh "${DISTDIR}"/${At} --accept-license --unpack || die "Failed to unpack"
-
- cd ..
- bash "${FILESDIR}"/construct.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
-}
-
-src_compile() {
- # Set PaX markings on all JDK/JRE executables to allow code-generation on
- # the heap by the JIT compiler. This has to be done before CDS - #215225
- pax-mark m $(list-paxables "${S}"/bin/*)
-
- # see bug #207282
- einfo "Creating the Class Data Sharing archives"
- "${S}"/bin/java -client -Xshare:dump || die
-}
-
-src_install() {
- dodir /opt/${P}
- cp -pPR bin lib man javaws plugin "${D}/opt/${P}/" || die "failed to copy"
-
- dodoc CHANGES README THIRDPARTYLICENSEREADME.txt || die
- dohtml Welcome.html || die
-
- if use nsplugin; then
- local plugin_dir="ns7-gcc29"
- if has_version '>=sys-devel/gcc-3' ; then
- plugin_dir="ns7"
- fi
-
- install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
- fi
-
- # FIXME figure out how to handle the control pannel conflict with
- # sun-jdk-bin
-
- # install control panel for Gnome/KDE
-# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
-# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
-# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
-# ${T}/sun_java-${SLOT}.desktop
-
-# domenu ${T}/sun_java-${SLOT}.desktop
-
- set_java_env
- java-vm_revdep-mask
-}
-
-pkg_postinst() {
- # Set as default VM if none exists
- java-vm-2_pkg_postinst
-
- if ! use X; then
- local xwarn="X11 libraries and/or"
- fi
-
- echo
- ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
- ewarn "Be careful which Java libraries you attempt to use."
-
- echo
- elog "Beginning with 1.5.0.10 the hotspot vm can use epoll"
- elog "The epoll-based implementation of SelectorProvider is not selected by"
- elog "default."
- elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
-}
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.19.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.19.ebuild
deleted file mode 100644
index 68b893cda580..000000000000
--- a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.19.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.19.ebuild,v 1.2 2009/08/02 13:12:44 maekke Exp $
-
-inherit versionator pax-utils eutils java-vm-2
-
-UPDATE="$(get_version_component_range 4)"
-UPDATE="${UPDATE#0}"
-MY_PV="$(get_version_component_range 2-3)u${UPDATE}"
-
-At="jdk-${MY_PV}-dlj-linux-i586.bin"
-DESCRIPTION="Sun's Java SE Runtime Environment (32bit)"
-HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
-SRC_URI="http://download.java.net/dlj/binaries/${At}"
-
-SLOT="1.5"
-LICENSE="dlj-1.1"
-KEYWORDS="-* amd64"
-RESTRICT="strip"
-IUSE="X alsa nsplugin"
-
-JAVA_VM_NO_GENERATION1=true
-
-RDEPEND="alsa? ( app-emulation/emul-linux-x86-soundlibs )
- X? ( app-emulation/emul-linux-x86-xlibs )"
-
-JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
-
-QA_TEXTRELS_amd64="opt/${P}/lib/i386/motif21/libmawt.so
- opt/${P}/lib/i386/libdeploy.so"
-QA_DT_HASH="opt/${P}/.*"
-
-src_unpack() {
- mkdir bundled-jdk
- cd bundled-jdk
- sh "${DISTDIR}"/${At} --accept-license --unpack || die "Failed to unpack"
-
- cd ..
- bash "${FILESDIR}"/construct.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
-}
-
-src_compile() {
- # Set PaX markings on all JDK/JRE executables to allow code-generation on
- # the heap by the JIT compiler. This has to be done before CDS - #215225
- pax-mark m $(list-paxables "${S}"/bin/*)
-
- # see bug #207282
- einfo "Creating the Class Data Sharing archives"
- "${S}"/bin/java -client -Xshare:dump || die
-}
-
-src_install() {
- dodir /opt/${P}
- cp -pPR bin lib man javaws plugin "${D}/opt/${P}/" || die "failed to copy"
-
- dodoc CHANGES README THIRDPARTYLICENSEREADME.txt || die
- dohtml Welcome.html || die
-
- if use nsplugin; then
- local plugin_dir="ns7-gcc29"
- if has_version '>=sys-devel/gcc-3' ; then
- plugin_dir="ns7"
- fi
-
- install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
- fi
-
- # FIXME figure out how to handle the control pannel conflict with
- # sun-jdk-bin
-
- # install control panel for Gnome/KDE
-# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
-# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
-# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
-# ${T}/sun_java-${SLOT}.desktop
-
-# domenu ${T}/sun_java-${SLOT}.desktop
-
- set_java_env
- java-vm_revdep-mask
-}
-
-pkg_postinst() {
- # Set as default VM if none exists
- java-vm-2_pkg_postinst
-
- if ! use X; then
- local xwarn="X11 libraries and/or"
- fi
-
- echo
- ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
- ewarn "Be careful which Java libraries you attempt to use."
-
- echo
- elog "Beginning with 1.5.0.10 the hotspot vm can use epoll"
- elog "The epoll-based implementation of SelectorProvider is not selected by"
- elog "default."
- elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
-}
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.13.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.13.ebuild
deleted file mode 100644
index c6632a810951..000000000000
--- a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.13.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.13.ebuild,v 1.4 2009/05/29 20:34:25 caster Exp $
-
-inherit versionator pax-utils java-vm-2 eutils
-
-UPDATE="$(get_version_component_range 4)"
-UPDATE="${UPDATE#0}"
-MY_PV="$(get_version_component_range 2)u${UPDATE}"
-
-At="jdk-${MY_PV}-dlj-linux-i586.bin"
-DESCRIPTION="Sun's Java SE Runtime Environment (32bit)"
-HOMEPAGE="http://java.sun.com/javase/6/"
-#SRC_URI="http://download.java.net/dlj/binaries/${At}"
-SRC_URI="http://dlc.sun.com/dlj/binaries/${At}"
-
-SLOT="1.6"
-LICENSE="dlj-1.1"
-KEYWORDS="-* amd64"
-RESTRICT="strip"
-IUSE="X alsa nsplugin"
-
-JAVA_VM_NO_GENERATION1=true
-
-RDEPEND="alsa? ( app-emulation/emul-linux-x86-soundlibs )
- X? ( app-emulation/emul-linux-x86-xlibs )
- app-emulation/emul-linux-x86-compat"
-
-JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
-
-QA_TEXTRELS_amd64="opt/${P}/lib/i386/motif21/libmawt.so
- opt/${P}/lib/i386/libdeploy.so
- opt/${P}/lib/i386/client/libjvm.so
- opt/${P}/lib/i386/server/libjvm.so"
-QA_DT_HASH="opt/${P}/.*"
-
-src_unpack() {
- mkdir bundled-jdk
- cd bundled-jdk
- sh "${DISTDIR}"/${At} --accept-license --unpack || die "Failed to unpack"
-
- cd ..
- bash "${FILESDIR}"/construct-${SLOT}.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct-${SLOT}.sh failed"
-}
-
-src_compile() {
- # Set PaX markings on all JDK/JRE executables to allow code-generation on
- # the heap by the JIT compiler. This has to be done before CDS - #215225
- pax-mark m $(list-paxables "${S}"/bin/*)
-
- # see bug #207282
- einfo "Creating the Class Data Sharing archives"
- "${S}"/bin/java -client -Xshare:dump || die
- "${S}"/bin/java -server -Xshare:dump || die
-}
-
-src_install() {
- local dirs="bin lib man javaws plugin"
- dodir /opt/${P}
-
- cp -pPR ${dirs} "${D}/opt/${P}/" || die "failed to copy"
-
- dodoc README THIRDPARTYLICENSEREADME.txt || die
- dohtml Welcome.html || die
- dodir /opt/${P}/share/
-
- if use nsplugin; then
- local plugin_dir="ns7-gcc29"
- if has_version '>=sys-devel/gcc-3' ; then
- plugin_dir="ns7"
- fi
-
- install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
- install_mozilla_plugin /opt/${P}/lib/i386/libnpjp2.so plugin2
- fi
-
- # FIXME figure out how to handle the control pannel conflict with
- # sun-jdk-bin
-
- # install control panel for Gnome/KDE
-# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
-# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
-# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
-# ${T}/sun_java-${SLOT}.desktop
-
-# domenu ${T}/sun_java-${SLOT}.desktop
-
- set_java_env
- java-vm_revdep-mask
-}
-
-pkg_postinst() {
- # Set as default VM if none exists
- java-vm-2_pkg_postinst
-
- elog
- elog "Two variants of the nsplugin are available via eselect java-nsplugin:"
- elog "${VMHANDLE} and ${VMHANDLE}-plugin2 (the Next-Generation Plug-In) "
- ewarn "Note that the ${VMHANDLE}-plugin2 works only in Firefox 3!"
- elog "For more info see https://jdk6.dev.java.net/plugin2/"
- elog
-
- if ! use X; then
- local xwarn="X11 libraries and/or"
- fi
-
- echo
- ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
- ewarn "Be careful which Java libraries you attempt to use."
-}
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.14.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.16.ebuild
index 78052e09d3c7..9b7ffa030fc4 100644
--- a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.14.ebuild
+++ b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.14.ebuild,v 1.1 2009/05/31 11:26:36 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.16.ebuild,v 1.1 2009/08/18 10:11:50 caster Exp $
inherit versionator pax-utils java-vm-2 eutils