summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-11 13:19:02 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-11 13:19:02 +0000
commite7ce8a33b5145e8d6394c8ca26708a50521ddad5 (patch)
tree73fb285449e658de6845a470a05d41d492c8fcfe
parentvanilla-3.11.7 + genpatches-3.11-10 + grsecurity-2.9.1-3.11.7-201311071634 (diff)
downloadgentoo-2-e7ce8a33b5145e8d6394c8ca26708a50521ddad5.tar.gz
gentoo-2-e7ce8a33b5145e8d6394c8ca26708a50521ddad5.tar.bz2
gentoo-2-e7ce8a33b5145e8d6394c8ca26708a50521ddad5.zip
Add ruby20 target. Cleanup old.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
-rw-r--r--dev-ruby/unf/ChangeLog8
-rw-r--r--dev-ruby/unf/unf-0.1.3-r1.ebuild (renamed from dev-ruby/unf/unf-0.1.2.ebuild)4
-rw-r--r--dev-ruby/unf/unf-0.1.3.ebuild57
3 files changed, 9 insertions, 60 deletions
diff --git a/dev-ruby/unf/ChangeLog b/dev-ruby/unf/ChangeLog
index 4cc74a79cdf0..f1c61fa2b14c 100644
--- a/dev-ruby/unf/ChangeLog
+++ b/dev-ruby/unf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/unf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf/ChangeLog,v 1.12 2013/10/27 06:43:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf/ChangeLog,v 1.13 2013/11/11 13:19:01 mrueg Exp $
+
+*unf-0.1.3-r1 (11 Nov 2013)
+
+ 11 Nov 2013; Manuel Rüger <mrueg@gentoo.org> +unf-0.1.3-r1.ebuild,
+ -unf-0.1.2.ebuild, -unf-0.1.3.ebuild:
+ Add ruby20 target. Cleanup old.
*unf-0.1.3 (27 Oct 2013)
diff --git a/dev-ruby/unf/unf-0.1.2.ebuild b/dev-ruby/unf/unf-0.1.3-r1.ebuild
index 42285b67dc46..d955cec96160 100644
--- a/dev-ruby/unf/unf-0.1.2.ebuild
+++ b/dev-ruby/unf/unf-0.1.3-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf/unf-0.1.2.ebuild,v 1.1 2013/08/18 12:39:34 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf/unf-0.1.3-r1.ebuild,v 1.1 2013/11/11 13:19:01 mrueg Exp $
EAPI=5
-USE_RUBY="ruby18 ruby19 jruby"
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
RUBY_FAKEGEM_RECIPE_TEST="none"
RUBY_FAKEGEM_TASK_DOC=""
diff --git a/dev-ruby/unf/unf-0.1.3.ebuild b/dev-ruby/unf/unf-0.1.3.ebuild
deleted file mode 100644
index 3d9c065604bb..000000000000
--- a/dev-ruby/unf/unf-0.1.3.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf/unf-0.1.3.ebuild,v 1.1 2013/10/27 06:43:46 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_RECIPE_TEST="none"
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A wrapper library to bring Unicode Normalization Form support to Ruby/JRuby."
-HOMEPAGE="https://github.com/knu/ruby-unf"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE="test"
-
-# jruby already has support for UNF so it does not need the extension.
-USE_RUBY=${USE_RUBY/jruby/} ruby_add_rdepend "dev-ruby/unf_ext"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/test-unit-2.5.1-r1
- dev-ruby/shoulda
- )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/,/end/ d' test/helper.rb || die
-
- # Remove development dependencies; also remove platform as we don't
- # care about it as it is, they only use it to avoid the unf_ext dep
- # that we tackle on our own; finally remove git ls-files usage.
- sed -i -e '/dependency.*\(shoulda\|bundler\|jeweler\|rcov\)/d' \
- -e '/platform/d' \
- -e '/git ls/d' \
- ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_prepare() {
- if [[ ${RUBY} == *jruby ]]; then
- # Remove dependency over unf_ext which does not exist for JRuby
- # remove platform, we don't set it.
- sed -i -e '/dependency.*unf_ext/d' \
- ${RUBY_FAKEGEM_GEMSPEC} || die
- fi
-}
-
-each_ruby_test() {
- ruby-ng_testrb-2 test/test_*.rb
-}