summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-14 23:16:01 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-14 23:16:01 +0000
commit05f3ff3dc62c32d1760ff8c3ecf81e4be120d168 (patch)
treec850cac8087d135429a17af3ef0a5255fb3005ad /app-admin/conkyforecast
parentConvert to python-single-r1. (diff)
downloadgentoo-2-05f3ff3dc62c32d1760ff8c3ecf81e4be120d168.tar.gz
gentoo-2-05f3ff3dc62c32d1760ff8c3ecf81e4be120d168.tar.bz2
gentoo-2-05f3ff3dc62c32d1760ff8c3ecf81e4be120d168.zip
Convert to distutils-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-admin/conkyforecast')
-rw-r--r--app-admin/conkyforecast/ChangeLog10
-rw-r--r--app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild45
2 files changed, 52 insertions, 3 deletions
diff --git a/app-admin/conkyforecast/ChangeLog b/app-admin/conkyforecast/ChangeLog
index f2bc25ebe0b7..109c5c624c11 100644
--- a/app-admin/conkyforecast/ChangeLog
+++ b/app-admin/conkyforecast/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/conkyforecast
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conkyforecast/ChangeLog,v 1.4 2012/01/05 15:54:39 xmw Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conkyforecast/ChangeLog,v 1.5 2014/12/14 23:16:01 mgorny Exp $
+
+*conkyforecast-2.24-r1 (14 Dec 2014)
+
+ 14 Dec 2014; Michał Górny <mgorny@gentoo.org> +conkyforecast-2.24-r1.ebuild:
+ Convert to distutils-r1.
*conkyforecast-2.24 (05 Jan 2012)
@@ -23,4 +28,3 @@
+conkyforecast-2.12.ebuild, +metadata.xml:
Initial commit for conkyforecast. Fixes bug #255948, thanks to Hans Meier
for the report and Christopher Robin Elmersson for the initial ebuilds
-
diff --git a/app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild b/app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild
new file mode 100644
index 000000000000..8547eebff7a0
--- /dev/null
+++ b/app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild,v 1.1 2014/12/14 23:16:01 mgorny Exp $
+
+EAPI=5
+
+# upstream broke setup.py to install into /usr/share...
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Conky weather forecast script with support for language files"
+HOMEPAGE="https://launchpad.net/~conky-companions"
+SRC_URI="https://launchpad.net/~conky-companions/+archive/ppa/+files/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-admin/conky"
+
+S=${WORKDIR}/src
+
+python_prepare_all() {
+ sed -i -e "s:pythoncmd=.*$:pythoncmd=${EPYTHON}:" conkyForecast* || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ python_optimize "${ED%/}"/usr/share/${PN}
+}
+
+pkg_postinst() {
+ elog "You have to define a partner id and registration code for "
+ elog "the weather.com xoap. You need to copy the template from"
+ elog "/usr/share/conkyforecast/conkyForecast.config into you account"
+ elog "as ~/.conkyForecast.config and edit the respective fields."
+ elog
+ elog "More details can be found in the README file."
+}