summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2012-12-24 17:52:08 +0000
committerLance Albertson <ramereth@gentoo.org>2012-12-24 17:52:08 +0000
commit0562bec6bba2a3aeeec9e90053214c4e0d834811 (patch)
treea30064e2afce658237d7a2953c2a746869fcd02d /app-emulation/ganeti
parentRemove old patches (diff)
downloadgentoo-2-0562bec6bba2a3aeeec9e90053214c4e0d834811.tar.gz
gentoo-2-0562bec6bba2a3aeeec9e90053214c4e0d834811.tar.bz2
gentoo-2-0562bec6bba2a3aeeec9e90053214c4e0d834811.zip
Fix metadata invariance reported in bug #448432
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 27F4B742)
Diffstat (limited to 'app-emulation/ganeti')
-rw-r--r--app-emulation/ganeti/ChangeLog5
-rw-r--r--app-emulation/ganeti/ganeti-2.6.2.ebuild14
2 files changed, 8 insertions, 11 deletions
diff --git a/app-emulation/ganeti/ChangeLog b/app-emulation/ganeti/ChangeLog
index 3b53ac4e2e7e..46ff317fa9aa 100644
--- a/app-emulation/ganeti/ChangeLog
+++ b/app-emulation/ganeti/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/ganeti
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.67 2012/12/24 07:34:07 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.68 2012/12/24 17:52:08 ramereth Exp $
+
+ 24 Dec 2012; Lance Albertson <ramereth@gentoo.org> ganeti-2.6.2.ebuild:
+ Fix metadata invariance reported in bug #448432
*ganeti-2.6.2 (24 Dec 2012)
*ganeti-2.5.2-r2 (24 Dec 2012)
diff --git a/app-emulation/ganeti/ganeti-2.6.2.ebuild b/app-emulation/ganeti/ganeti-2.6.2.ebuild
index 8fcdc02978c0..efbf52846ffb 100644
--- a/app-emulation/ganeti/ganeti-2.6.2.ebuild
+++ b/app-emulation/ganeti/ganeti-2.6.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.6.2.ebuild,v 1.1 2012/12/24 07:34:07 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.6.2.ebuild,v 1.2 2012/12/24 17:52:08 ramereth Exp $
EAPI="4"
-PYTHON_DEPEND="2"
+PYTHON_DEPEND="2:2.6"
inherit eutils confutils bash-completion-r1 python
@@ -33,17 +33,11 @@ HOMEPAGE="http://code.google.com/p/ganeti/"
LICENSE="GPL-2"
SLOT="0"
IUSE="kvm xen lxc drbd +filestorage sharedstorage htools syslog ipv6
- haskell-daemons rbd"
+ haskell-daemons rbd test"
REQUIRED_USE="|| ( kvm xen lxc )"
S="${WORKDIR}/${MY_P}"
-if use test ; then
- PYTHON_DEPEND=">=dev-lang/python-2.6[ipv6]"
-else
- PYTHON_DEPEND=">=dev-lang/python-2.6"
-fi
-
DEPEND="xen? ( >=app-emulation/xen-3.0 )
kvm? ( app-emulation/qemu )
lxc? ( app-emulation/lxc )
@@ -78,10 +72,10 @@ DEPEND="xen? ( >=app-emulation/xen-3.0 )
sys-apps/iproute2
sys-fs/lvm2
>=sys-apps/baselayout-2.0
- ${PYTHON_DEPEND}
${GIT_DEPEND}"
RDEPEND="${DEPEND}
!app-emulation/ganeti-htools"
+DEPEND+=" test? ( || ( dev-lang/python:2.7[ipv6] dev-lang/python:2.6[ipv6] ) )"
pkg_setup () {
confutils_use_depend_all haskell-daemons htools