summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-04-27 14:27:53 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-04-27 14:27:53 +0000
commitfae5faf6b146baf7f629cc17b929fb32093fcb36 (patch)
tree64ffaa3b8f6681bee1f4e7f120fbee344a921008 /app-emulation/winex-transgaming
parentnew version; bugfixes to dripgetdvd.sh (diff)
downloadgentoo-2-fae5faf6b146baf7f629cc17b929fb32093fcb36.tar.gz
gentoo-2-fae5faf6b146baf7f629cc17b929fb32093fcb36.tar.bz2
gentoo-2-fae5faf6b146baf7f629cc17b929fb32093fcb36.zip
new version
Diffstat (limited to 'app-emulation/winex-transgaming')
-rw-r--r--app-emulation/winex-transgaming/ChangeLog6
-rw-r--r--app-emulation/winex-transgaming/files/digest-winex-transgaming-3.00
-rw-r--r--app-emulation/winex-transgaming/winex-transgaming-3.0.ebuild61
3 files changed, 66 insertions, 1 deletions
diff --git a/app-emulation/winex-transgaming/ChangeLog b/app-emulation/winex-transgaming/ChangeLog
index 07b05afe0e09..6d24b7763a5e 100644
--- a/app-emulation/winex-transgaming/ChangeLog
+++ b/app-emulation/winex-transgaming/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/winex-transgaming
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/ChangeLog,v 1.4 2003/04/06 08:59:29 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/ChangeLog,v 1.5 2003/04/27 14:27:53 lordvan Exp $
+
+*winex-transgaming-3.0 (27 Apr 2003)
+ 27 Apr 2003; Thomas Raschbacher <lordvan@gentoo.org> winex-transgaming-3.0.ebuild:
+ new version + dep for !app-emulation/winex-cvs
06 Apr 2003; phoen][x <phoenix@gentoo.org> winex-transgaming-*.ebuild :
Changed SLOT to reflect the version of winex.
diff --git a/app-emulation/winex-transgaming/files/digest-winex-transgaming-3.0 b/app-emulation/winex-transgaming/files/digest-winex-transgaming-3.0
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/app-emulation/winex-transgaming/files/digest-winex-transgaming-3.0
diff --git a/app-emulation/winex-transgaming/winex-transgaming-3.0.ebuild b/app-emulation/winex-transgaming/winex-transgaming-3.0.ebuild
new file mode 100644
index 000000000000..e36c20bc91a1
--- /dev/null
+++ b/app-emulation/winex-transgaming/winex-transgaming-3.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/winex-transgaming-3.0.ebuild,v 1.1 2003/04/27 14:27:53 lordvan Exp $
+
+IUSE="cups opengl"
+
+MY_P="winex3_${PV}-1.i386"
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+
+SLOT="3"
+KEYWORDS="~x86"
+LICENSE="Aladdin"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ !app-emulation/winex
+ !app-emulation/winex-cvs"
+
+src_unpack () {
+ if [ ! -e "${DISTDIR}/${MY_P}.tgz" ] ; then
+ eerror ""
+ eerror "Please download the appropriate WineX archive (${MY_P}.tgz)"
+ eerror "from: ${HOMEPAGE} (requires a Transgaming subscription)."
+ eerror ""
+ eerror "The archive should be placed into ${DISTDIR}."
+ eerror ""
+
+ die "package archive (${MY_P}.tgz) not found"
+ fi
+ unpack "${MY_P}.tgz"
+}
+
+src_install () {
+ mv "${WORKDIR}/usr" "${D}"
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/winex3 to start winex as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the winex wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/winex:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to /etc/modules.autoload."
+}