summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-26 21:43:46 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-26 21:43:46 +0000
commitbad933fd639d8a8040490074c1cd7f9c0b9222fa (patch)
tree490e151bcfbd2cfd97038632a600bcd0518c2339 /app-misc/ccal
parentExtend gcc mask on hpux, bug 311239 (diff)
downloadgentoo-2-bad933fd639d8a8040490074c1cd7f9c0b9222fa.tar.gz
gentoo-2-bad933fd639d8a8040490074c1cd7f9c0b9222fa.tar.bz2
gentoo-2-bad933fd639d8a8040490074c1cd7f9c0b9222fa.zip
Fix for py3 stabilization, #311517
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/ccal')
-rw-r--r--app-misc/ccal/ChangeLog9
-rw-r--r--app-misc/ccal/ccal-0.6-r1.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/app-misc/ccal/ChangeLog b/app-misc/ccal/ChangeLog
index 9bd5bc9fc562..d6a49ff7a799 100644
--- a/app-misc/ccal/ChangeLog
+++ b/app-misc/ccal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/ccal
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ccal/ChangeLog,v 1.8 2007/01/28 05:00:00 genone Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ccal/ChangeLog,v 1.9 2010/03/26 21:43:46 jlec Exp $
+
+*ccal-0.6-r1 (26 Mar 2010)
+
+ 26 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org> +ccal-0.6-r1.ebuild:
+ Fix for py3 stabilization, #311517
28 Jan 2007; Marius Mauch <genone@gentoo.org> ccal-0.6.ebuild:
Replacing einfo with elog
diff --git a/app-misc/ccal/ccal-0.6-r1.ebuild b/app-misc/ccal/ccal-0.6-r1.ebuild
new file mode 100644
index 000000000000..88d4b4249d4a
--- /dev/null
+++ b/app-misc/ccal/ccal-0.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ccal/ccal-0.6-r1.ebuild,v 1.1 2010/03/26 21:43:46 jlec Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="Curses-based calendar/journal/diary/todo utility"
+HOMEPAGE="http://www.jamiehillman.co.uk/ccal/"
+SRC_URI="mirror://gentoo/${P}.py.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ python_convert_shebangs 2 ${P}.py
+}
+
+src_install() {
+ newbin ${P}.py ${PN} || die "dobin failed"
+ dohtml "${FILESDIR}"/instructions.htm || die "dohtml failed"
+}
+
+pkg_postinst() {
+ echo
+ elog "Read /usr/share/doc/${PF}/html/instructions.htm for"
+ elog "information on using ccal."
+ echo
+}