summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-02-19 13:30:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-02-19 13:30:35 +0000
commit1567a5f37c99b3469e9e3761cf49dc54dddb8252 (patch)
tree95bc662446561dcfeb4a6330a1b7b976f0871591 /app-misc
parentremove old (diff)
downloadgentoo-2-1567a5f37c99b3469e9e3761cf49dc54dddb8252.tar.gz
gentoo-2-1567a5f37c99b3469e9e3761cf49dc54dddb8252.tar.bz2
gentoo-2-1567a5f37c99b3469e9e3761cf49dc54dddb8252.zip
version bump
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ledit/ChangeLog9
-rw-r--r--app-misc/ledit/ledit-2.03.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/app-misc/ledit/ChangeLog b/app-misc/ledit/ChangeLog
index 537d1faa8e8e..18fe606a4fbb 100644
--- a/app-misc/ledit/ChangeLog
+++ b/app-misc/ledit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/ledit
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ChangeLog,v 1.35 2011/01/21 00:32:50 aballier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ChangeLog,v 1.36 2012/02/19 13:30:35 aballier Exp $
+
+*ledit-2.03 (19 Feb 2012)
+
+ 19 Feb 2012; Alexis Ballier <aballier@gentoo.org> +ledit-2.03.ebuild:
+ version bump
21 Jan 2011; Alexis Ballier <aballier@gentoo.org> -ledit-2.01.ebuild,
-ledit-2.02.ebuild:
diff --git a/app-misc/ledit/ledit-2.03.ebuild b/app-misc/ledit/ledit-2.03.ebuild
new file mode 100644
index 000000000000..429885fb4b95
--- /dev/null
+++ b/app-misc/ledit/ledit-2.03.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ledit-2.03.ebuild,v 1.1 2012/02/19 13:30:35 aballier Exp $
+
+EAPI=2
+inherit eutils
+
+RESTRICT="installsources"
+IUSE="+ocamlopt"
+
+DESCRIPTION="A line editor to be used with interactive commands."
+SRC_URI="http://pauillac.inria.fr/~ddr/ledit/distrib/src/${P}.tgz"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/ledit/"
+
+DEPEND=">=dev-lang/ocaml-3.09[ocamlopt?]
+ dev-ml/camlp5"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_compile() {
+ emake -j1 all || die "make failed"
+ if use ocamlopt; then
+ emake -j1 ledit.opt || die "make failed"
+ else
+ # If using bytecode we dont want to strip the binary as it would remove the
+ # bytecode and only leave ocamlrun...
+ export STRIP_MASK="*/bin/*"
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ newbin ledit.opt ledit || die
+ else
+ newbin ledit.out ledit || die
+ fi
+ doman ledit.1
+ dodoc CHANGES README
+}