summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-22 15:44:03 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-22 15:44:03 +0000
commitfd25e8193f47d9a364cd8f075d128e7b82205b4e (patch)
treed7aec7a0cd27ea6aaed03c9a47e084209ca25ba0 /app-office
parentVersion bump. (diff)
downloadgentoo-2-fd25e8193f47d9a364cd8f075d128e7b82205b4e.tar.gz
gentoo-2-fd25e8193f47d9a364cd8f075d128e7b82205b4e.tar.bz2
gentoo-2-fd25e8193f47d9a364cd8f075d128e7b82205b4e.zip
Revision bump adds upstream patch which fixes db initialization error, bug #506608. Remove old.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/akonadi-server/ChangeLog11
-rw-r--r--app-office/akonadi-server/akonadi-server-1.12.1-r1.ebuild (renamed from app-office/akonadi-server/akonadi-server-1.12.1.ebuild)4
-rw-r--r--app-office/akonadi-server/files/akonadi-server-1.12.1-db-initialize.patch41
3 files changed, 54 insertions, 2 deletions
diff --git a/app-office/akonadi-server/ChangeLog b/app-office/akonadi-server/ChangeLog
index 47d714223326..6b348953f14d 100644
--- a/app-office/akonadi-server/ChangeLog
+++ b/app-office/akonadi-server/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-office/akonadi-server
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.140 2014/04/21 13:45:37 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.141 2014/04/22 15:44:02 johu Exp $
+
+*akonadi-server-1.12.1-r1 (22 Apr 2014)
+
+ 22 Apr 2014; Johannes Huber <johu@gentoo.org>
+ +akonadi-server-1.12.1-r1.ebuild,
+ +files/akonadi-server-1.12.1-db-initialize.patch,
+ -akonadi-server-1.12.1.ebuild:
+ Revision bump adds upstream patch which fixes db initialization error, bug
+ #506608. Remove old.
21 Apr 2014; Johannes Huber <johu@gentoo.org> akonadi-server-1.12.1.ebuild,
metadata.xml:
diff --git a/app-office/akonadi-server/akonadi-server-1.12.1.ebuild b/app-office/akonadi-server/akonadi-server-1.12.1-r1.ebuild
index 04b511721999..664965aab576 100644
--- a/app-office/akonadi-server/akonadi-server-1.12.1.ebuild
+++ b/app-office/akonadi-server/akonadi-server-1.12.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.12.1.ebuild,v 1.2 2014/04/21 13:45:37 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.12.1-r1.ebuild,v 1.1 2014/04/22 15:44:02 johu Exp $
EAPI=5
@@ -59,6 +59,8 @@ RDEPEND="${CDEPEND}
postgres? ( dev-db/postgresql-server )
"
+PATCHES=( "${FILESDIR}/${P}-db-initialize.patch" )
+
pkg_setup() {
# Set default storage backend in order: MySQL, SQLite PostgreSQL
# reverse driver check to keep the order
diff --git a/app-office/akonadi-server/files/akonadi-server-1.12.1-db-initialize.patch b/app-office/akonadi-server/files/akonadi-server-1.12.1-db-initialize.patch
new file mode 100644
index 000000000000..a36706764199
--- /dev/null
+++ b/app-office/akonadi-server/files/akonadi-server-1.12.1-db-initialize.patch
@@ -0,0 +1,41 @@
+commit 4ca8b846baaad48ebbd723f6411f9571a3b0f5ad
+Author: Dan Vrátil <dvratil@redhat.com>
+Date: Tue Apr 22 11:28:07 2014 +0200
+
+ Remove the invalid GID part from PartTable before starting PartTable migration
+
+ More people than we expected have invalid 'GID' part in their PartTable,
+ which breaks migration to schema 25, because it expects all part types
+ to have a valid name.
+
+ To work around this fact, we DELETE all parts with name 'GID' from PartTable
+ before starting the actual migration. This will not fix the migration for
+ people with other invalid parts, but I haven't heard of any such. To make
+ this completely bullet-proof, we would need to iterate through all entries,
+ which would be massively slower than current INSERT INTO ... SELECT FROM approach.
+
+ Distributions, this is a good choice for backporting into 1.12.1 ;-)
+
+ BUG: 331867
+ FIXED-IN: 1.12.2
+
+diff --git a/server/src/storage/dbupdater.cpp b/server/src/storage/dbupdater.cpp
+index ccaf584..d6368b5 100644
+--- a/server/src/storage/dbupdater.cpp
++++ b/server/src/storage/dbupdater.cpp
+@@ -261,6 +261,15 @@ bool DbUpdater::complexUpdate_25()
+ }
+ }
+
++ {
++ // It appears that more users than expected have the invalid "GID" part in their
++ // PartTable, which breaks the migration below (see BKO#331867), so we apply this
++ // wanna-be fix to remove the invalid part before we start the actual migration.
++ QueryBuilder qb( QLatin1String( "PartTable" ), QueryBuilder::Delete );
++ qb.addValueCondition( QLatin1String( "PartTable.name" ), Query::Equals, QLatin1String( "GID" ) );
++ qb.exec();
++ }
++
+ akDebug() << "Creating a PartTable_new";
+ {
+ TableDescription description;