summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-11-07 08:06:01 +0000
committerMike Frysinger <vapier@gentoo.org>2012-11-07 08:06:01 +0000
commit8c0ede420c8d4eb69b70b42fcfa9ce6b984f4e76 (patch)
treed533d4c2868a76b2c00438349fe7ea4d7eb138b4 /app-shells
parentRun elibtoolize for cross-compile relinking, and use get_libdir when deleting... (diff)
downloadgentoo-2-8c0ede420c8d4eb69b70b42fcfa9ce6b984f4e76.tar.gz
gentoo-2-8c0ede420c8d4eb69b70b42fcfa9ce6b984f4e76.tar.bz2
gentoo-2-8c0ede420c8d4eb69b70b42fcfa9ce6b984f4e76.zip
Version bump and move to EAPI 4.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/dash/ChangeLog8
-rw-r--r--app-shells/dash/dash-0.5.7.3.ebuild58
2 files changed, 64 insertions, 2 deletions
diff --git a/app-shells/dash/ChangeLog b/app-shells/dash/ChangeLog
index 6d1c63baf328..513910cca1f8 100644
--- a/app-shells/dash/ChangeLog
+++ b/app-shells/dash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/dash
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.98 2012/06/17 18:15:42 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.99 2012/11/07 08:06:01 vapier Exp $
+
+*dash-0.5.7.3 (07 Nov 2012)
+
+ 07 Nov 2012; Mike Frysinger <vapier@gentoo.org> +dash-0.5.7.3.ebuild:
+ Version bump and move to EAPI 4.
17 Jun 2012; Raúl Porcel <armin76@gentoo.org> dash-0.5.7.1.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #416929
@@ -391,4 +396,3 @@
26 Mar 2004; Seemant Kulleen <seemant@gentoo.org> dash-0.4.24.ebuild:
this is the debian verison of NetBSDs ash. ebuild submitted by: Thomas Eckert
<eckert.thomas@gmx.net> in bug #26253
-
diff --git a/app-shells/dash/dash-0.5.7.3.ebuild b/app-shells/dash/dash-0.5.7.3.ebuild
new file mode 100644
index 000000000000..a286a0d46ac5
--- /dev/null
+++ b/app-shells/dash/dash-0.5.7.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.7.3.ebuild,v 1.1 2012/11/07 08:06:01 vapier Exp $
+
+EAPI="4"
+
+inherit autotools eutils flag-o-matic toolchain-funcs
+
+DEB_PV=${PV%.*}
+DEB_PATCH=${PV##*.}
+DEB_PF="${PN}_${DEB_PV}-${DEB_PATCH}"
+MY_P="${PN}-${DEB_PV}"
+
+DESCRIPTION="DASH is a direct descendant of the NetBSD version of ash (the Almquist SHell) and is POSIX compliant"
+HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
+SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${PN}-${DEB_PV}.tar.gz
+ mirror://debian/pool/main/d/dash/${DEB_PF}.diff.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="libedit static"
+
+RDEPEND="!static? ( libedit? ( dev-libs/libedit ) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ libedit? ( static? ( dev-libs/libedit[static-libs] ) )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${WORKDIR}"/${DEB_PF}.diff
+ epatch */debian/diff/*
+ epatch "${FILESDIR}"/${PN}-0.5.5.1-octal.patch #337329
+
+ # Fix the invalid sort
+ sed -i -e 's/LC_COLLATE=C/LC_ALL=C/g' src/mkbuiltins
+
+ # Use pkg-config for libedit linkage
+ sed -i "/LIBS/s:-ledit:\`$(tc-getPKG_CONFIG) --libs libedit $(usex static --static '')\`:" configure.ac
+
+ # May as well, as the debian patches force this anyway
+ eautoreconf
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ --bindir=/bin \
+ --enable-fnmatch \
+ --enable-glob \
+ $(use_with libedit)
+}
+
+src_install() {
+ default
+ dodoc */debian/changelog
+}