summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-02-21 03:53:20 +0000
committerJonathan Callen <abcd@gentoo.org>2010-02-21 03:53:20 +0000
commitdab72823d1c05826f06e18795bf1ff3b6ed1358f (patch)
tree1747d39648bce3ac530993bef91aa02aeec7a989 /app-text/convmv
parentRevbump for EAPI bump, add prefix keywords (diff)
downloadgentoo-2-dab72823d1c05826f06e18795bf1ff3b6ed1358f.tar.gz
gentoo-2-dab72823d1c05826f06e18795bf1ff3b6ed1358f.tar.bz2
gentoo-2-dab72823d1c05826f06e18795bf1ff3b6ed1358f.zip
Bump EAPI, add prefix support & keywords
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-text/convmv')
-rw-r--r--app-text/convmv/ChangeLog7
-rw-r--r--app-text/convmv/convmv-1.14.ebuild16
2 files changed, 12 insertions, 11 deletions
diff --git a/app-text/convmv/ChangeLog b/app-text/convmv/ChangeLog
index 8026eb1f509f..9bf5edc885ab 100644
--- a/app-text/convmv/ChangeLog
+++ b/app-text/convmv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/convmv
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/convmv/ChangeLog,v 1.36 2009/06/28 09:35:10 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/convmv/ChangeLog,v 1.37 2010/02/21 03:53:20 abcd Exp $
+
+ 21 Feb 2010; Jonathan Callen <abcd@gentoo.org> convmv-1.14.ebuild:
+ Bump EAPI, add prefix support & keywords
*convmv-1.14 (28 Jun 2009)
diff --git a/app-text/convmv/convmv-1.14.ebuild b/app-text/convmv/convmv-1.14.ebuild
index 7c363460794c..d8970d9fbba1 100644
--- a/app-text/convmv/convmv-1.14.ebuild
+++ b/app-text/convmv/convmv-1.14.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/convmv/convmv-1.14.ebuild,v 1.1 2009/06/28 09:35:10 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/convmv/convmv-1.14.ebuild,v 1.2 2010/02/21 03:53:20 abcd Exp $
+
+EAPI=3
inherit eutils
@@ -15,22 +17,18 @@ IUSE=""
DEPEND="dev-lang/perl"
-src_compile() {
- emake || die "emake failed"
+src_prepare() {
+ sed -i -e "1s|#!/usr|#!${EPREFIX}/usr|" convmv || die
}
src_install() {
- einstall DESTDIR="${D}" PREFIX=/usr || die "einstall failed"
+ einstall DESTDIR="${D}" PREFIX="${EPREFIX}"/usr || die "einstall failed"
dodoc CREDITS Changes TODO VERSION
}
src_test() {
unpack ./testsuite.tar
- # Patch merged by upstream
- # Never make assumptions as to the ordering of files inside a directory!
- #EPATCH_OPTS="-d ${S}/suite/" epatch "${FILESDIR}"/${PN}-1.10-testcase-cleanup.patch
-
cd "${S}"/suite
./dotests.sh || die "Tests failed"
}