summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-26 11:24:59 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-26 11:24:59 +0000
commit56bf08c66bfeed4dee60171cdc3e689f8f9a631d (patch)
tree3f076a2bdb4de45a246d4c4eaec8678d0691c021 /dev-haskell/hamlet
parentdev-haskell/dav: initial layout (diff)
downloadgentoo-2-56bf08c66bfeed4dee60171cdc3e689f8f9a631d.tar.gz
gentoo-2-56bf08c66bfeed4dee60171cdc3e689f8f9a631d.tar.bz2
gentoo-2-56bf08c66bfeed4dee60171cdc3e689f8f9a631d.zip
dev-haskell/hamlet: initial layout
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/hamlet')
-rw-r--r--dev-haskell/hamlet/ChangeLog9
-rw-r--r--dev-haskell/hamlet/hamlet-1.1.7.1.ebuild37
-rw-r--r--dev-haskell/hamlet/metadata.xml25
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-haskell/hamlet/ChangeLog b/dev-haskell/hamlet/ChangeLog
new file mode 100644
index 000000000000..0e9f54adc3a3
--- /dev/null
+++ b/dev-haskell/hamlet/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/hamlet
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hamlet/ChangeLog,v 1.1 2013/08/26 11:24:59 qnikst Exp $
+
+*hamlet-1.1.7.1 (26 Aug 2013)
+
+ 26 Aug 2013; Alexander Vershilov <qnikst@gentoo.org> +hamlet-1.1.7.1.ebuild,
+ +metadata.xml:
+ dev-haskell/hamlet: initial layout
diff --git a/dev-haskell/hamlet/hamlet-1.1.7.1.ebuild b/dev-haskell/hamlet/hamlet-1.1.7.1.ebuild
new file mode 100644
index 000000000000..cc8bf34c2308
--- /dev/null
+++ b/dev-haskell/hamlet/hamlet-1.1.7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hamlet/hamlet-1.1.7.1.ebuild,v 1.1 2013/08/26 11:24:59 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haml-like template files that are compile-time checked"
+HOMEPAGE="http://www.yesodweb.com/book/shakespearean-templates"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/blaze-builder-0.2:=[profile?]
+ <dev-haskell/blaze-builder-0.4:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5.1:=[profile?]
+ >=dev-haskell/failure-0.1:=[profile?]
+ <dev-haskell/failure-0.3:=[profile?]
+ >=dev-haskell/parsec-2:=[profile?]
+ <dev-haskell/parsec-4:=[profile?]
+ >=dev-haskell/shakespeare-1.0.1:=[profile?]
+ <dev-haskell/shakespeare-1.1:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ )"
diff --git a/dev-haskell/hamlet/metadata.xml b/dev-haskell/hamlet/metadata.xml
new file mode 100644
index 000000000000..47f4fc959ebe
--- /dev/null
+++ b/dev-haskell/hamlet/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Hamlet gives you a type-safe tool for generating HTML code. It works via Quasi-Quoting, and generating extremely efficient output code. The syntax is white-space sensitive, and it helps you avoid cross-site scripting issues and 404 errors. Please see the documentation at &lt;http://docs.yesodweb.com/book/hamlet/&gt; for more details.
+
+ Here is a quick overview of hamlet html. Due to haddock escaping issues, we can&#39;t properly show variable insertion, but we are still going to show some conditionals. Please see &lt;http://www.yesodweb.com/book/templates&gt; for a thorough description
+
+ &gt; !!!
+ &gt; &lt;html&gt;
+ &gt; &lt;head&gt;
+ &gt; &lt;title&gt;Hamlet Demo
+ &gt; &lt;body&gt;
+ &gt; &lt;h1&gt;Information on John Doe
+ &gt; &lt;h2&gt;
+ &gt; $if isMarried person
+ &gt; Married
+ &gt; $else
+ &gt; Not married
+ </longdescription>
+</pkgmetadata>