summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-03-16 20:03:07 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-03-16 20:03:07 +0000
commit1e8e2dcef320231dec28bc7886e6be7232ff0b2f (patch)
treeeaee76f09c2fe6ade4d796011cf142e2379479da /dev-java/javahelp-bin
parentstable on amd64 (diff)
downloadgentoo-2-1e8e2dcef320231dec28bc7886e6be7232ff0b2f.tar.gz
gentoo-2-1e8e2dcef320231dec28bc7886e6be7232ff0b2f.tar.bz2
gentoo-2-1e8e2dcef320231dec28bc7886e6be7232ff0b2f.zip
revision bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-java/javahelp-bin')
-rw-r--r--dev-java/javahelp-bin/ChangeLog8
-rw-r--r--dev-java/javahelp-bin/files/digest-javahelp-bin-2.0.01-r11
-rw-r--r--dev-java/javahelp-bin/files/digest-javahelp-bin-2.0.02-r11
-rw-r--r--dev-java/javahelp-bin/javahelp-bin-2.0.01-r1.ebuild37
-rw-r--r--dev-java/javahelp-bin/javahelp-bin-2.0.02-r1.ebuild37
5 files changed, 83 insertions, 1 deletions
diff --git a/dev-java/javahelp-bin/ChangeLog b/dev-java/javahelp-bin/ChangeLog
index 81f805675f17..bd0f189bf5d8 100644
--- a/dev-java/javahelp-bin/ChangeLog
+++ b/dev-java/javahelp-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/javahelp-bin
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/javahelp-bin/ChangeLog,v 1.6 2005/03/16 19:54:23 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/javahelp-bin/ChangeLog,v 1.7 2005/03/16 20:03:07 luckyduck Exp $
+
+*javahelp-bin-2.0.02-r1 (16 Mar 2005)
+
+ 16 Mar 2005; Jan Brinkmann <luckyduck@gentoo.org>
+ +javahelp-bin-2.0.01-r1.ebuild, +javahelp-bin-2.0.02-r1.ebuild:
+ revision bump
16 Mar 2005; Jan Brinkmann <luckyduck@gentoo.org>
javahelp-bin-2.0.01.ebuild, javahelp-bin-2.0.02.ebuild:
diff --git a/dev-java/javahelp-bin/files/digest-javahelp-bin-2.0.01-r1 b/dev-java/javahelp-bin/files/digest-javahelp-bin-2.0.01-r1
new file mode 100644
index 000000000000..fc06022d8259
--- /dev/null
+++ b/dev-java/javahelp-bin/files/digest-javahelp-bin-2.0.01-r1
@@ -0,0 +1 @@
+MD5 7ffccc2148d617f5482aa1c227e2a54d javahelp-2_0_01.zip 6695540
diff --git a/dev-java/javahelp-bin/files/digest-javahelp-bin-2.0.02-r1 b/dev-java/javahelp-bin/files/digest-javahelp-bin-2.0.02-r1
new file mode 100644
index 000000000000..f3f4b49bdd06
--- /dev/null
+++ b/dev-java/javahelp-bin/files/digest-javahelp-bin-2.0.02-r1
@@ -0,0 +1 @@
+MD5 bfd64cb13dd3bdb13bcf9d3e8ca599ad javahelp-2_0_02.zip 6805901
diff --git a/dev-java/javahelp-bin/javahelp-bin-2.0.01-r1.ebuild b/dev-java/javahelp-bin/javahelp-bin-2.0.01-r1.ebuild
new file mode 100644
index 000000000000..1966a2b4c50b
--- /dev/null
+++ b/dev-java/javahelp-bin/javahelp-bin-2.0.01-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/javahelp-bin/javahelp-bin-2.0.01-r1.ebuild,v 1.1 2005/03/16 20:03:07 luckyduck Exp $
+
+inherit java-pkg
+
+DESCRIPTION="JavaHelp software is a full-featured, platform-independent, extensible help system that enables you to incorporate online help in applets, components, applications, operating systems, and devices."
+HOMEPAGE="http://java.sun.com/products/javahelp/"
+LICENSE="sun-j2sl"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+DEPEND=">=app-arch/unzip-5.50-r1"
+RDEPEND=">=virtual/jdk-1.3"
+RESTRICT="fetch"
+SRC_URI="javahelp-${PV//./_}.zip"
+IUSE="doc"
+
+S="${WORKDIR}/jh2.0"
+
+DOWNLOAD_URL="http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=javahelp-${PV//./_}-oth-JPR&SiteId=JSC&TransactionId=noreg"
+
+pkg_nofetch() {
+ einfo "Please download ${SRC_URI} from ${HOMEPAGE} and move it to ${DISTDIR}"
+ einfo "Direct url: ${DOWNLOAD_URL}"
+}
+
+src_compile() { :; }
+
+src_install(){
+ java-pkg_dojar javahelp/lib/*.jar
+ cp -R ${S}/javahelp/lib/dtd ${D}/usr/share/${PN}/lib
+ cp -R ${S}/javahelp/bin ${D}/usr/share/${PN}/bin
+
+ use doc && cp -R ${S}/demos ${D}/usr/share/${PN} && java-pkg_dohtml -r doc
+ dodoc README
+}
+
diff --git a/dev-java/javahelp-bin/javahelp-bin-2.0.02-r1.ebuild b/dev-java/javahelp-bin/javahelp-bin-2.0.02-r1.ebuild
new file mode 100644
index 000000000000..455f9fd30215
--- /dev/null
+++ b/dev-java/javahelp-bin/javahelp-bin-2.0.02-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/javahelp-bin/javahelp-bin-2.0.02-r1.ebuild,v 1.1 2005/03/16 20:03:07 luckyduck Exp $
+
+inherit java-pkg
+
+DESCRIPTION="JavaHelp software is a full-featured, platform-independent, extensible help system that enables you to incorporate online help in applets, components, applications, operating systems, and devices."
+HOMEPAGE="http://java.sun.com/products/javahelp/"
+LICENSE="sun-j2sl"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+DEPEND=">=app-arch/unzip-5.50-r1"
+RDEPEND=">=virtual/jdk-1.3"
+RESTRICT="fetch"
+SRC_URI="javahelp-${PV//./_}.zip"
+IUSE="doc"
+
+S="${WORKDIR}/jh2.0"
+
+DOWNLOAD_URL="http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=javahelp-${PV//./_}-oth-JPR&SiteId=JSC&TransactionId=noreg"
+
+pkg_nofetch() {
+ einfo "Please download ${SRC_URI} from ${HOMEPAGE} and move it to ${DISTDIR}"
+ einfo "Direct url: ${DOWNLOAD_URL}"
+}
+
+src_compile() { :; }
+
+src_install(){
+ java-pkg_dojar javahelp/lib/*.jar
+ cp -R ${S}/javahelp/lib/dtd ${D}/usr/share/${PN}/lib
+ cp -R ${S}/javahelp/bin ${D}/usr/share/${PN}/bin
+
+ use doc && cp -R ${S}/demos ${D}/usr/share/${PN} && java-pkg_dohtml -r doc
+ dodoc README
+}
+