summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-10-02 11:36:24 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-10-02 11:36:24 +0000
commitd0cd82ce408e05ca81d9711a0484173a6367da9f (patch)
tree70959fdcb9fcd852a11932edc312578bf65e9b7f /dev-lang/icc
parentSplit debugger into dev-lang/idb, remove IA32ROOT env, added more log comments. (diff)
downloadgentoo-2-d0cd82ce408e05ca81d9711a0484173a6367da9f.tar.gz
gentoo-2-d0cd82ce408e05ca81d9711a0484173a6367da9f.tar.bz2
gentoo-2-d0cd82ce408e05ca81d9711a0484173a6367da9f.zip
Version bump. Restructured ebuild with newer package. Debugger now in dev-lang/idb. Added myself as maintainer and added longdescription.
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-lang/icc')
-rw-r--r--dev-lang/icc/ChangeLog9
-rw-r--r--dev-lang/icc/files/digest-icc-10.0.0269
-rw-r--r--dev-lang/icc/icc-10.0.026.ebuild90
-rw-r--r--dev-lang/icc/metadata.xml12
4 files changed, 119 insertions, 1 deletions
diff --git a/dev-lang/icc/ChangeLog b/dev-lang/icc/ChangeLog
index 7812f540ff94..9fc7d5d3500b 100644
--- a/dev-lang/icc/ChangeLog
+++ b/dev-lang/icc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/icc
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.42 2007/07/02 14:43:12 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.43 2007/10/02 11:36:23 bicatali Exp $
+
+*icc-10.0.026 (02 Oct 2007)
+
+ 02 Oct 2007; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ +icc-10.0.026.ebuild:
+ Version bump. Restructured ebuild with newer package. Debugger now in
+ dev-lang/idb. Added myself as maintainer and added longdescription.
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> icc-9.1.045.ebuild:
(QA) RESTRICT clean up.
diff --git a/dev-lang/icc/files/digest-icc-10.0.026 b/dev-lang/icc/files/digest-icc-10.0.026
new file mode 100644
index 000000000000..cbbec3f68f5c
--- /dev/null
+++ b/dev-lang/icc/files/digest-icc-10.0.026
@@ -0,0 +1,9 @@
+MD5 d426b44bc13b584b74df81c24eb3a57f l_cc_c_10.0.026_ia32.tar.gz 56556358
+RMD160 47e1ba1897edaccfb1200d8224bfccb8410b8671 l_cc_c_10.0.026_ia32.tar.gz 56556358
+SHA256 0e18dbbf6608ebf7d87db71dbdb6f00284913451dd97f47471323e7f1d7cd66a l_cc_c_10.0.026_ia32.tar.gz 56556358
+MD5 bd024cd6947b95fc1e7c038e5bdfa8f1 l_cc_c_10.0.026_ia64.tar.gz 64662221
+RMD160 51601383678f759979a2c9d456102e28a9d017bf l_cc_c_10.0.026_ia64.tar.gz 64662221
+SHA256 1d55e6040fef6c3e42725049c19ab80c506efff99b7810e04cc55731d0e31b19 l_cc_c_10.0.026_ia64.tar.gz 64662221
+MD5 010ae81d9e93ff968948b55c80a92842 l_cc_c_10.0.026_intel64.tar.gz 36405579
+RMD160 bcf8bec436ad4c9e91b35201e709491b197f6145 l_cc_c_10.0.026_intel64.tar.gz 36405579
+SHA256 00ca4de9510e04c7d3f27590e21339d663d17b12b39ebc5153d9bd58e750128e l_cc_c_10.0.026_intel64.tar.gz 36405579
diff --git a/dev-lang/icc/icc-10.0.026.ebuild b/dev-lang/icc/icc-10.0.026.ebuild
new file mode 100644
index 000000000000..32e7ef32b7a3
--- /dev/null
+++ b/dev-lang/icc/icc-10.0.026.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-10.0.026.ebuild,v 1.1 2007/10/02 11:36:23 bicatali Exp $
+
+inherit rpm
+
+PID=786
+PB=cc
+PEXEC=icc
+DESCRIPTION="Intel C/C++ optimized compiler for Linux"
+HOMEPAGE="http://www.intel.com/software/products/compilers/clin/"
+
+###
+# everything below common to ifc and icc
+# no eclass: very likely to change for next versions
+###
+PACKAGEID="l_${PB}_c_${PV}"
+KEYWORDS="~amd64 ~ia64 ~x86"
+SRC_URI="amd64? ( http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKAGEID}_intel64.tar.gz )
+ ia64? ( http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKAGEID}_ia64.tar.gz )
+ x86? ( http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKAGEID}_ia32.tar.gz )"
+
+LICENSE="Intel-SDP"
+SLOT="0"
+
+RESTRICT="test strip mirror"
+IUSE=""
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ mv "${WORKDIR}"/l_* "${S}"
+ cd "${S}"
+
+ local ext=
+ use amd64 && ext=e
+ INSTALL_DIR=/opt/intel/${PB}${ext}/${PV}
+
+ # debugger installed with dev-lang/idb
+ rm -f data/intel*idb*.rpm
+
+ for x in data/intel*.rpm; do
+ einfo "Extracting $(basename ${x})..."
+ rpm_unpack "${S}/${x}" || die "rpm_unpack ${x} failed"
+ done
+
+ einfo "Fixing paths and tagging"
+ cd "${S}"/${INSTALL_DIR}/bin
+ sed -e "s|<INSTALLDIR>|${INSTALL_DIR}|g" \
+ -i ${PEXEC} ${PEXEC}*sh \
+ || die "sed fixing path failed"
+
+ cd "${S}"/${INSTALL_DIR}/doc
+ sed -e "s|\<installpackageid\>|${PACKAGEID}|g" \
+ -e "s|\<INSTALLTIMECOMBOPACKAGEID\>|${PACKAGEID}|g" \
+ -i *support \
+ || die "sed support file failed"
+ chmod 644 *support
+}
+
+src_install() {
+ einfo "Copying files"
+ dodir ${INSTALL_DIR}
+ cp -pPR \
+ "${S}"/${INSTALL_DIR}/* \
+ "${D}"/${INSTALL_DIR}/ \
+ || die "copying ${PN} failed"
+
+ local env_file=05${PN}
+ echo "PATH=${INSTALL_DIR}/bin" > ${env_file}
+ echo "ROOTPATH=${INSTALL_DIR}/bin" >> ${env_file}
+ echo "LDPATH=${INSTALL_DIR}/lib" >> ${env_file}
+ echo "MANPATH=${INSTALL_DIR}/man" >> ${env_file}
+ echo "INCLUDE=${INSTALL_DIR}/include" >> ${env_file}
+ doenvd ${env_file} || die "doenvd ${env_file} failed"
+}
+
+pkg_postinst () {
+ # remove left over from unpacking
+ rm -f "${ROOT}"/opt/intel/{intel_sdp_products.db,.*.log} || die "remove logs failed"
+
+ elog "Make sure you have recieved the a license for ${PN}"
+ elog "To receive a restrictive non-commercial licenses , you need to register at:"
+ elog "http://www.intel.com/cd/software/products/asmo-na/eng/download/download/219771.htm"
+ elog "Read the website for more information on this license."
+ elog "You cannot run ${PN} without a license file."
+ elog "Then put the license file into ${ROOT}/opt/intel/licenses"
+ elog "\nTo use ${PN} issue first \n\tsource /etc/profile"
+ elog "Debugger is installed with dev-lang/idb"
+}
diff --git a/dev-lang/icc/metadata.xml b/dev-lang/icc/metadata.xml
index e2a3a2b83518..b0442c427987 100644
--- a/dev-lang/icc/metadata.xml
+++ b/dev-lang/icc/metadata.xml
@@ -7,5 +7,17 @@
<name>Karl Trygve Kalleberg</name>
<description>Also, bug Kugelfang.</description>
</maintainer>
+<maintainer>
+<email>bicatali@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+The Intel® C++ Compiler is a full featured C/C++ compiler for Intel
+based architectures. The compiler supports multi-threading, automatic
+processor dispatch, vectorization, auto-parallelization, OpenMP, data
+prefetching, loop unrolling. The package comes with extensive
+documentation.
+The product can be installed as a non-commercial as
+well. License, terms of qualifications can be found on the web site.
+</longdescription>
</pkgmetadata>