summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2011-10-27 13:56:55 +0000
committerJesus Rivero <neurogeek@gentoo.org>2011-10-27 13:56:55 +0000
commitcd572e68a2bed8d62bddeeb75ed9c96187a8c7ca (patch)
tree53351e668e38fb6e95b3c899455750dbb7a8f455 /dev-lang
parentFixed mms-agent SRC_URI (diff)
downloadgentoo-2-cd572e68a2bed8d62bddeeb75ed9c96187a8c7ca.tar.gz
gentoo-2-cd572e68a2bed8d62bddeeb75ed9c96187a8c7ca.tar.bz2
gentoo-2-cd572e68a2bed8d62bddeeb75ed9c96187a8c7ca.zip
Changes to pydoc conf.d and init.d files wrt bug #361867. Patch by Arfrever
(Portage version: 2.2.0_alpha46/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog9
-rw-r--r--dev-lang/python/files/pydoc.conf9
-rwxr-xr-xdev-lang/python/files/pydoc.init14
-rw-r--r--dev-lang/python/python-2.4.6.ebuild7
-rw-r--r--dev-lang/python/python-2.5.4-r4.ebuild7
-rw-r--r--dev-lang/python/python-2.6.6-r2.ebuild7
-rw-r--r--dev-lang/python/python-2.7.1-r1.ebuild7
-rw-r--r--dev-lang/python/python-3.1.3-r1.ebuild7
-rw-r--r--dev-lang/python/python-3.2-r2.ebuild7
-rw-r--r--dev-lang/python/python-3.2.2.ebuild7
10 files changed, 55 insertions, 26 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index dbee910d08b2..be21dd71e212 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.552 2011/10/26 14:39:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.553 2011/10/27 13:56:55 neurogeek Exp $
+
+ 27 Oct 2011; Jesus Rivero <neurogeek@gentoo.org> python-2.4.6.ebuild,
+ python-2.5.4-r4.ebuild, python-2.6.6-r2.ebuild, python-2.7.1-r1.ebuild,
+ python-3.1.3-r1.ebuild, python-3.2-r2.ebuild, python-3.2.2.ebuild,
+ files/pydoc.conf, files/pydoc.init:
+ Changes to pydoc conf.d and init.d files wrt bug #361867. Patch by
+ Arfrever
26 Oct 2011; Jeroen Roovers <jer@gentoo.org> python-3.1.4-r3.ebuild:
Stable for HPPA (bug #387849).
diff --git a/dev-lang/python/files/pydoc.conf b/dev-lang/python/files/pydoc.conf
index 4a98fd40e485..20e3628ba483 100644
--- a/dev-lang/python/files/pydoc.conf
+++ b/dev-lang/python/files/pydoc.conf
@@ -1,8 +1,7 @@
# /etc/init.d/pydoc.conf
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/files/pydoc.conf,v 1.2 2008/06/30 15:10:28 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/files/pydoc.conf,v 1.3 2011/10/27 13:56:55 neurogeek Exp $
-# This file contains the configuration information for pydoc's internal
-# webserver. The variables should be rather self explanatory :-)
+# This file contains the configuration for pydoc's internal webserver.
-# Default port for Python's pydoc server
-PYDOC_PORT=7464
+# Default port for Python's pydoc server.
+@PYDOC_PORT_VARIABLE@="7464"
diff --git a/dev-lang/python/files/pydoc.init b/dev-lang/python/files/pydoc.init
index f67371d8d9a8..0d62dfcf02c3 100755
--- a/dev-lang/python/files/pydoc.init
+++ b/dev-lang/python/files/pydoc.init
@@ -1,27 +1,29 @@
#!/sbin/runscript
# Copyright 1999-2011 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public Licence v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/files/pydoc.init,v 1.3 2011/05/17 15:14:43 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/files/pydoc.init,v 1.4 2011/10/27 13:56:55 neurogeek Exp $
depend() {
need net
}
start() {
- if [ -z "${PYDOC_PORT}" ]; then
+ local pydoc_port="${@PYDOC_PORT_VARIABLE@-${PYDOC_PORT}}"
+
+ if [ -z "${pydoc_port}" ]; then
eerror "Port not set"
return 1
fi
- ebegin "Starting pydoc server on port ${PYDOC_PORT}"
+ ebegin "Starting pydoc server on port ${pydoc_port}"
start-stop-daemon --start --background --make-pidfile \
- --pidfile /var/run/pydoc.pid \
- --startas /usr/bin/@PYDOC@ -- -p "${PYDOC_PORT}"
+ --pidfile /var/run/@PYDOC@.pid \
+ --exec /usr/bin/@PYDOC@ -- -p "${pydoc_port}"
eend $?
}
stop() {
ebegin "Stopping pydoc server"
- start-stop-daemon --stop --quiet --pidfile /var/run/pydoc.pid
+ start-stop-daemon --stop --quiet --pidfile /var/run/@PYDOC@.pid
eend $?
}
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index bce28db5be9f..630b64fc66e3 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.47 2011/05/17 15:14:43 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.48 2011/10/27 13:56:55 neurogeek Exp $
EAPI="1"
@@ -257,7 +257,10 @@ src_install() {
newconfd "${FILESDIR}/pydoc.conf" pydoc-${SLOT} || die "newconfd failed"
newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT} || die "newinitd failed"
- sed -e "s:@PYDOC@:pydoc${SLOT}:" -i "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
+ sed \
+ -e "s:@PYDOC_PORT_VARIABLE@:PYDOC${SLOT/./_}_PORT:" \
+ -e "s:@PYDOC@:pydoc${SLOT}:" \
+ -i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
}
pkg_preinst() {
diff --git a/dev-lang/python/python-2.5.4-r4.ebuild b/dev-lang/python/python-2.5.4-r4.ebuild
index 88b3f866eb84..77d8226026e4 100644
--- a/dev-lang/python/python-2.5.4-r4.ebuild
+++ b/dev-lang/python/python-2.5.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.29 2011/05/17 15:14:43 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.30 2011/10/27 13:56:55 neurogeek Exp $
EAPI="1"
@@ -272,7 +272,10 @@ src_install() {
newconfd "${FILESDIR}/pydoc.conf" pydoc-${SLOT} || die "newconfd failed"
newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT} || die "newinitd failed"
- sed -e "s:@PYDOC@:pydoc${SLOT}:" -i "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
+ sed \
+ -e "s:@PYDOC_PORT_VARIABLE@:PYDOC${SLOT/./_}_PORT:" \
+ -e "s:@PYDOC@:pydoc${SLOT}:" \
+ -i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
}
pkg_preinst() {
diff --git a/dev-lang/python/python-2.6.6-r2.ebuild b/dev-lang/python/python-2.6.6-r2.ebuild
index 3da872fdeec1..63a8baa6ad2a 100644
--- a/dev-lang/python/python-2.6.6-r2.ebuild
+++ b/dev-lang/python/python-2.6.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.6-r2.ebuild,v 1.10 2011/05/17 15:14:43 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.6-r2.ebuild,v 1.11 2011/10/27 13:56:55 neurogeek Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -292,7 +292,10 @@ src_install() {
newconfd "${FILESDIR}/pydoc.conf" pydoc-${SLOT} || die "newconfd failed"
newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT} || die "newinitd failed"
- sed -e "s:@PYDOC@:pydoc${SLOT}:" -i "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
+ sed \
+ -e "s:@PYDOC_PORT_VARIABLE@:PYDOC${SLOT/./_}_PORT:" \
+ -e "s:@PYDOC@:pydoc${SLOT}:" \
+ -i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# Do not install empty directory.
rmdir "${ED}$(python_get_libdir)/lib-old"
diff --git a/dev-lang/python/python-2.7.1-r1.ebuild b/dev-lang/python/python-2.7.1-r1.ebuild
index dddafe504735..95184a6b6559 100644
--- a/dev-lang/python/python-2.7.1-r1.ebuild
+++ b/dev-lang/python/python-2.7.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.1-r1.ebuild,v 1.12 2011/05/17 15:14:43 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.1-r1.ebuild,v 1.13 2011/10/27 13:56:55 neurogeek Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -314,7 +314,10 @@ src_install() {
newconfd "${FILESDIR}/pydoc.conf" pydoc-${SLOT} || die "newconfd failed"
newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT} || die "newinitd failed"
- sed -e "s:@PYDOC@:pydoc${SLOT}:" -i "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
+ sed \
+ -e "s:@PYDOC_PORT_VARIABLE@:PYDOC${SLOT/./_}_PORT:" \
+ -e "s:@PYDOC@:pydoc${SLOT}:" \
+ -i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# Do not install empty directory.
rmdir "${ED}$(python_get_libdir)/lib-old"
diff --git a/dev-lang/python/python-3.1.3-r1.ebuild b/dev-lang/python/python-3.1.3-r1.ebuild
index 8f3fb58409a4..436e79ad1a91 100644
--- a/dev-lang/python/python-3.1.3-r1.ebuild
+++ b/dev-lang/python/python-3.1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.3-r1.ebuild,v 1.9 2011/08/27 21:09:43 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.3-r1.ebuild,v 1.10 2011/10/27 13:56:55 neurogeek Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -285,7 +285,10 @@ src_install() {
newconfd "${FILESDIR}/pydoc.conf" pydoc-${SLOT} || die "newconfd failed"
newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT} || die "newinitd failed"
- sed -e "s:@PYDOC@:pydoc${SLOT}:" -i "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
+ sed \
+ -e "s:@PYDOC_PORT_VARIABLE@:PYDOC${SLOT/./_}_PORT:" \
+ -e "s:@PYDOC@:pydoc${SLOT}:" \
+ -i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
}
pkg_preinst() {
diff --git a/dev-lang/python/python-3.2-r2.ebuild b/dev-lang/python/python-3.2-r2.ebuild
index e6bdf0553e73..24cb8d51daac 100644
--- a/dev-lang/python/python-3.2-r2.ebuild
+++ b/dev-lang/python/python-3.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2-r2.ebuild,v 1.4 2011/08/23 19:03:37 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2-r2.ebuild,v 1.5 2011/10/27 13:56:55 neurogeek Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -313,7 +313,10 @@ src_install() {
fi
fi
- sed -e "s:@PYDOC@:pydoc${SLOT}:" -i "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
+ sed \
+ -e "s:@PYDOC_PORT_VARIABLE@:PYDOC${SLOT/./_}_PORT:" \
+ -e "s:@PYDOC@:pydoc${SLOT}:" \
+ -i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
}
pkg_preinst() {
diff --git a/dev-lang/python/python-3.2.2.ebuild b/dev-lang/python/python-3.2.2.ebuild
index 75a950d5ad68..e4be16e822eb 100644
--- a/dev-lang/python/python-3.2.2.ebuild
+++ b/dev-lang/python/python-3.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.2.ebuild,v 1.1 2011/09/16 20:47:06 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.2.ebuild,v 1.2 2011/10/27 13:56:55 neurogeek Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -310,7 +310,10 @@ src_install() {
fi
fi
- sed -e "s:@PYDOC@:pydoc${SLOT}:" -i "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
+ sed \
+ -e "s:@PYDOC_PORT_VARIABLE@:PYDOC${SLOT/./_}_PORT:" \
+ -e "s:@PYDOC@:pydoc${SLOT}:" \
+ -i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
}
pkg_preinst() {