summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-05-21 15:51:59 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-05-21 15:51:59 +0000
commit4cde49c7909ab370086db3beab87fa1f0aa47f1b (patch)
treee0c04107184c05b02b0032e0f659b24e17563cd7 /dev-libs/wayland
parentAdd ChangeLog entry for fontsproto, xorg-server, wayland and weston mask (diff)
downloadgentoo-2-4cde49c7909ab370086db3beab87fa1f0aa47f1b.tar.gz
gentoo-2-4cde49c7909ab370086db3beab87fa1f0aa47f1b.tar.bz2
gentoo-2-4cde49c7909ab370086db3beab87fa1f0aa47f1b.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/wayland')
-rw-r--r--dev-libs/wayland/ChangeLog8
-rw-r--r--dev-libs/wayland/wayland-1.5.0.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-libs/wayland/ChangeLog b/dev-libs/wayland/ChangeLog
index 678eaf582bfb..4958d2f616f8 100644
--- a/dev-libs/wayland/ChangeLog
+++ b/dev-libs/wayland/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/wayland
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/ChangeLog,v 1.43 2014/04/28 17:43:33 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/ChangeLog,v 1.44 2014/05/21 15:51:59 chithanh Exp $
+
+*wayland-1.5.0 (21 May 2014)
+
+ 21 May 2014; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +wayland-1.5.0.ebuild:
+ Version bump.
28 Apr 2014; Michał Górny <mgorny@gentoo.org> wayland-1.3.0.ebuild,
wayland-1.4.0.ebuild:
diff --git a/dev-libs/wayland/wayland-1.5.0.ebuild b/dev-libs/wayland/wayland-1.5.0.ebuild
new file mode 100644
index 000000000000..23f472ff30e4
--- /dev/null
+++ b/dev-libs/wayland/wayland-1.5.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/wayland-1.5.0.ebuild,v 1.1 2014/05/21 15:51:59 chithanh Exp $
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ AUTOTOOLS_AUTORECONF=1
+fi
+
+inherit autotools-multilib toolchain-funcs $GIT_ECLASS
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="http://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="dev-libs/expat[${MULTILIB_USEDEP}]
+ virtual/libffi[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable doc documentation)
+ )
+ if tc-is-cross-compiler ; then
+ myeconfargs+=( --disable-scanner )
+ fi
+ if ! multilib_is_native_abi; then
+ myeconfargs+=( --disable-documentation )
+ fi
+
+ autotools-multilib_src_configure
+}
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ autotools-multilib_src_test
+}