summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-01-21 15:27:39 +0000
committerChristian Heim <phreak@gentoo.org>2007-01-21 15:27:39 +0000
commit795785d76fc985729e1ddec8d755e50db53d62ad (patch)
tree2ec913e7ae0a32b1e60379c84327c789add97a9d /dev-libs
parentadded app-doc/gimp-help:webinstall (diff)
downloadgentoo-2-795785d76fc985729e1ddec8d755e50db53d62ad.tar.gz
gentoo-2-795785d76fc985729e1ddec8d755e50db53d62ad.tar.bz2
gentoo-2-795785d76fc985729e1ddec8d755e50db53d62ad.zip
Version bump (thanks to Conrad Kostecki <ConiKost at gmx.de> in #114232).
(Portage version: 2.1.2-r1)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/apr/ChangeLog7
-rw-r--r--dev-libs/apr/apr-1.2.8.ebuild89
-rw-r--r--dev-libs/apr/files/digest-apr-1.2.83
3 files changed, 98 insertions, 1 deletions
diff --git a/dev-libs/apr/ChangeLog b/dev-libs/apr/ChangeLog
index 76babf97edde..e4d5ca202e60 100644
--- a/dev-libs/apr/ChangeLog
+++ b/dev-libs/apr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/apr
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.74 2007/01/08 23:35:43 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.75 2007/01/21 15:27:39 phreak Exp $
+
+*apr-1.2.8 (21 Jan 2007)
+
+ 21 Jan 2007; Christian Heim <phreak@gentoo.org> +apr-1.2.8.ebuild:
+ Version bump (thanks to Conrad Kostecki <ConiKost at gmx.de> in #114232).
08 Jan 2007; Christian Heim <phreak@gentoo.org> apr-1.2.7-r1.ebuild,
apr-1.2.7-r2.ebuild, apr-1.2.7-r3.ebuild:
diff --git a/dev-libs/apr/apr-1.2.8.ebuild b/dev-libs/apr/apr-1.2.8.ebuild
new file mode 100644
index 000000000000..f98e7db5697d
--- /dev/null
+++ b/dev-libs/apr/apr-1.2.8.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.2.8.ebuild,v 1.1 2007/01/21 15:27:39 phreak Exp $
+
+WANT_AUTOCONF="2.5"
+WANT_AUTOMAKE="1.1"
+
+inherit autotools
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="ipv6 urandom debug"
+RESTRICT="test"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # for some reason not all the .m4 files that are referenced in
+ # configure.in exist, so we remove all references and include every
+ # .m4 file in build using aclocal via eautoreconf
+ # See bug 135463
+ sed -i -e '/sinclude/d' configure.in
+ AT_M4DIR="build" eautoreconf
+
+ epatch "${FILESDIR}"/config.layout.patch
+
+}
+
+src_compile() {
+ # For now we always enable ipv6. Testing has shown that is still works
+ # correctly in ipv4 systems, and currently, the ipv4-only support
+ # is broken in apr. (ipv6 is enabled by default)
+ #myconf="${myconf} $(use_enable ipv6)"
+
+ if use urandom; then
+ myconf="${myconf} --with-devrandom=/dev/urandom"
+ else
+ myconf="${myconf} --with-devrandom=/dev/random"
+ fi
+
+ use debug && myconf="${myconf} --enable-maintainer-mode"
+
+ # We pre-load the cache with the correct answer! This avoids
+ # it violating the sandbox. This may have to be changed for
+ # non-Linux systems or if sem_open changes on Linux. This
+ # hack is built around documentation in /usr/include/semaphore.h
+ # and the glibc (pthread) source
+ # See bugs 24215 and 133573
+ echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> "${S}"/config.cache
+
+ econf --enable-layout=gentoo \
+ --enable-threads \
+ --enable-nonportable-atomics \
+ ${myconf} || die "econf failed!"
+
+ # Make sure we use the system libtool
+ sed -i 's,$(apr_builddir)/libtool,/usr/bin/libtool,' "${S}"/build/apr_rules.mk
+ sed -i 's,${installbuilddir}/libtool,/usr/bin/libtool,' "${S}"/apr-1-config
+ rm -f "${S}"/libtool
+
+ emake || die "Make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # This file is only used on AIX systems, which gentoo is not,
+ # and causes collisions between the SLOTs, so kill it
+ rm "${D}"/usr/$(get_libdir)/apr.exp
+
+ dodoc CHANGES NOTICE LICENSE
+}
+
+pkg_postinst() {
+ ewarn "We are now using the system's libtool rather then bundling"
+ ewarn "our own. You will need to rebuild Apache and possibly other"
+ ewarn "software if you get a message similiar to the following:"
+ ewarn
+ ewarn " /usr/share/apr-1/build-1/libtool: No such file or directory"
+ ewarn
+} \ No newline at end of file
diff --git a/dev-libs/apr/files/digest-apr-1.2.8 b/dev-libs/apr/files/digest-apr-1.2.8
new file mode 100644
index 000000000000..7e31fb56fcdf
--- /dev/null
+++ b/dev-libs/apr/files/digest-apr-1.2.8
@@ -0,0 +1,3 @@
+MD5 814f19528d9cfc79aef188dd752e04d8 apr-1.2.8.tar.gz 1107189
+RMD160 299e1ddb1f7c9b0169a410e120c30abea38557c5 apr-1.2.8.tar.gz 1107189
+SHA256 96e31f0ea2e028f372d5fdbbd4f88f31d59e14eda85cd12153183759f8e221c7 apr-1.2.8.tar.gz 1107189