summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2014-04-28 03:15:51 +0000
committerAndrey Grozin <grozin@gentoo.org>2014-04-28 03:15:51 +0000
commit44dd4f5d92c202361261ab4e8145d7d611d4219f (patch)
tree56c3b3f88a37c1f68b4bae6e848abe07da278aa3 /dev-lisp
parentfor patrick (diff)
downloadgentoo-2-44dd4f5d92c202361261ab4e8145d7d611d4219f.tar.gz
gentoo-2-44dd4f5d92c202361261ab4e8145d7d611d4219f.tar.bz2
gentoo-2-44dd4f5d92c202361261ab4e8145d7d611d4219f.zip
Version bump, cleaning old
(Portage version: 2.2.10/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/sbcl/ChangeLog9
-rw-r--r--dev-lisp/sbcl/sbcl-1.1.10.ebuild204
-rw-r--r--dev-lisp/sbcl/sbcl-1.1.11.ebuild204
-rw-r--r--dev-lisp/sbcl/sbcl-1.1.12.ebuild204
-rw-r--r--dev-lisp/sbcl/sbcl-1.1.17.ebuild (renamed from dev-lisp/sbcl/sbcl-1.1.14.ebuild)4
5 files changed, 10 insertions, 615 deletions
diff --git a/dev-lisp/sbcl/ChangeLog b/dev-lisp/sbcl/ChangeLog
index 84f114b407c9..d84af6ebfe4f 100644
--- a/dev-lisp/sbcl/ChangeLog
+++ b/dev-lisp/sbcl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lisp/sbcl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.201 2014/03/09 14:18:01 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.202 2014/04/28 03:15:51 grozin Exp $
+
+*sbcl-1.1.17 (28 Apr 2014)
+
+ 28 Apr 2014; Andrey Grozin <grozin@gentoo.org> -sbcl-1.1.10.ebuild,
+ -sbcl-1.1.11.ebuild, -sbcl-1.1.12.ebuild, -sbcl-1.1.14.ebuild,
+ +sbcl-1.1.17.ebuild:
+ Version bump, cleaning old
*sbcl-1.1.16 (09 Mar 2014)
diff --git a/dev-lisp/sbcl/sbcl-1.1.10.ebuild b/dev-lisp/sbcl/sbcl-1.1.10.ebuild
deleted file mode 100644
index 85318f77d768..000000000000
--- a/dev-lisp/sbcl/sbcl-1.1.10.ebuild
+++ /dev/null
@@ -1,204 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.1.10.ebuild,v 1.1 2013/08/09 12:28:09 grozin Exp $
-
-EAPI=5
-inherit multilib eutils flag-o-matic pax-utils
-
-#same order as http://www.sbcl.org/platform-table.html
-BV_X86=1.0.58
-BV_AMD64=1.1.10
-BV_PPC=1.0.28
-BV_SPARC=1.0.28
-BV_ALPHA=1.0.28
-
-DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
-HOMEPAGE="http://sbcl.sourceforge.net/"
-SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
- x86? ( mirror://sourceforge/sbcl/${PN}-${BV_X86}-x86-linux-binary.tar.bz2 )
- amd64? ( mirror://sourceforge/sbcl/${PN}-${BV_AMD64}-x86-64-linux-binary.tar.bz2 )
- ppc? ( mirror://sourceforge/sbcl/${PN}-${BV_PPC}-powerpc-linux-binary.tar.bz2 )
- sparc? ( mirror://sourceforge/sbcl/${PN}-${BV_SPARC}-sparc-linux-binary.tar.bz2 )
- alpha? ( mirror://sourceforge/sbcl/${PN}-${BV_ALPHA}-alpha-linux-binary.tar.bz2 )"
-
-RESTRICT="mirror"
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="debug doc source +threads +unicode zlib"
-
-CDEPEND=">=dev-lisp/asdf-2.33-r3:="
-DEPEND="${CDEPEND}
- doc? ( <sys-apps/texinfo-5.0 >=media-gfx/graphviz-2.26.0 )"
-RDEPEND="${CDEPEND}
- elibc_glibc? ( >=sys-libs/glibc-2.3 || ( <sys-libs/glibc-2.6[nptl] >=sys-libs/glibc-2.6 ) )"
-
-# Disable warnings about executable stacks, as this won't be fixed soon by upstream
-QA_EXECSTACK="usr/bin/sbcl"
-
-CONFIG="${S}/customize-target-features.lisp"
-ENVD="${T}/50sbcl"
-
-# Prevent ASDF from using the system libraries
-CL_SOURCE_REGISTRY="(:source-registry :ignore-inherited-configuration)"
-ASDF_OUTPUT_TRANSLATIONS="(:output-translations :ignore-inherited-configuration)"
-
-usep() {
- use ${1} && echo "true" || echo "false"
-}
-
-sbcl_feature() {
- echo "$( [[ ${1} == "true" ]] && echo "(enable ${2})" || echo "(disable ${2})")" >> "${CONFIG}"
-}
-
-sbcl_apply_features() {
- cat > "${CONFIG}" <<'EOF'
-(lambda (list)
- (flet ((enable (x) (pushnew x list))
- (disable (x) (setf list (remove x list))))
-EOF
- if use x86 || use amd64; then
- sbcl_feature "$(usep threads)" ":sb-thread"
- fi
- sbcl_feature "true" ":sb-ldb"
- sbcl_feature "false" ":sb-test"
- sbcl_feature "$(usep unicode)" ":sb-unicode"
- sbcl_feature "$(usep zlib)" ":sb-core-compression"
- sbcl_feature "$(usep debug)" ":sb-xref-for-internals"
- cat >> "${CONFIG}" <<'EOF'
- )
- list)
-EOF
- cat "${CONFIG}"
-}
-
-src_unpack() {
- unpack ${A}
- mv sbcl-*-linux sbcl-binary || die
- cd "${S}"
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/gentoo-fix_install_man.patch
- epatch "${FILESDIR}"/gentoo-fix_linux-os-c.patch
-
- # To make the hardened compiler NOT compile with -fPIE -pie
- if gcc-specs-pie ; then
- einfo "Disabling PIE..."
- epatch "${FILESDIR}"/gentoo-fix_nopie_for_hardened_toolchain.patch
- fi
-
- cp /usr/share/common-lisp/source/asdf/build/asdf.lisp contrib/asdf/ || die
-
- use source && sed 's%"$(BUILD_ROOT)%$(MODULE).lisp "$(BUILD_ROOT)%' -i contrib/vanilla-module.mk
-
- # Some shells(such as dash) don't have "time" as builtin
- # and we don't want to DEPEND on sys-process/time
- sed "s,^time ,," -i make.sh || die
- sed "s,/lib,/$(get_libdir),g" -i install.sh || die
- # #define SBCL_HOME ...
- sed "s,/usr/local/lib,/usr/$(get_libdir),g" -i src/runtime/runtime.c || die
-
- find . -type f -name .cvsignore -delete
-}
-
-src_configure() {
- # customizing SBCL version as per
- # http://sbcl.cvs.sourceforge.net/sbcl/sbcl/doc/PACKAGING-SBCL.txt?view=markup
- echo -e ";;; Auto-generated by Gentoo\n\"gentoo-${PR}\"" > branch-version.lisp-expr
-
- # applying customizations
- sbcl_apply_features
-}
-
-src_compile() {
- local bindir="${WORKDIR}"/sbcl-binary
-
- strip-unsupported-flags ; filter-flags -fomit-frame-pointer
-
- if host-is-pax ; then
- # To disable PaX on hardened systems
- pax-mark -C "${bindir}"/src/runtime/sbcl
- pax-mark -mr "${bindir}"/src/runtime/sbcl
-
- # Hack to disable PaX on second GENESIS stage
- sed -i -e '/load/!s/^echo \/\/doing warm.*$/&\npaxctl -C \.\/src\/runtime\/sbcl\npaxctl -mprexs \.\/src\/runtime\/sbcl/' \
- "${S}"/make-target-2.sh || die "Cannot disable PaX on second GENESIS runtime"
- fi
-
- # clear the environment to get rid of non-ASCII strings, see bug 174702
- # set HOME for paludis
- env - HOME="${T}" \
- CC="$(tc-getCC)" AS="$(tc-getAS)" LD="$(tc-getLD)" \
- CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}" ASFLAGS="${ASFLAGS}" LDFLAGS="${LDFLAGS}" \
- GNUMAKE=make ./make.sh \
- "sh ${bindir}/run-sbcl.sh --no-sysinit --no-userinit --disable-debugger" \
- || die "make failed"
-
- # need to set HOME because libpango(used by graphviz) complains about it
- if use doc; then
- env - HOME="${T}" \
- CL_SOURCE_REGISTRY="(:source-registry :ignore-inherited-configuration)" \
- ASDF_OUTPUT_TRANSLATIONS="(:output-translations :ignore-inherited-configuration)" \
- make -C doc/manual info html || die "Cannot build manual"
- env - HOME="${T}" \
- CL_SOURCE_REGISTRY="(:source-registry :ignore-inherited-configuration)" \
- ASDF_OUTPUT_TRANSLATIONS="(:output-translations :ignore-inherited-configuration)" \
- make -C doc/internals info html || die "Cannot build internal docs"
- fi
-}
-
-src_test() {
- ewarn "Unfortunately, it is known that some tests fail eg."
- ewarn "run-program.impure.lisp. This is an issue of the upstream's"
- ewarn "development and not of Gentoo's side. Please, before filing"
- ewarn "any bug(s) search for older submissions. Thank you."
- time ( cd tests && sh run-tests.sh )
-}
-
-src_install() {
- # install system-wide initfile
- dodir /etc/
- cat > "${D}"/etc/sbclrc <<EOF
-;;; The following is required if you want source location functions to
-;;; work in SLIME, for example.
-
-(setf (logical-pathname-translations "SYS")
- '(("SYS:SRC;**;*.*.*" #p"/usr/$(get_libdir)/sbcl/src/**/*.*")
- ("SYS:CONTRIB;**;*.*.*" #p"/usr/$(get_libdir)/sbcl/**/*.*")))
-
-;;; Setup ASDF2
-(load "/etc/common-lisp/gentoo-init.lisp")
-EOF
-
- # Install documentation
- unset SBCL_HOME
- INSTALL_ROOT="${D}/usr" LIB_DIR="/usr/$(get_libdir)" DOC_DIR="${D}/usr/share/doc/${PF}" \
- sh install.sh || die "install.sh failed"
-
- # rm empty directories lest paludis complain about this
- find "${D}" -empty -type d -exec rmdir -v {} +
-
- if use doc; then
- dohtml -r doc/manual/
- doinfo doc/manual/*.info*
- dohtml -r doc/internals/sbcl-internals
- doinfo doc/internals/sbcl-internals.info
- docinto internals-notes && dodoc doc/internals-notes/*
- else
- rm -Rv "${D}/usr/share/doc/${PF}" || die
- fi
-
- dodoc BUGS CREDITS INSTALL NEWS OPTIMIZATIONS PRINCIPLES README TLA TODO
-
- # install the SBCL source
- if use source; then
- ./clean.sh
- cp -av src "${D}/usr/$(get_libdir)/sbcl/" || die
- fi
-
- # necessary for running newly-saved images
- echo "SBCL_HOME=/usr/$(get_libdir)/${PN}" > "${ENVD}"
- echo "SBCL_SOURCE_ROOT=/usr/$(get_libdir)/${PN}/src" >> "${ENVD}"
- doenvd "${ENVD}"
-}
diff --git a/dev-lisp/sbcl/sbcl-1.1.11.ebuild b/dev-lisp/sbcl/sbcl-1.1.11.ebuild
deleted file mode 100644
index d4375e8954fa..000000000000
--- a/dev-lisp/sbcl/sbcl-1.1.11.ebuild
+++ /dev/null
@@ -1,204 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.1.11.ebuild,v 1.1 2013/09/12 15:25:44 grozin Exp $
-
-EAPI=5
-inherit multilib eutils flag-o-matic pax-utils
-
-#same order as http://www.sbcl.org/platform-table.html
-BV_X86=1.0.58
-BV_AMD64=1.1.11
-BV_PPC=1.0.28
-BV_SPARC=1.0.28
-BV_ALPHA=1.0.28
-
-DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
-HOMEPAGE="http://sbcl.sourceforge.net/"
-SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
- x86? ( mirror://sourceforge/sbcl/${PN}-${BV_X86}-x86-linux-binary.tar.bz2 )
- amd64? ( mirror://sourceforge/sbcl/${PN}-${BV_AMD64}-x86-64-linux-binary.tar.bz2 )
- ppc? ( mirror://sourceforge/sbcl/${PN}-${BV_PPC}-powerpc-linux-binary.tar.bz2 )
- sparc? ( mirror://sourceforge/sbcl/${PN}-${BV_SPARC}-sparc-linux-binary.tar.bz2 )
- alpha? ( mirror://sourceforge/sbcl/${PN}-${BV_ALPHA}-alpha-linux-binary.tar.bz2 )"
-
-RESTRICT="mirror"
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="debug doc source +threads +unicode zlib"
-
-CDEPEND=">=dev-lisp/asdf-2.33-r3:="
-DEPEND="${CDEPEND}
- doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )"
-RDEPEND="${CDEPEND}
- elibc_glibc? ( >=sys-libs/glibc-2.3 || ( <sys-libs/glibc-2.6[nptl] >=sys-libs/glibc-2.6 ) )"
-
-# Disable warnings about executable stacks, as this won't be fixed soon by upstream
-QA_EXECSTACK="usr/bin/sbcl"
-
-CONFIG="${S}/customize-target-features.lisp"
-ENVD="${T}/50sbcl"
-
-# Prevent ASDF from using the system libraries
-CL_SOURCE_REGISTRY="(:source-registry :ignore-inherited-configuration)"
-ASDF_OUTPUT_TRANSLATIONS="(:output-translations :ignore-inherited-configuration)"
-
-usep() {
- use ${1} && echo "true" || echo "false"
-}
-
-sbcl_feature() {
- echo "$( [[ ${1} == "true" ]] && echo "(enable ${2})" || echo "(disable ${2})")" >> "${CONFIG}"
-}
-
-sbcl_apply_features() {
- cat > "${CONFIG}" <<'EOF'
-(lambda (list)
- (flet ((enable (x) (pushnew x list))
- (disable (x) (setf list (remove x list))))
-EOF
- if use x86 || use amd64; then
- sbcl_feature "$(usep threads)" ":sb-thread"
- fi
- sbcl_feature "true" ":sb-ldb"
- sbcl_feature "false" ":sb-test"
- sbcl_feature "$(usep unicode)" ":sb-unicode"
- sbcl_feature "$(usep zlib)" ":sb-core-compression"
- sbcl_feature "$(usep debug)" ":sb-xref-for-internals"
- cat >> "${CONFIG}" <<'EOF'
- )
- list)
-EOF
- cat "${CONFIG}"
-}
-
-src_unpack() {
- unpack ${A}
- mv sbcl-*-linux sbcl-binary || die
- cd "${S}"
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/gentoo-fix_install_man.patch
- epatch "${FILESDIR}"/gentoo-fix_linux-os-c.patch
-
- # To make the hardened compiler NOT compile with -fPIE -pie
- if gcc-specs-pie ; then
- einfo "Disabling PIE..."
- epatch "${FILESDIR}"/gentoo-fix_nopie_for_hardened_toolchain.patch
- fi
-
- cp /usr/share/common-lisp/source/asdf/build/asdf.lisp contrib/asdf/ || die
-
- use source && sed 's%"$(BUILD_ROOT)%$(MODULE).lisp "$(BUILD_ROOT)%' -i contrib/vanilla-module.mk
-
- # Some shells(such as dash) don't have "time" as builtin
- # and we don't want to DEPEND on sys-process/time
- sed "s,^time ,," -i make.sh || die
- sed "s,/lib,/$(get_libdir),g" -i install.sh || die
- # #define SBCL_HOME ...
- sed "s,/usr/local/lib,/usr/$(get_libdir),g" -i src/runtime/runtime.c || die
-
- find . -type f -name .cvsignore -delete
-}
-
-src_configure() {
- # customizing SBCL version as per
- # http://sbcl.cvs.sourceforge.net/sbcl/sbcl/doc/PACKAGING-SBCL.txt?view=markup
- echo -e ";;; Auto-generated by Gentoo\n\"gentoo-${PR}\"" > branch-version.lisp-expr
-
- # applying customizations
- sbcl_apply_features
-}
-
-src_compile() {
- local bindir="${WORKDIR}"/sbcl-binary
-
- strip-unsupported-flags ; filter-flags -fomit-frame-pointer
-
- if host-is-pax ; then
- # To disable PaX on hardened systems
- pax-mark -C "${bindir}"/src/runtime/sbcl
- pax-mark -mr "${bindir}"/src/runtime/sbcl
-
- # Hack to disable PaX on second GENESIS stage
- sed -i -e '/load/!s/^echo \/\/doing warm.*$/&\npaxctl -C \.\/src\/runtime\/sbcl\npaxctl -mprexs \.\/src\/runtime\/sbcl/' \
- "${S}"/make-target-2.sh || die "Cannot disable PaX on second GENESIS runtime"
- fi
-
- # clear the environment to get rid of non-ASCII strings, see bug 174702
- # set HOME for paludis
- env - HOME="${T}" \
- CC="$(tc-getCC)" AS="$(tc-getAS)" LD="$(tc-getLD)" \
- CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}" ASFLAGS="${ASFLAGS}" LDFLAGS="${LDFLAGS}" \
- GNUMAKE=make ./make.sh \
- "sh ${bindir}/run-sbcl.sh --no-sysinit --no-userinit --disable-debugger" \
- || die "make failed"
-
- # need to set HOME because libpango(used by graphviz) complains about it
- if use doc; then
- env - HOME="${T}" \
- CL_SOURCE_REGISTRY="(:source-registry :ignore-inherited-configuration)" \
- ASDF_OUTPUT_TRANSLATIONS="(:output-translations :ignore-inherited-configuration)" \
- make -C doc/manual info html || die "Cannot build manual"
- env - HOME="${T}" \
- CL_SOURCE_REGISTRY="(:source-registry :ignore-inherited-configuration)" \
- ASDF_OUTPUT_TRANSLATIONS="(:output-translations :ignore-inherited-configuration)" \
- make -C doc/internals info html || die "Cannot build internal docs"
- fi
-}
-
-src_test() {
- ewarn "Unfortunately, it is known that some tests fail eg."
- ewarn "run-program.impure.lisp. This is an issue of the upstream's"
- ewarn "development and not of Gentoo's side. Please, before filing"
- ewarn "any bug(s) search for older submissions. Thank you."
- time ( cd tests && sh run-tests.sh )
-}
-
-src_install() {
- # install system-wide initfile
- dodir /etc/
- cat > "${D}"/etc/sbclrc <<EOF
-;;; The following is required if you want source location functions to
-;;; work in SLIME, for example.
-
-(setf (logical-pathname-translations "SYS")
- '(("SYS:SRC;**;*.*.*" #p"/usr/$(get_libdir)/sbcl/src/**/*.*")
- ("SYS:CONTRIB;**;*.*.*" #p"/usr/$(get_libdir)/sbcl/**/*.*")))
-
-;;; Setup ASDF2
-(load "/etc/common-lisp/gentoo-init.lisp")
-EOF
-
- # Install documentation
- unset SBCL_HOME
- INSTALL_ROOT="${D}/usr" LIB_DIR="/usr/$(get_libdir)" DOC_DIR="${D}/usr/share/doc/${PF}" \
- sh install.sh || die "install.sh failed"
-
- # rm empty directories lest paludis complain about this
- find "${D}" -empty -type d -exec rmdir -v {} +
-
- if use doc; then
- dohtml -r doc/manual/
- doinfo doc/manual/*.info*
- dohtml -r doc/internals/sbcl-internals
- doinfo doc/internals/sbcl-internals.info
- docinto internals-notes && dodoc doc/internals-notes/*
- else
- rm -Rv "${D}/usr/share/doc/${PF}" || die
- fi
-
- dodoc BUGS CREDITS INSTALL NEWS OPTIMIZATIONS PRINCIPLES README TLA TODO
-
- # install the SBCL source
- if use source; then
- ./clean.sh
- cp -av src "${D}/usr/$(get_libdir)/sbcl/" || die
- fi
-
- # necessary for running newly-saved images
- echo "SBCL_HOME=/usr/$(get_libdir)/${PN}" > "${ENVD}"
- echo "SBCL_SOURCE_ROOT=/usr/$(get_libdir)/${PN}/src" >> "${ENVD}"
- doenvd "${ENVD}"
-}
diff --git a/dev-lisp/sbcl/sbcl-1.1.12.ebuild b/dev-lisp/sbcl/sbcl-1.1.12.ebuild
deleted file mode 100644
index 818d876cc06d..000000000000
--- a/dev-lisp/sbcl/sbcl-1.1.12.ebuild
+++ /dev/null
@@ -1,204 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.1.12.ebuild,v 1.3 2013/12/12 10:06:13 nimiux Exp $
-
-EAPI=5
-inherit multilib eutils flag-o-matic pax-utils
-
-#same order as http://www.sbcl.org/platform-table.html
-BV_X86=1.0.58
-BV_AMD64=1.1.12
-BV_PPC=1.0.28
-BV_SPARC=1.0.28
-BV_ALPHA=1.0.28
-
-DESCRIPTION="Steel Bank Common Lisp (SBCL) is an implementation of ANSI Common Lisp."
-HOMEPAGE="http://sbcl.sourceforge.net/"
-SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
- x86? ( mirror://sourceforge/sbcl/${PN}-${BV_X86}-x86-linux-binary.tar.bz2 )
- amd64? ( mirror://sourceforge/sbcl/${PN}-${BV_AMD64}-x86-64-linux-binary.tar.bz2 )
- ppc? ( mirror://sourceforge/sbcl/${PN}-${BV_PPC}-powerpc-linux-binary.tar.bz2 )
- sparc? ( mirror://sourceforge/sbcl/${PN}-${BV_SPARC}-sparc-linux-binary.tar.bz2 )
- alpha? ( mirror://sourceforge/sbcl/${PN}-${BV_ALPHA}-alpha-linux-binary.tar.bz2 )"
-
-RESTRICT="mirror"
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="debug doc source +threads +unicode zlib"
-
-CDEPEND=">=dev-lisp/asdf-2.33-r3:="
-DEPEND="${CDEPEND}
- doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )"
-RDEPEND="${CDEPEND}
- elibc_glibc? ( >=sys-libs/glibc-2.3 || ( <sys-libs/glibc-2.6[nptl] >=sys-libs/glibc-2.6 ) )"
-
-# Disable warnings about executable stacks, as this won't be fixed soon by upstream
-QA_EXECSTACK="usr/bin/sbcl"
-
-CONFIG="${S}/customize-target-features.lisp"
-ENVD="${T}/50sbcl"
-
-# Prevent ASDF from using the system libraries
-CL_SOURCE_REGISTRY="(:source-registry :ignore-inherited-configuration)"
-ASDF_OUTPUT_TRANSLATIONS="(:output-translations :ignore-inherited-configuration)"
-
-usep() {
- use ${1} && echo "true" || echo "false"
-}
-
-sbcl_feature() {
- echo "$( [[ ${1} == "true" ]] && echo "(enable ${2})" || echo "(disable ${2})")" >> "${CONFIG}"
-}
-
-sbcl_apply_features() {
- cat > "${CONFIG}" <<'EOF'
-(lambda (list)
- (flet ((enable (x) (pushnew x list))
- (disable (x) (setf list (remove x list))))
-EOF
- if use x86 || use amd64; then
- sbcl_feature "$(usep threads)" ":sb-thread"
- fi
- sbcl_feature "true" ":sb-ldb"
- sbcl_feature "false" ":sb-test"
- sbcl_feature "$(usep unicode)" ":sb-unicode"
- sbcl_feature "$(usep zlib)" ":sb-core-compression"
- sbcl_feature "$(usep debug)" ":sb-xref-for-internals"
- cat >> "${CONFIG}" <<'EOF'
- )
- list)
-EOF
- cat "${CONFIG}"
-}
-
-src_unpack() {
- unpack ${A}
- mv sbcl-*-linux sbcl-binary || die
- cd "${S}"
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/gentoo-fix_install_man.patch
- epatch "${FILESDIR}"/gentoo-fix_linux-os-c.patch
-
- # To make the hardened compiler NOT compile with -fPIE -pie
- if gcc-specs-pie ; then
- einfo "Disabling PIE..."
- epatch "${FILESDIR}"/gentoo-fix_nopie_for_hardened_toolchain.patch
- fi
-
- cp /usr/share/common-lisp/source/asdf/build/asdf.lisp contrib/asdf/ || die
-
- use source && sed 's%"$(BUILD_ROOT)%$(MODULE).lisp "$(BUILD_ROOT)%' -i contrib/vanilla-module.mk
-
- # Some shells(such as dash) don't have "time" as builtin
- # and we don't want to DEPEND on sys-process/time
- sed "s,^time ,," -i make.sh || die
- sed "s,/lib,/$(get_libdir),g" -i install.sh || die
- # #define SBCL_HOME ...
- sed "s,/usr/local/lib,/usr/$(get_libdir),g" -i src/runtime/runtime.c || die
-
- find . -type f -name .cvsignore -delete
-}
-
-src_configure() {
- # customizing SBCL version as per
- # http://sbcl.cvs.sourceforge.net/sbcl/sbcl/doc/PACKAGING-SBCL.txt?view=markup
- echo -e ";;; Auto-generated by Gentoo\n\"gentoo-${PR}\"" > branch-version.lisp-expr
-
- # applying customizations
- sbcl_apply_features
-}
-
-src_compile() {
- local bindir="${WORKDIR}"/sbcl-binary
-
- strip-unsupported-flags ; filter-flags -fomit-frame-pointer
-
- if host-is-pax ; then
- # To disable PaX on hardened systems
- pax-mark -C "${bindir}"/src/runtime/sbcl
- pax-mark -mr "${bindir}"/src/runtime/sbcl
-
- # Hack to disable PaX on second GENESIS stage
- sed -i -e '/load/!s/^echo \/\/doing warm.*$/&\npaxctl -C \.\/src\/runtime\/sbcl\npaxctl -mprexs \.\/src\/runtime\/sbcl/' \
- "${S}"/make-target-2.sh || die "Cannot disable PaX on second GENESIS runtime"
- fi
-
- # clear the environment to get rid of non-ASCII strings, see bug 174702
- # set HOME for paludis
- env - HOME="${T}" \
- CC="$(tc-getCC)" AS="$(tc-getAS)" LD="$(tc-getLD)" \
- CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}" ASFLAGS="${ASFLAGS}" LDFLAGS="${LDFLAGS}" \
- GNUMAKE=make ./make.sh \
- "sh ${bindir}/run-sbcl.sh --no-sysinit --no-userinit --disable-debugger" \
- || die "make failed"
-
- # need to set HOME because libpango(used by graphviz) complains about it
- if use doc; then
- env - HOME="${T}" \
- CL_SOURCE_REGISTRY="(:source-registry :ignore-inherited-configuration)" \
- ASDF_OUTPUT_TRANSLATIONS="(:output-translations :ignore-inherited-configuration)" \
- make -C doc/manual info html || die "Cannot build manual"
- env - HOME="${T}" \
- CL_SOURCE_REGISTRY="(:source-registry :ignore-inherited-configuration)" \
- ASDF_OUTPUT_TRANSLATIONS="(:output-translations :ignore-inherited-configuration)" \
- make -C doc/internals info html || die "Cannot build internal docs"
- fi
-}
-
-src_test() {
- ewarn "Unfortunately, it is known that some tests fail eg."
- ewarn "run-program.impure.lisp. This is an issue of the upstream's"
- ewarn "development and not of Gentoo's side. Please, before filing"
- ewarn "any bug(s) search for older submissions. Thank you."
- time ( cd tests && sh run-tests.sh )
-}
-
-src_install() {
- # install system-wide initfile
- dodir /etc/
- cat > "${D}"/etc/sbclrc <<EOF
-;;; The following is required if you want source location functions to
-;;; work in SLIME, for example.
-
-(setf (logical-pathname-translations "SYS")
- '(("SYS:SRC;**;*.*.*" #p"/usr/$(get_libdir)/sbcl/src/**/*.*")
- ("SYS:CONTRIB;**;*.*.*" #p"/usr/$(get_libdir)/sbcl/**/*.*")))
-
-;;; Setup ASDF2
-(load "/etc/common-lisp/gentoo-init.lisp")
-EOF
-
- # Install documentation
- unset SBCL_HOME
- INSTALL_ROOT="${D}/usr" LIB_DIR="/usr/$(get_libdir)" DOC_DIR="${D}/usr/share/doc/${PF}" \
- sh install.sh || die "install.sh failed"
-
- # rm empty directories lest paludis complain about this
- find "${D}" -empty -type d -exec rmdir -v {} +
-
- if use doc; then
- dohtml -r doc/manual/
- doinfo doc/manual/*.info*
- dohtml -r doc/internals/sbcl-internals
- doinfo doc/internals/sbcl-internals.info
- docinto internals-notes && dodoc doc/internals-notes/*
- else
- rm -Rv "${D}/usr/share/doc/${PF}" || die
- fi
-
- dodoc BUGS CREDITS INSTALL NEWS OPTIMIZATIONS PRINCIPLES README TLA TODO
-
- # install the SBCL source
- if use source; then
- ./clean.sh
- cp -av src "${D}/usr/$(get_libdir)/sbcl/" || die
- fi
-
- # necessary for running newly-saved images
- echo "SBCL_HOME=/usr/$(get_libdir)/${PN}" > "${ENVD}"
- echo "SBCL_SOURCE_ROOT=/usr/$(get_libdir)/${PN}/src" >> "${ENVD}"
- doenvd "${ENVD}"
-}
diff --git a/dev-lisp/sbcl/sbcl-1.1.14.ebuild b/dev-lisp/sbcl/sbcl-1.1.17.ebuild
index 0788761f1e8c..52c71425d512 100644
--- a/dev-lisp/sbcl/sbcl-1.1.14.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.1.17.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.1.14.ebuild,v 1.2 2014/01/11 11:09:50 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.1.17.ebuild,v 1.1 2014/04/28 03:15:51 grozin Exp $
EAPI=5
inherit multilib eutils flag-o-matic pax-utils
#same order as http://www.sbcl.org/platform-table.html
BV_X86=1.0.58
-BV_AMD64=1.1.14
+BV_AMD64=1.1.17
BV_PPC=1.0.28
BV_SPARC=1.0.28
BV_ALPHA=1.0.28