summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-10-22 11:18:22 +0000
committerTorsten Veller <tove@gentoo.org>2008-10-22 11:18:22 +0000
commite37cfc860284cf2aa2d5c05abe1309406136b972 (patch)
treeca8ce581cff265dccc0485e7457ed11eafa48bff /dev-perl/Mail-DKIM
parentlibdrm should be safe now, and xf86-video-i810-2.4.0 is no longer in portage (diff)
downloadgentoo-2-e37cfc860284cf2aa2d5c05abe1309406136b972.tar.gz
gentoo-2-e37cfc860284cf2aa2d5c05abe1309406136b972.tar.bz2
gentoo-2-e37cfc860284cf2aa2d5c05abe1309406136b972.zip
Version bump. Fixes bug #217370 and bug #217368
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-tuxonice i686)
Diffstat (limited to 'dev-perl/Mail-DKIM')
-rw-r--r--dev-perl/Mail-DKIM/ChangeLog10
-rw-r--r--dev-perl/Mail-DKIM/Mail-DKIM-0.31.ebuild5
-rw-r--r--dev-perl/Mail-DKIM/Mail-DKIM-0.32.ebuild30
3 files changed, 41 insertions, 4 deletions
diff --git a/dev-perl/Mail-DKIM/ChangeLog b/dev-perl/Mail-DKIM/ChangeLog
index 898967f4e1dc..c6b0dcd09f11 100644
--- a/dev-perl/Mail-DKIM/ChangeLog
+++ b/dev-perl/Mail-DKIM/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-perl/Mail-DKIM
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-DKIM/ChangeLog,v 1.18 2008/09/15 11:32:06 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-DKIM/ChangeLog,v 1.19 2008/10/22 11:18:22 tove Exp $
+
+*Mail-DKIM-0.32 (22 Oct 2008)
+
+ 22 Oct 2008; Torsten Veller <tove@gentoo.org> Mail-DKIM-0.31.ebuild,
+ +Mail-DKIM-0.32.ebuild:
+ Version bump. Disable online tests. DEPEND on
+ >=dev-perl/Crypt-OpenSSL-RSA-0.24 (#217370). Remove dev-perl/Error from
+ DEPEND (#217368).
15 Sep 2008; Torsten Veller <tove@gentoo.org> -Mail-DKIM-0.18.ebuild,
-Mail-DKIM-0.19.ebuild, -Mail-DKIM-0.22.ebuild, -Mail-DKIM-0.23.ebuild,
diff --git a/dev-perl/Mail-DKIM/Mail-DKIM-0.31.ebuild b/dev-perl/Mail-DKIM/Mail-DKIM-0.31.ebuild
index 6594b3b7e7cc..db9d9fccd3ac 100644
--- a/dev-perl/Mail-DKIM/Mail-DKIM-0.31.ebuild
+++ b/dev-perl/Mail-DKIM/Mail-DKIM-0.31.ebuild
@@ -1,19 +1,18 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-DKIM/Mail-DKIM-0.31.ebuild,v 1.5 2008/08/29 22:02:41 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-DKIM/Mail-DKIM-0.31.ebuild,v 1.6 2008/10/22 11:18:22 tove Exp $
inherit perl-module
DESCRIPTION="Mail::DKIM - Signs/verifies Internet mail using DKIM message signatures"
SRC_URI="mirror://cpan/authors/id/J/JA/JASLONG/${P}.tar.gz"
HOMEPAGE="http://search.cpan.org/~jaslong/${P}/"
-DEPEND="dev-perl/Crypt-OpenSSL-RSA
+DEPEND=">=dev-perl/Crypt-OpenSSL-RSA-0.24
dev-perl/Digest-SHA
dev-perl/Digest-SHA1
virtual/perl-MIME-Base64
dev-perl/Net-DNS
dev-perl/MailTools
- dev-perl/Error
dev-lang/perl"
SLOT="0"
diff --git a/dev-perl/Mail-DKIM/Mail-DKIM-0.32.ebuild b/dev-perl/Mail-DKIM/Mail-DKIM-0.32.ebuild
new file mode 100644
index 000000000000..01ebd372849e
--- /dev/null
+++ b/dev-perl/Mail-DKIM/Mail-DKIM-0.32.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-DKIM/Mail-DKIM-0.32.ebuild,v 1.1 2008/10/22 11:18:22 tove Exp $
+
+MODULE_AUTHOR=JASLONG
+inherit perl-module
+
+DESCRIPTION="Mail::DKIM - Signs/verifies Internet mail using DKIM message signatures"
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-perl/Crypt-OpenSSL-RSA-0.24
+ dev-perl/Digest-SHA
+ virtual/perl-MIME-Base64
+ dev-perl/Net-DNS
+ dev-perl/MailTools
+ dev-lang/perl"
+
+SRC_TEST="do"
+
+src_test(){
+ # disable online tests
+ for test in policy verifier ; do
+ mv ${S}/t/${test}.t{,.disable}
+ done
+ perl-module_src_test
+}