summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2004-11-02 08:13:46 +0000
committerMichael Cummings <mcummings@gentoo.org>2004-11-02 08:13:46 +0000
commit528f19ebf40253c85de63673218154eae40bd4b1 (patch)
treed9cf554fdeb62f7b9b6e66ecf4f28b61f2f52fd4 /dev-perl/SOAP-Lite
parentMarking stable for x86 and sparc - bug 69764 (Manifest recommit) (diff)
downloadgentoo-2-528f19ebf40253c85de63673218154eae40bd4b1.tar.gz
gentoo-2-528f19ebf40253c85de63673218154eae40bd4b1.tar.bz2
gentoo-2-528f19ebf40253c85de63673218154eae40bd4b1.zip
bug 69248
Diffstat (limited to 'dev-perl/SOAP-Lite')
-rw-r--r--dev-perl/SOAP-Lite/ChangeLog9
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-0.60a-r1.ebuild10
-rw-r--r--dev-perl/SOAP-Lite/files/SOAP-Lite-0.60.a.patch2
3 files changed, 12 insertions, 9 deletions
diff --git a/dev-perl/SOAP-Lite/ChangeLog b/dev-perl/SOAP-Lite/ChangeLog
index b6b2e8d9f394..26a7da7f9158 100644
--- a/dev-perl/SOAP-Lite/ChangeLog
+++ b/dev-perl/SOAP-Lite/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-perl/SOAP-Lite
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.8 2004/10/29 15:29:31 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.9 2004/11/02 08:13:46 mcummings Exp $
+
+ 02 Nov 2004; Michael Cummings <mcummings@gentoo.org>
+ SOAP-Lite-0.60a-r1.ebuild:
+ Still working on bug 69248. I missed the hardcoded call to tests at the bottom
+ of the original - removed; also removed the echo yes in favor of the internal
+ --noprompt argument. This builds cleanly and works fine on both sparc and x86
+ on this end.
*SOAP-Lite-0.60a-r1 (29 Oct 2004)
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-0.60a-r1.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-0.60a-r1.ebuild
index 1a695dbbe169..5dc446786e82 100644
--- a/dev-perl/SOAP-Lite/SOAP-Lite-0.60a-r1.ebuild
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-0.60a-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/SOAP-Lite-0.60a-r1.ebuild,v 1.1 2004/10/29 15:29:31 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/SOAP-Lite-0.60a-r1.ebuild,v 1.2 2004/11/02 08:13:46 mcummings Exp $
IUSE="jabber ssl"
@@ -18,6 +18,8 @@ SLOT="0"
LICENSE="|| ( Artistic GPL-2 )"
KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha"
+myconf="${myconf} --noprompt"
+
# TESTS ARE DISABLED ON PURPOSE
# This module attempts to access an external website for validation
# of the MIME::Parser - not only is that bad practice in general,
@@ -46,9 +48,3 @@ src_unpack() {
# MIME::Parser.
epatch ${FILESDIR}/SOAP-Lite-0.60.a.patch
}
-
-
-src_compile() {
- (echo yes) | perl-module_src_compile || perl-module_src_compile || die "compile failed"
- perl-module_src_test || die "test failed"
-}
diff --git a/dev-perl/SOAP-Lite/files/SOAP-Lite-0.60.a.patch b/dev-perl/SOAP-Lite/files/SOAP-Lite-0.60.a.patch
index 2bcbe767f55e..14a5038fdb98 100644
--- a/dev-perl/SOAP-Lite/files/SOAP-Lite-0.60.a.patch
+++ b/dev-perl/SOAP-Lite/files/SOAP-Lite-0.60.a.patch
@@ -6,7 +6,7 @@ diff -burN SOAP-Lite-0.60/Makefile.PL.old SOAP-Lite-0.60/Makefile.PL
["SSL Support for TCP Transport","SOAP::Transport::TCP",{"IO::Socket::SSL" => 0},0],
["Compression support for HTTP","SOAP::Transport::HTTP",{"Compress::Zlib" => 0},0],
- ["MIME interoperability w/ Axis","SOAP::Lite",{"MIME::Parser" => "6.106"},0],
-+ ["MIME interoperability w/ Axis","SOAP::Lite",{"MIME::Parser" => "5.415"},0],
++ ["MIME interoperability w/ Axis","SOAP::Lite",{"MIME::Parser" => "5.413"},0],
);
use Getopt::Long;