summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-23 04:51:55 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-23 04:51:55 +0000
commit3978db00448be9c29c0a64403e068050a9591c40 (patch)
treecd88465e94801ffd9f1dfc99ff872934975f0f39 /dev-python/hcs-utils
parentVersion bump. (diff)
downloadgentoo-2-3978db00448be9c29c0a64403e068050a9591c40.tar.gz
gentoo-2-3978db00448be9c29c0a64403e068050a9591c40.tar.bz2
gentoo-2-3978db00448be9c29c0a64403e068050a9591c40.zip
bump, been 6 months
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/hcs-utils')
-rw-r--r--dev-python/hcs-utils/ChangeLog7
-rw-r--r--dev-python/hcs-utils/hcs-utils-1.4_rc5.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/hcs-utils/ChangeLog b/dev-python/hcs-utils/ChangeLog
index 92c10f33a101..5392ab38040d 100644
--- a/dev-python/hcs-utils/ChangeLog
+++ b/dev-python/hcs-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/hcs-utils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hcs-utils/ChangeLog,v 1.6 2013/03/17 17:57:16 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hcs-utils/ChangeLog,v 1.7 2013/06/23 04:51:55 idella4 Exp $
+
+*hcs-utils-1.4_rc5 (23 Jun 2013)
+
+ 23 Jun 2013; Ian Delaney <idella4@gentoo.org> +hcs-utils-1.4_rc5.ebuild:
+ bump, been 6 months
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/dev-python/hcs-utils/hcs-utils-1.4_rc5.ebuild b/dev-python/hcs-utils/hcs-utils-1.4_rc5.ebuild
new file mode 100644
index 000000000000..bb2b1050380a
--- /dev/null
+++ b/dev-python/hcs-utils/hcs-utils-1.4_rc5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hcs-utils/hcs-utils-1.4_rc5.ebuild,v 1.1 2013/06/23 04:51:55 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+MY_P=${P/_rc/rc}
+DESCRIPTION="A library containing some useful snippets"
+HOMEPAGE="http://pypi.python.org/pypi/hcs_utils"
+SRC_URI="mirror://pypi/h/${PN/-/_}/${MY_P/-/_}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P/-/_}"
+
+python_test() {
+ cd "${BUILD_DIR}/lib" || die
+ py.test --doctest-modules hcs_utils || die
+}