summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-07-10 00:24:23 +0000
committerJoshua Brindle <method@gentoo.org>2003-07-10 00:24:23 +0000
commite7ebafcba38fd0dec89e974445a1edea99bc93de (patch)
treefb491f8b6c23167c69ed11e4b1387eee050c5d4c /dev-python
parentfixed stuff (diff)
downloadgentoo-2-e7ebafcba38fd0dec89e974445a1edea99bc93de.tar.gz
gentoo-2-e7ebafcba38fd0dec89e974445a1edea99bc93de.tar.bz2
gentoo-2-e7ebafcba38fd0dec89e974445a1edea99bc93de.zip
fixed stuff
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-selinux/ChangeLog8
-rw-r--r--dev-python/python-selinux/Manifest4
-rw-r--r--dev-python/python-selinux/files/digest-python-selinux-1.0-r1 (renamed from dev-python/python-selinux/files/digest-python-selinux-1.0)0
-rw-r--r--dev-python/python-selinux/python-selinux-1.0-r1.ebuild (renamed from dev-python/python-selinux/python-selinux-1.0.ebuild)8
4 files changed, 14 insertions, 6 deletions
diff --git a/dev-python/python-selinux/ChangeLog b/dev-python/python-selinux/ChangeLog
index af4f3c4cc84b..b9f6dbffda40 100644
--- a/dev-python/python-selinux/ChangeLog
+++ b/dev-python/python-selinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-selinux
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.1 2003/07/04 01:05:44 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.2 2003/07/10 00:24:19 method Exp $
+
+*python-selinux-1.0-r1 (09 Jul 2003)
+
+ 09 Jul 2003; Joshua Brindle <method@gentoo.org>
+ python-selinux-1.0-r1.ebuild:
+ wow, what was i thinking with that ebuild, this one should really work
*python-selinux-1.0 (03 Jul 2003)
diff --git a/dev-python/python-selinux/Manifest b/dev-python/python-selinux/Manifest
index 28e75dbf35f6..8dd4bc59b1ed 100644
--- a/dev-python/python-selinux/Manifest
+++ b/dev-python/python-selinux/Manifest
@@ -1,4 +1,4 @@
-MD5 e89003755c0049a295da73c879e7792a python-selinux-1.0-r1.ebuild 720
-MD5 a3963e941c121f92f339ceaeecead336 ChangeLog 408
+MD5 afbd1cf62fa9f3d52ea9f0de38d5693b python-selinux-1.0-r1.ebuild 723
+MD5 b3f7051be1ae0b47fa182e948873285a ChangeLog 603
MD5 f182ab46e74041b1e72cc2f0e31d09d7 metadata.xml 418
MD5 41ce3631984a8e2bf2dc1a9ea66a7315 files/digest-python-selinux-1.0-r1 69
diff --git a/dev-python/python-selinux/files/digest-python-selinux-1.0 b/dev-python/python-selinux/files/digest-python-selinux-1.0-r1
index 942de1aeb32b..942de1aeb32b 100644
--- a/dev-python/python-selinux/files/digest-python-selinux-1.0
+++ b/dev-python/python-selinux/files/digest-python-selinux-1.0-r1
diff --git a/dev-python/python-selinux/python-selinux-1.0.ebuild b/dev-python/python-selinux/python-selinux-1.0-r1.ebuild
index bbfb4e7f58e0..a5a4290bdd93 100644
--- a/dev-python/python-selinux/python-selinux-1.0.ebuild
+++ b/dev-python/python-selinux/python-selinux-1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-1.0.ebuild,v 1.1 2003/07/04 01:05:44 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-1.0-r1.ebuild,v 1.1 2003/07/10 00:24:19 method Exp $
DESCRIPTION="Python bindings for SELinux functions"
HOMEPAGE="http://selinux.dev.gentoo.org/python"
@@ -14,12 +14,14 @@ IUSE="selinux"
DEPEND="sys-apps/selinux-small"
RDEPEND="sys-apps/selinux-small"
-S=${WORKDIR}/${P}
+S=${WORKDIR}/${PN}
src_compile() {
+ cd ${S}
gcc -shared -o selinux.so -I /usr/include/python2.2/ selinux.c -lsecure
}
src_install() {
- cp selinux.so /usr/lib/python2.2/site-packages
+ insinto /usr/lib/python2.2/site-packages
+ doins selinux.so
}