summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-10-05 17:58:15 +0000
committerHans de Graaff <graaff@gentoo.org>2011-10-05 17:58:15 +0000
commite99a46de0b127783af54ee6e91c2c469553c06d2 (patch)
tree2875cf393f26d0cda2cae20472cb0d34da16e9cc /dev-ruby/actionpack/actionpack-3.0.7.ebuild
parentppc stable wrt #369909 (diff)
downloadgentoo-2-e99a46de0b127783af54ee6e91c2c469553c06d2.tar.gz
gentoo-2-e99a46de0b127783af54ee6e91c2c469553c06d2.tar.bz2
gentoo-2-e99a46de0b127783af54ee6e91c2c469553c06d2.zip
Remove old versions.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/actionpack/actionpack-3.0.7.ebuild')
-rw-r--r--dev-ruby/actionpack/actionpack-3.0.7.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-ruby/actionpack/actionpack-3.0.7.ebuild b/dev-ruby/actionpack/actionpack-3.0.7.ebuild
deleted file mode 100644
index 7dbc3b95603a..000000000000
--- a/dev-ruby/actionpack/actionpack-3.0.7.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.0.7.ebuild,v 1.2 2011/07/23 07:34:11 graaff Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ree18"
-
-# The default test task tries to test activerecord with SQLite as well.
-RUBY_FAKEGEM_TASK_TEST="test_action_pack"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Eases web-request routing, handling, and response."
-HOMEPAGE="http://rubyforge.org/projects/actionpack/"
-SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="3.0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-S="${WORKDIR}/rails-rails-*/actionpack"
-
-ruby_add_rdepend "
- ~dev-ruby/activemodel-${PV}
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/builder-2.1.2:0
- >=dev-ruby/erubis-2.6.6
- >=dev-ruby/i18n-0.5.0:0.5
- >=dev-ruby/rack-1.2.1:1.2
- >=dev-ruby/rack-mount-0.6.14
- >=dev-ruby/rack-test-0.5.7:0.5
- >=dev-ruby/tzinfo-0.3.23"
-
-ruby_add_bdepend "
- test? (
- ~dev-ruby/activerecord-${PV}
- ~dev-ruby/actionmailer-${PV}
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-
- # Loosen erubis and rack-mount dependencies since these are not slotted.
- sed -i -e 's/~> 2.6.6/>= 2.6.6/' -e 's/~> 0.6.14/>= 0.6.14/' actionpack.gemspec || die
-}