summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-18 05:44:06 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-18 05:44:06 +0000
commitc0e31923676f86b09e19851f9429bf6098c61c33 (patch)
tree508b4a860abf0afe7e6d0f8e2478c9276606ff15 /dev-ruby/multi_json
parentRe-enabling test suite that now actually works (diff)
downloadgentoo-2-c0e31923676f86b09e19851f9429bf6098c61c33.tar.gz
gentoo-2-c0e31923676f86b09e19851f9429bf6098c61c33.tar.bz2
gentoo-2-c0e31923676f86b09e19851f9429bf6098c61c33.zip
Version bump.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/multi_json')
-rw-r--r--dev-ruby/multi_json/ChangeLog7
-rw-r--r--dev-ruby/multi_json/multi_json-1.6.1.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-ruby/multi_json/ChangeLog b/dev-ruby/multi_json/ChangeLog
index 23a51f0a91fb..4c0044eb61a5 100644
--- a/dev-ruby/multi_json/ChangeLog
+++ b/dev-ruby/multi_json/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/multi_json
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.26 2013/01/16 01:13:11 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.27 2013/07/18 05:44:06 graaff Exp $
+
+*multi_json-1.6.1 (18 Jul 2013)
+
+ 18 Jul 2013; Hans de Graaff <graaff@gentoo.org> +multi_json-1.6.1.ebuild:
+ Version bump.
16 Jan 2013; Rick Farina <zerochaos@gentoo.org> multi_json-1.3.6.ebuild,
multi_json-1.3.7.ebuild, multi_json-1.4.0.ebuild, multi_json-1.5.0.ebuild:
diff --git a/dev-ruby/multi_json/multi_json-1.6.1.ebuild b/dev-ruby/multi_json/multi_json-1.6.1.ebuild
new file mode 100644
index 000000000000..44a0afb99b89
--- /dev/null
+++ b/dev-ruby/multi_json/multi_json-1.6.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-1.6.1.ebuild,v 1.1 2013/07/18 05:44:06 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="http://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-0.7 =dev-ruby/activesupport-3* )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec:2 dev-ruby/yard )"
+
+ruby_add_bdepend "test? ( dev-ruby/json )"
+
+USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile spec/helper.rb || die "Unable to remove bundler."
+ rm Gemfile || die "Unable to remove bundler Gemfile."
+
+ # Remove unimportant rspec options not supported by rspec 2.6.
+ rm .rspec || die
+
+ # Remove specs specific to oj since we don't package oj yet.
+ sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' spec/multi_json_spec.rb || die
+ sed -i -e '/Oj does not create symbols on parse/,/^ end/ s:^:#:' spec/multi_json_spec.rb
+
+ # Contains hardcoded yajl reference with no special case for jruby
+ sed -i -e '/can set adapter for a block/,/^ end/ s:^:#:' spec/multi_json_spec.rb || die
+
+ # Avoid simplecov which only works with ruby 1.9
+ sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/helper.rb || die
+
+ # Remove unpackaged and for our purposes unneeded coveralls
+ sed -i -e '/coveralls/d' spec/helper.rb || die
+}
+
+each_ruby_test() {
+ CI=true each_fakegem_test
+}