summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-07-02 08:13:33 +0000
committerHans de Graaff <graaff@gentoo.org>2014-07-02 08:13:33 +0000
commit0d4f5f09556f7326c5e966b41b909a785d41bbf1 (patch)
tree970b2754f20b7c44810bfebaceadd7f941be703f /dev-ruby/will_paginate
parentLoosen transformers dep in file-location-0.4.5.2-r1 (diff)
downloadgentoo-2-0d4f5f09556f7326c5e966b41b909a785d41bbf1.tar.gz
gentoo-2-0d4f5f09556f7326c5e966b41b909a785d41bbf1.tar.bz2
gentoo-2-0d4f5f09556f7326c5e966b41b909a785d41bbf1.zip
Add ruby20.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/will_paginate')
-rw-r--r--dev-ruby/will_paginate/ChangeLog5
-rw-r--r--dev-ruby/will_paginate/will_paginate-3.0.5.ebuild8
2 files changed, 10 insertions, 3 deletions
diff --git a/dev-ruby/will_paginate/ChangeLog b/dev-ruby/will_paginate/ChangeLog
index 83abc68e9212..5a592661b2b2 100644
--- a/dev-ruby/will_paginate/ChangeLog
+++ b/dev-ruby/will_paginate/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/will_paginate
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/ChangeLog,v 1.25 2014/06/29 06:41:12 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/ChangeLog,v 1.26 2014/07/02 08:13:33 graaff Exp $
+
+ 02 Jul 2014; Hans de Graaff <graaff@gentoo.org> will_paginate-3.0.5.ebuild:
+ Add ruby20.
*will_paginate-3.0.6 (29 Jun 2014)
diff --git a/dev-ruby/will_paginate/will_paginate-3.0.5.ebuild b/dev-ruby/will_paginate/will_paginate-3.0.5.ebuild
index c13439ee9feb..bcf48117b260 100644
--- a/dev-ruby/will_paginate/will_paginate-3.0.5.ebuild
+++ b/dev-ruby/will_paginate/will_paginate-3.0.5.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/will_paginate-3.0.5.ebuild,v 1.2 2014/04/19 03:23:13 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/will_paginate-3.0.5.ebuild,v 1.3 2014/07/02 08:13:33 graaff Exp $
EAPI=5
-USE_RUBY="ruby19"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
@@ -25,3 +25,7 @@ ruby_add_bdepend "
=dev-ruby/rails-3*
dev-ruby/mocha
)"
+
+all_ruby_prepare() {
+ sed -e '1igem "rails", "~> 3.2.0"' -i spec/spec_helper.rb || die
+}