summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-23 10:38:07 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-23 10:38:07 +0000
commitbcd827920a2b94cb2786b41482714b033a7275d0 (patch)
tree2a6d4d31d11f183f99b87e6fd4211618748466e7 /dev-util/boa-constructor
parentAdded GNU GPL version 1 (diff)
downloadgentoo-2-bcd827920a2b94cb2786b41482714b033a7275d0.tar.gz
gentoo-2-bcd827920a2b94cb2786b41482714b033a7275d0.tar.bz2
gentoo-2-bcd827920a2b94cb2786b41482714b033a7275d0.zip
repoman'd
Diffstat (limited to 'dev-util/boa-constructor')
-rw-r--r--dev-util/boa-constructor/boa-constructor-0.1.0_alpha.ebuild66
1 files changed, 34 insertions, 32 deletions
diff --git a/dev-util/boa-constructor/boa-constructor-0.1.0_alpha.ebuild b/dev-util/boa-constructor/boa-constructor-0.1.0_alpha.ebuild
index 5a3cd120f0ec..0fa7a0dee72c 100644
--- a/dev-util/boa-constructor/boa-constructor-0.1.0_alpha.ebuild
+++ b/dev-util/boa-constructor/boa-constructor-0.1.0_alpha.ebuild
@@ -1,49 +1,51 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boa-constructor/boa-constructor-0.1.0_alpha.ebuild,v 1.3 2002/07/11 06:30:24 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boa-constructor/boa-constructor-0.1.0_alpha.ebuild,v 1.4 2002/07/23 10:38:06 seemant Exp $
+BOA_VER=0.1.0-alpha
+S=${WORKDIR}/boa
DESCRIPTION="Python GUI RAD development tool."
HOMEPAGE="http://boa-constructor.sourceforge.net/"
-
-BOA_VER=0.1.0-alpha
SRC_URI="mirror://sourceforge/boa-constructor/${PN}-${BOA_VER}.src.zip"
-S="${WORKDIR}"/boa
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
RDEPEND=">=dev-lang/python-2.0
- >=dev-python/wxPython-2.3
- dev-libs/expat"
+ >=dev-python/wxPython-2.3
+ dev-libs/expat"
DEPEND="${RDEPEND}
- app-arch/unzip"
+ app-arch/unzip"
src_compile() {
- python -c "import compileall; compileall.compile_dir('.', force=1)"
+ python -c "import compileall; compileall.compile_dir('.', force=1)"
}
src_install () {
- local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
- local boadir="/usr/lib/python${pv}/site-packages/boa"
-
- local dir
- for dir in `find . -type d`
- do
- insinto "${boadir}/${dir}"
- cd "${dir}"
- local file
- for file in *
- do
- [ -f "${file}" ] && doins "${file}"
- done
- cd "${S}"
- done
-
- insinto "${boadir}"
- doins *.cfg
- insinto "${boadir}/Plug-ins"
- doins Plug-ins/*
-
- dobin "${FILESDIR}/boa-constructor"
-
- dodoc Bugs.txt Changes.txt Credits.txt PYTHONSTARTUP README.txt
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+ local boadir="/usr/lib/python${pv}/site-packages/boa"
+
+ local dir
+ for dir in `find . -type d`
+ do
+ insinto "${boadir}/${dir}"
+ cd "${dir}"
+ local file
+ for file in *
+ do
+ [ -f "${file}" ] && doins "${file}"
+ done
+ cd "${S}"
+ done
+
+ insinto "${boadir}"
+ doins *.cfg
+ insinto "${boadir}/Plug-ins"
+ doins Plug-ins/*
+
+ dobin "${FILESDIR}/boa-constructor"
+
+ dodoc Bugs.txt Changes.txt Credits.txt PYTHONSTARTUP README.txt
}