summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2007-03-08 16:00:12 +0000
committerMarien Zwart <marienz@gentoo.org>2007-03-08 16:00:12 +0000
commitab1cabbcaa71e9f9e2d936935eeb663d19080f34 (patch)
tree45ba299eab7a1ed71f6ecd86c5267080a3a37628 /dev-util/buildbot
parentTesting for infra. (diff)
downloadgentoo-2-ab1cabbcaa71e9f9e2d936935eeb663d19080f34.tar.gz
gentoo-2-ab1cabbcaa71e9f9e2d936935eeb663d19080f34.tar.bz2
gentoo-2-ab1cabbcaa71e9f9e2d936935eeb663d19080f34.zip
Fix tests without FEATURES=userpriv. No bump since it only affects the tests.
(Portage version: 2.1.2.1-r1)
Diffstat (limited to 'dev-util/buildbot')
-rw-r--r--dev-util/buildbot/ChangeLog6
-rw-r--r--dev-util/buildbot/buildbot-0.7.5.ebuild9
-rw-r--r--dev-util/buildbot/files/buildbot-0.7.5-root-skip-tests.patch13
3 files changed, 26 insertions, 2 deletions
diff --git a/dev-util/buildbot/ChangeLog b/dev-util/buildbot/ChangeLog
index 1d9d433ff858..a8b0ef8051c8 100644
--- a/dev-util/buildbot/ChangeLog
+++ b/dev-util/buildbot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/buildbot
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.6 2007/03/05 03:20:30 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.7 2007/03/08 16:00:12 marienz Exp $
+
+ 08 Mar 2007; Marien Zwart <marienz@gentoo.org>
+ +files/buildbot-0.7.5-root-skip-tests.patch, buildbot-0.7.5.ebuild:
+ Fix tests without FEATURES=userpriv. No bump since it only affects the tests.
05 Mar 2007; Marius Mauch <genone@gentoo.org> buildbot-0.7.4.ebuild,
buildbot-0.7.5.ebuild:
diff --git a/dev-util/buildbot/buildbot-0.7.5.ebuild b/dev-util/buildbot/buildbot-0.7.5.ebuild
index 0a15dbf1af4b..c1d864f73e5b 100644
--- a/dev-util/buildbot/buildbot-0.7.5.ebuild
+++ b/dev-util/buildbot/buildbot-0.7.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.7.5.ebuild,v 1.3 2007/03/05 03:20:30 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.7.5.ebuild,v 1.4 2007/03/08 16:00:12 marienz Exp $
inherit distutils eutils
@@ -27,6 +27,13 @@ pkg_setup() {
enewuser buildbot
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-root-skip-tests.patch"
+}
+
src_compile() {
distutils_src_compile
if use doc; then
diff --git a/dev-util/buildbot/files/buildbot-0.7.5-root-skip-tests.patch b/dev-util/buildbot/files/buildbot-0.7.5-root-skip-tests.patch
new file mode 100644
index 000000000000..b180506318e1
--- /dev/null
+++ b/dev-util/buildbot/files/buildbot-0.7.5-root-skip-tests.patch
@@ -0,0 +1,13 @@
+=== modified file 'buildbot/test/test_vc.py'
+--- buildbot/test/test_vc.py 2007-03-08 15:34:45 +0000
++++ buildbot/test/test_vc.py 2007-03-08 15:38:45 +0000
+@@ -1083,6 +1083,8 @@
+ try_branchname = "branch"
+
+ def capable(self):
++ if not os.geteuid():
++ return (False, "CVS tests fail as root")
+ cvspaths = which('cvs')
+ if not cvspaths:
+ return (False, "CVS is not installed")
+