summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2008-02-11 11:20:02 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2008-02-11 11:20:02 +0000
commit6b88133023aa238c70f92d4725de105d0c2aa7c9 (patch)
treee82e64c7c2af495e2ad4b923ffa6c1d4e26d0cbe /dev-util/cdecl
parentAdded webpy-0.23 to the tree. (diff)
downloadgentoo-2-6b88133023aa238c70f92d4725de105d0c2aa7c9.tar.gz
gentoo-2-6b88133023aa238c70f92d4725de105d0c2aa7c9.tar.bz2
gentoo-2-6b88133023aa238c70f92d4725de105d0c2aa7c9.zip
Fixing dependencies, bug #195885
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-util/cdecl')
-rw-r--r--dev-util/cdecl/ChangeLog9
-rw-r--r--dev-util/cdecl/cdecl-2.5-r1.ebuild22
2 files changed, 20 insertions, 11 deletions
diff --git a/dev-util/cdecl/ChangeLog b/dev-util/cdecl/ChangeLog
index 3ebfa9c9d450..a105b1d22355 100644
--- a/dev-util/cdecl/ChangeLog
+++ b/dev-util/cdecl/ChangeLog
@@ -1,11 +1,14 @@
# ChangeLog for dev-util/cdecl
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cdecl/ChangeLog,v 1.11 2007/06/04 12:10:56 phosphan Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cdecl/ChangeLog,v 1.12 2008/02/11 11:20:02 phosphan Exp $
+
+ 11 Feb 2008; Patrick Kursawe <phosphan@gentoo.org> cdecl-2.5-r1.ebuild:
+ Works with bison, fixed dependencies, see bug #159885
04 Jun 2007; Patrick Kursawe <phosphan@gentoo.org> cdecl-2.5-r1.ebuild:
Homepage adjusted, bug #179548
- 22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
+ 22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
29 Apr 2006; Jason Wever <weeve@gentoo.org> cdecl-2.5-r1.ebuild:
diff --git a/dev-util/cdecl/cdecl-2.5-r1.ebuild b/dev-util/cdecl/cdecl-2.5-r1.ebuild
index 007ac7b5bd0e..15f429398b1e 100644
--- a/dev-util/cdecl/cdecl-2.5-r1.ebuild
+++ b/dev-util/cdecl/cdecl-2.5-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cdecl/cdecl-2.5-r1.ebuild,v 1.12 2007/07/12 01:05:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cdecl/cdecl-2.5-r1.ebuild,v 1.13 2008/02/11 11:20:02 phosphan Exp $
inherit eutils
@@ -12,18 +12,24 @@ KEYWORDS="~amd64 ~mips ~ppc sparc x86"
LICENSE="public-domain"
SLOT="0"
-DEPEND=">=sys-apps/sed-4
- dev-util/yacc
- readline? ( sys-libs/ncurses
- sys-libs/readline )
+RDEPEND="readline? (
+ sys-libs/ncurses
+ sys-libs/readline
+ )"
+
+DEPEND="${RDEPEND}
+ || (
+ dev-util/yacc
+ sys-devel/bison
+ )
!<dev-util/cutils-1.6-r2"
IUSE="readline"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${P}.patch"
}
src_compile() {