summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-07-18 17:25:40 +0000
committerJeroen Roovers <jer@gentoo.org>2012-07-18 17:25:40 +0000
commit38d1b6c64ca852a05b31bbdcaf0854e2ba92f934 (patch)
tree6bd945d74d23e28bffe6842b6f4bef2a23a87c34 /dev-util
parentVersion bump. (diff)
downloadgentoo-2-38d1b6c64ca852a05b31bbdcaf0854e2ba92f934.tar.gz
gentoo-2-38d1b6c64ca852a05b31bbdcaf0854e2ba92f934.tar.bz2
gentoo-2-38d1b6c64ca852a05b31bbdcaf0854e2ba92f934.zip
Version bump. Do not install VERSION.
(Portage version: 2.2.0_alpha119/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/dialog/ChangeLog7
-rw-r--r--dev-util/dialog/dialog-1.1.20120706.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/dev-util/dialog/ChangeLog b/dev-util/dialog/ChangeLog
index fff7ee2f7b05..f186656d58c8 100644
--- a/dev-util/dialog/ChangeLog
+++ b/dev-util/dialog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/dialog
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/ChangeLog,v 1.159 2012/07/08 15:09:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/ChangeLog,v 1.160 2012/07/18 17:25:40 jer Exp $
+
+*dialog-1.1.20120706 (18 Jul 2012)
+
+ 18 Jul 2012; Jeroen Roovers <jer@gentoo.org> +dialog-1.1.20120706.ebuild:
+ Version bump. Do not install VERSION.
08 Jul 2012; Raúl Porcel <armin76@gentoo.org> dialog-1.1.20120215.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #417669
diff --git a/dev-util/dialog/dialog-1.1.20120706.ebuild b/dev-util/dialog/dialog-1.1.20120706.ebuild
new file mode 100644
index 000000000000..187f4054b01e
--- /dev/null
+++ b/dev-util/dialog/dialog-1.1.20120706.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/dialog-1.1.20120706.ebuild,v 1.1 2012/07/18 17:25:40 jer Exp $
+
+EAPI="4"
+
+inherit multilib
+
+MY_PV="${PV/1.1./1.1-}"
+S=${WORKDIR}/${PN}-${MY_PV}
+DESCRIPTION="tool to display dialog boxes from a shell"
+HOMEPAGE="http://invisible-island.net/dialog/dialog.html"
+SRC_URI="ftp://invisible-island.net/${PN}/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="examples minimal nls static-libs unicode"
+
+RDEPEND="
+ >=app-shells/bash-2.04-r3
+ !unicode? ( >=sys-libs/ncurses-5.2-r5 )
+ unicode? ( >=sys-libs/ncurses-5.2-r5[unicode] )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ !minimal? ( sys-devel/libtool )
+ !<=sys-freebsd/freebsd-contrib-8.9999
+"
+
+src_prepare() {
+ sed -i configure -e '/LIB_CREATE=/s:${CC}:& ${LDFLAGS}:g' || die
+}
+
+src_configure() {
+ local ncursesw
+ use unicode && ncursesw="w"
+ econf \
+ --disable-rpath-hack \
+ $(use_enable nls) \
+ $(use_with !minimal libtool) \
+ --with-ncurses${ncursesw}
+}
+
+src_install() {
+ if use minimal; then
+ emake DESTDIR="${D}" install
+ else
+ emake DESTDIR="${D}" install-full
+ fi
+
+ dodoc CHANGES README
+
+ if use examples; then
+ docinto samples
+ dodoc $( find samples -maxdepth 1 -type f )
+ docinto samples/copifuncs
+ dodoc $( find samples/copifuncs -maxdepth 1 -type f )
+ docinto samples/install
+ dodoc $( find samples/install -type f )
+ fi
+
+ if ! use static-libs; then
+ rm -f \
+ "${D}"usr/$(get_libdir)/libdialog.a \
+ "${D}"usr/$(get_libdir)/libdialog.la
+ fi
+}