summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-05-12 06:30:55 +0000
committerTim Harder <radhermit@gentoo.org>2012-05-12 06:30:55 +0000
commitd3fa91311a59ce465df819c94f8ca7b0f42fa510 (patch)
treea568b3dcf735ccd2c0ba3463b1758f8abedc49b4 /dev-vcs/tig
parentRemove old. (diff)
downloadgentoo-2-d3fa91311a59ce465df819c94f8ca7b0f42fa510.tar.gz
gentoo-2-d3fa91311a59ce465df819c94f8ca7b0f42fa510.tar.bz2
gentoo-2-d3fa91311a59ce465df819c94f8ca7b0f42fa510.zip
Version bump.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/tig')
-rw-r--r--dev-vcs/tig/ChangeLog9
-rw-r--r--dev-vcs/tig/tig-1.0.ebuild27
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-vcs/tig/ChangeLog b/dev-vcs/tig/ChangeLog
index 0abfcd79bb9f..b2ba817ecc40 100644
--- a/dev-vcs/tig/ChangeLog
+++ b/dev-vcs/tig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/tig
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.13 2011/11/03 04:35:17 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.14 2012/05/12 06:30:55 radhermit Exp $
+
+*tig-1.0 (12 May 2012)
+
+ 12 May 2012; Tim Harder <radhermit@gentoo.org> +tig-1.0.ebuild:
+ Version bump.
03 Nov 2011; Tim Harder <radhermit@gentoo.org> -tig-0.17.ebuild:
Remove old.
diff --git a/dev-vcs/tig/tig-1.0.ebuild b/dev-vcs/tig/tig-1.0.ebuild
new file mode 100644
index 000000000000..8642acb8ea48
--- /dev/null
+++ b/dev-vcs/tig/tig-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-1.0.ebuild,v 1.1 2012/05/12 06:30:55 radhermit Exp $
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="Tig: text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc BUGS NEWS
+ dohtml manual.html README.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+}