summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2010-06-04 00:15:24 +0000
committerMike Auty <ikelos@gentoo.org>2010-06-04 00:15:24 +0000
commit1e9424905675a5bd09db5a84c7022683aafc52a5 (patch)
tree1610ea3f3cabda255054ef79dabad9335d583b6f /dev-vcs
parentFix bug 320533. Thanks to Fabiano Francesconi. (diff)
downloadgentoo-2-1e9424905675a5bd09db5a84c7022683aafc52a5.tar.gz
gentoo-2-1e9424905675a5bd09db5a84c7022683aafc52a5.tar.bz2
gentoo-2-1e9424905675a5bd09db5a84c7022683aafc52a5.zip
Version bump giggle to 0.5.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/giggle/ChangeLog7
-rw-r--r--dev-vcs/giggle/giggle-0.5.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-vcs/giggle/ChangeLog b/dev-vcs/giggle/ChangeLog
index 9f3e86e00ca2..24692fde0063 100644
--- a/dev-vcs/giggle/ChangeLog
+++ b/dev-vcs/giggle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/giggle
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/giggle/ChangeLog,v 1.3 2010/03/21 10:40:01 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/giggle/ChangeLog,v 1.4 2010/06/04 00:15:24 ikelos Exp $
+
+*giggle-0.5 (04 Jun 2010)
+
+ 04 Jun 2010; Mike Auty <ikelos@gentoo.org> +giggle-0.5.ebuild:
+ Version bump giggle to 0.5.
21 Mar 2010; Mike Auty <ikelos@gentoo.org> giggle-0.4.96.ebuild:
Add in x11-libs/vte to giggle's dependencies, bug 308393.
diff --git a/dev-vcs/giggle/giggle-0.5.ebuild b/dev-vcs/giggle/giggle-0.5.ebuild
new file mode 100644
index 000000000000..64070727a9ff
--- /dev/null
+++ b/dev-vcs/giggle/giggle-0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/giggle/giggle-0.5.ebuild,v 1.1 2010/06/04 00:15:24 ikelos Exp $
+
+EAPI="1"
+
+inherit autotools gnome2
+
+DESCRIPTION="GTK+ Frontend for GIT"
+HOMEPAGE="http://live.gnome.org/giggle"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="eds"
+
+RDEPEND=">=dev-vcs/git-1.5
+ >=dev-libs/glib-2.18
+ >=x11-libs/gtk+-2.10
+ >=x11-libs/gtksourceview-2.8
+ eds? ( gnome-extra/evolution-data-server )
+ >=gnome-base/libglade-2.4
+ >=x11-libs/vte-0.17"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.15
+ >=dev-util/intltool-0.35
+ >=sys-devel/autoconf-2.64
+ >=sys-devel/libtool-2"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+G2CONF="$(use_enable eds evolution-data-server)"
+
+src_unpack() {
+ gnome2_src_unpack
+ cd "${S}"
+ eautoreconf
+}