summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-03 07:50:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-03 07:50:38 +0000
commit4da674f457f94fb565ee0928a7fd03f86d834068 (patch)
tree2eaa0f6be34ce1981aeb0a6facdea1a71d0a1aac /games-action
parentsed in unpack; fix use invocation; tidy (Manifest recommit) (diff)
downloadgentoo-2-4da674f457f94fb565ee0928a7fd03f86d834068.tar.gz
gentoo-2-4da674f457f94fb565ee0928a7fd03f86d834068.tar.bz2
gentoo-2-4da674f457f94fb565ee0928a7fd03f86d834068.zip
die backticks
Diffstat (limited to 'games-action')
-rw-r--r--games-action/bombermaze/ChangeLog6
-rw-r--r--games-action/bombermaze/bombermaze-0.6.6.ebuild10
-rw-r--r--games-action/d2x/d2x-0.2.5.ebuild6
3 files changed, 13 insertions, 9 deletions
diff --git a/games-action/bombermaze/ChangeLog b/games-action/bombermaze/ChangeLog
index cf71499d4f95..c6f221434c3c 100644
--- a/games-action/bombermaze/ChangeLog
+++ b/games-action/bombermaze/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/bombermaze
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bombermaze/ChangeLog,v 1.3 2004/02/03 00:10:21 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bombermaze/ChangeLog,v 1.4 2004/06/03 07:48:23 mr_bones_ Exp $
+
+ 03 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ bombermaze-0.6.6.ebuild:
+ die backticks
02 Feb 2004; Michael Sterrett <mr_bones_@gentoo.org>
bombermaze-0.6.6.ebuild:
diff --git a/games-action/bombermaze/bombermaze-0.6.6.ebuild b/games-action/bombermaze/bombermaze-0.6.6.ebuild
index 006c1eb20aa7..aecbe60675a2 100644
--- a/games-action/bombermaze/bombermaze-0.6.6.ebuild
+++ b/games-action/bombermaze/bombermaze-0.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bombermaze/bombermaze-0.6.6.ebuild,v 1.3 2004/02/08 05:42:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bombermaze/bombermaze-0.6.6.ebuild,v 1.4 2004/06/03 07:48:23 mr_bones_ Exp $
inherit flag-o-matic
@@ -20,18 +20,18 @@ DEPEND="${RDEPEND}
src_compile() {
# It normally fails to locate gdk-pixbuf.h
- append-flags `gdk-pixbuf-config --cflags`
+ append-flags $(gdk-pixbuf-config --cflags)
./configure \
--host=${CHOST} \
--prefix=/usr \
--with-included-gettext \
- `use_enable nls` || die "./configure failed"
+ $(use_enable nls) || die "./configure failed"
emake || die "emake failed"
}
src_install() {
- make prefix=${D}/usr install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS TODO || die "dodoc failed"
+ make prefix="${D}/usr" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS TODO
}
diff --git a/games-action/d2x/d2x-0.2.5.ebuild b/games-action/d2x/d2x-0.2.5.ebuild
index c77cd4089d6a..9857961303a7 100644
--- a/games-action/d2x/d2x-0.2.5.ebuild
+++ b/games-action/d2x/d2x-0.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5.ebuild,v 1.4 2004/03/31 06:53:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5.ebuild,v 1.5 2004/06/03 07:50:38 mr_bones_ Exp $
inherit flag-o-matic eutils games
@@ -33,7 +33,7 @@ src_unpack() {
src_compile() {
# --disable-network --enable-console
- local myconf="`use_enable x86 assembler`"
+ local myconf="$(use_enable x86 assembler)"
use debug \
&& debugconf="${myconf} --enable-debug --disable-release" \
|| debugconf="${myconf} --disable-debug --enable-release"
@@ -41,7 +41,7 @@ src_compile() {
# in gr, thus when they go to link they cause redefine errors ...
# we build each by it self, save the binary file, clean up, and start over
mkdir my-bins
- for ren in sdl `use opengl` `use svga` `use ggi` ; do
+ for ren in sdl $(use opengl) $(use svga) $(use ggi) ; do
[ "${ren}" == "sdl" ] \
&& renconf="" \
|| renconf="--with-${ren}"