summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-08-09 17:04:03 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-08-09 17:04:03 +0000
commit5f14930e2331923f13e89a0ffe848f3f8fa06bb3 (patch)
tree568292b14076d325257eaebfed2b9ddfa21c071d /games-arcade/apricots/apricots-0.2.6-r1.ebuild
parentstable amd64 (diff)
downloadgentoo-2-5f14930e2331923f13e89a0ffe848f3f8fa06bb3.tar.gz
gentoo-2-5f14930e2331923f13e89a0ffe848f3f8fa06bb3.tar.bz2
gentoo-2-5f14930e2331923f13e89a0ffe848f3f8fa06bb3.zip
Added a patch by Tristan Heaven <tristanheaven@gmail.com> to fix the package with the split openal/freealut.
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'games-arcade/apricots/apricots-0.2.6-r1.ebuild')
-rw-r--r--games-arcade/apricots/apricots-0.2.6-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/games-arcade/apricots/apricots-0.2.6-r1.ebuild b/games-arcade/apricots/apricots-0.2.6-r1.ebuild
new file mode 100644
index 000000000000..ab7fb9160b09
--- /dev/null
+++ b/games-arcade/apricots/apricots-0.2.6-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/apricots-0.2.6-r1.ebuild,v 1.1 2006/08/09 17:04:03 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="Fly a plane around bomb/shoot the enemy. Port of Planegame from Amiga."
+HOMEPAGE="http://www.fishies.org.uk/apricots.html"
+SRC_URI="http://www.fishies.org.uk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc ~sparc x86"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2
+ media-libs/openal
+ media-libs/freealut"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-freealut.patch
+ sed -i \
+ -e 's:-DAP_PATH=\\\\\\"$prefix.*":-DAP_PATH=\\\\\\"${GAMES_DATADIR}/${PN}/\\\\\\"":' \
+ configure.in \
+ || die "sed failed"
+
+ sed -i \
+ -e "s:filename(AP_PATH):filename(\"${GAMES_SYSCONFDIR}/${PN}/\"):" \
+ ${PN}/init.cpp \
+ || die "sed failed"
+ sed -i \
+ -e "s:apricots.cfg:${GAMES_SYSCONFDIR}/${PN}/apricots.cfg:" \
+ README apricots.html \
+ || die "sed failed"
+ eautoconf
+}
+
+src_install() {
+ dodoc AUTHORS README TODO ChangeLog
+ dohtml apricots.html
+ cd ${PN}
+ dogamesbin apricots || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins *.wav *.psf *.shapes || die "doins failed"
+ insinto "${GAMES_SYSCONFDIR}/${PN}"
+ doins apricots.cfg || die "failed to install game config file"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "You can change the game options by editing:"
+ einfo "${GAMES_SYSCONFDIR}/${PN}/apricots.cfg"
+ echo
+}