summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-03-21 23:15:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-03-21 23:15:23 +0000
commitf0a65d4d0995efac56c2c7321c1b7b99c288d9f9 (patch)
treeb4c93a0c41c3a4b49f73230b3b1061672bcb7e5c /games-emulation/dosbox-cvs
parent~amd64 (diff)
downloadgentoo-2-f0a65d4d0995efac56c2c7321c1b7b99c288d9f9.tar.gz
gentoo-2-f0a65d4d0995efac56c2c7321c1b7b99c288d9f9.tar.bz2
gentoo-2-f0a65d4d0995efac56c2c7321c1b7b99c288d9f9.zip
sync with dosbox ebuild
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-emulation/dosbox-cvs')
-rw-r--r--games-emulation/dosbox-cvs/ChangeLog6
-rw-r--r--games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild53
2 files changed, 38 insertions, 21 deletions
diff --git a/games-emulation/dosbox-cvs/ChangeLog b/games-emulation/dosbox-cvs/ChangeLog
index bcb89a752ec4..1389d26cc512 100644
--- a/games-emulation/dosbox-cvs/ChangeLog
+++ b/games-emulation/dosbox-cvs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/dosbox-cvs
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox-cvs/ChangeLog,v 1.14 2007/03/12 13:56:49 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox-cvs/ChangeLog,v 1.15 2007/03/21 23:15:23 mr_bones_ Exp $
+
+ 21 Mar 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ dosbox-cvs-20030809.ebuild:
+ sync with dosbox ebuild
12 Mar 2007; Marius Mauch <genone@gentoo.org> dosbox-cvs-20030809.ebuild:
Replacing einfo with elog
diff --git a/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild b/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild
index 200beaa38ac8..f1a6284c62ca 100644
--- a/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild
+++ b/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild
@@ -1,24 +1,24 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild,v 1.16 2007/03/12 13:56:49 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox-cvs/dosbox-cvs-20030809.ebuild,v 1.17 2007/03/21 23:15:23 mr_bones_ Exp $
-inherit games cvs
+inherit eutils games cvs
-DESCRIPTION="DOS Emulator"
+DESCRIPTION="DOS emulator"
HOMEPAGE="http://dosbox.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
-IUSE="opengl debug"
+IUSE="alsa debug hardened opengl sdl png"
-DEPEND="media-libs/alsa-lib
+DEPEND="alsa? ( media-libs/alsa-lib )
opengl? ( virtual/opengl )
- >=media-libs/libsdl-1.2.0
- sys-libs/zlib
- media-libs/libpng
- media-libs/sdl-net
- debug? ( sys-libs/ncurses )"
+ png? ( media-libs/libpng )
+ debug? ( sys-libs/ncurses )
+ media-libs/libsdl
+ sdl? ( media-libs/sdl-net
+ media-libs/sdl-sound )"
ECVS_SERVER="dosbox.cvs.sourceforge.net:/cvsroot/dosbox"
ECVS_MODULE="dosbox"
@@ -26,26 +26,39 @@ ECVS_TOP_DIR=${DISTDIR}/cvs-src/${PN}
S=${WORKDIR}/${ECVS_MODULE}
+pkg_setup() {
+ if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror "To be able to build dosbox with ALSA support you need"
+ eerror "to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+ games_pkg_setup
+}
+
src_compile() {
+ local myconf=
+
+ if ! use alsa ; then
+ myconf="--without-alsa-prefix --without-alsa-inc-prefix --disable-alsatest"
+ fi
+ # bug #66038
+ if use hardened ; then
+ myconf="${myconf} --disable-dynamic-x86"
+ fi
+ if use debug ; then
+ myconf="${myconf} --enable-debug"
+ fi
./autogen.sh || die "autogen.sh failed"
egamesconf \
--disable-dependency-tracking \
- $(use_enable debug debug heavy) \
+ ${myconf} \
$(use_enable opengl) \
|| die
emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README THANKS
prepgamesdirs
}
-
-pkg_postinst() {
- games_pkg_postinst
- echo
- elog "If you're using ati-drivers, you may need to use output=overlay"
- elog "in the dosbox config file (see bug #57188)."
- echo
-}