summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-04-17 22:39:37 +0000
committerDaniel Goller <morfic@gentoo.org>2005-04-17 22:39:37 +0000
commit0c6f398a6fc2ef41293ed5d6c3e3257ae20d341d (patch)
treeb38dd1a1ac7877326059530a1893332bc1a4ef38 /games-emulation
parentUnmask xchat-xsys 1.9.3 (diff)
downloadgentoo-2-0c6f398a6fc2ef41293ed5d6c3e3257ae20d341d.tar.gz
gentoo-2-0c6f398a6fc2ef41293ed5d6c3e3257ae20d341d.tar.bz2
gentoo-2-0c6f398a6fc2ef41293ed5d6c3e3257ae20d341d.zip
fix dependency logic/defaults
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64-alsasnd/ChangeLog5
-rw-r--r--games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild15
2 files changed, 9 insertions, 11 deletions
diff --git a/games-emulation/mupen64-alsasnd/ChangeLog b/games-emulation/mupen64-alsasnd/ChangeLog
index 9877f9633c7e..c3dc8f2e06ac 100644
--- a/games-emulation/mupen64-alsasnd/ChangeLog
+++ b/games-emulation/mupen64-alsasnd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/mupen64-alsasnd
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/ChangeLog,v 1.4 2005/04/17 21:56:05 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/ChangeLog,v 1.5 2005/04/17 22:39:37 morfic Exp $
+
+ 17 Apr 2005; Daniel Goller <morfic@gentoo.org> mupen64-alsasnd-0.4.ebuild:
+ fix dependency logic/defaults
17 Apr 2005; Daniel Goller <morfic@gentoo.org> mupen64-alsasnd-0.4.ebuild:
add missing IUSE
diff --git a/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild b/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
index 0fabe52ca759..515605964200 100644
--- a/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
+++ b/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild,v 1.8 2005/04/17 21:56:05 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild,v 1.9 2005/04/17 22:39:37 morfic Exp $
inherit games eutils
@@ -16,9 +16,10 @@ RESTRICT="fetch"
DEPEND=">=media-libs/alsa-lib-0.9.0
|| (
- gtk? ( =x11-libs/gtk+-1* )
- gtk2? ( =x11-libs/gtk+-2* )
+ gtk? ( !gtk2? (=x11-libs/gtk+-1* )
+ gtk2? ( =x11-libs/gtk+-2* ) )
qt? ( >=x11-libs/qt-3 )
+ =x11-libs/gtk+-2*
)"
S="${WORKDIR}/alsa_plugin"
@@ -29,13 +30,6 @@ pkg_nofetch() {
einfo "Then just put ${A} in ${DISTDIR} !"
}
-pkg_setup() {
- if ! use gtk && ! use gtk2 && ! use qt ; then
- eerror "You must choose either gtk, gtk2 or qt as interface"
- die "User Choice of Interface required"
- fi
-}
-
src_unpack() {
unpack ${A}
cd "${S}"
@@ -44,6 +38,7 @@ src_unpack() {
}
src_compile() {
+ export GRAPHICAL_INTERFACE=gtk2
use qt && export GRAPHICAL_INTERFACE=qt3
use gtk && export GRAPHICAL_INTERFACE=gtk1
use gtk2 && export GRAPHICAL_INTERFACE=gtk2