summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-09-29 03:20:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-09-29 03:20:26 +0000
commitdd4e3be89c1b3bee58f93964774808a2d16d2717 (patch)
tree7c67524b311995768ff8c17046ec34392ffa85b4 /games-emulation
parentVersion bump. Set SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-dd4e3be89c1b3bee58f93964774808a2d16d2717.tar.gz
gentoo-2-dd4e3be89c1b3bee58f93964774808a2d16d2717.tar.bz2
gentoo-2-dd4e3be89c1b3bee58f93964774808a2d16d2717.zip
initial commit - ebuild submitted by Denilson via bug #235860
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/fceux/ChangeLog10
-rw-r--r--games-emulation/fceux/fceux-2.1.1.ebuild52
-rw-r--r--games-emulation/fceux/metadata.xml5
3 files changed, 67 insertions, 0 deletions
diff --git a/games-emulation/fceux/ChangeLog b/games-emulation/fceux/ChangeLog
new file mode 100644
index 000000000000..363ec81d7285
--- /dev/null
+++ b/games-emulation/fceux/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-emulation/fceux
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/ChangeLog,v 1.1 2009/09/29 03:20:26 mr_bones_ Exp $
+
+*fceux-2.1.1 (29 Sep 2009)
+
+ 29 Sep 2009; Michael Sterrett <mr_bones_@gentoo.org> +fceux-2.1.1.ebuild,
+ +metadata.xml:
+ initial commit - ebuild submitted by Denilson via bug #235860
+
diff --git a/games-emulation/fceux/fceux-2.1.1.ebuild b/games-emulation/fceux/fceux-2.1.1.ebuild
new file mode 100644
index 000000000000..e3b436ca219a
--- /dev/null
+++ b/games-emulation/fceux/fceux-2.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/fceux-2.1.1.ebuild,v 1.1 2009/09/29 03:20:26 mr_bones_ Exp $
+
+EAPI=2
+inherit games
+
+DESCRIPTION="A portable Famicom/NES emulator, an evolution of the original FCE Ultra"
+HOMEPAGE="http://fceux.com/"
+SRC_URI="mirror://sourceforge/fceultra/${P}.src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua opengl"
+
+RDEPEND="lua? ( dev-lang/lua )
+ media-libs/libsdl[opengl?,video]
+ opengl? ( virtual/opengl )
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+RDEPEND="${RDEPEND}
+ gnome-extra/zenity"
+# Note: zenity is "almost" optional. It is possible to compile and run fceux
+# without zenity, but file dialogs will not work.
+
+S=${WORKDIR}/fceu
+
+src_compile() {
+ local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[[:space:]]*[0-9]\+\).*/\1/; p }")
+ scons \
+ ${sconsopts} \
+ CREATE_AVI=1 \
+ OPENGL=$(use opengl && echo 1 || echo 0) \
+ LUA=$(use lua && echo 1 || echo 0) \
+ || die "scons failed"
+}
+
+src_install() {
+ dogamesbin bin/fceux || die
+
+ doman documentation/fceux.6 || die
+ dodoc Authors.txt changelog.txt TODO-PROJECT
+
+ # Extra documentation
+ insinto "/usr/share/doc/${PF}/"
+ doins -r bin/fceux.chm documentation
+ rm -f "${D}/usr/share/doc/${PF}/documentation/fceux.6"
+
+ prepgamesdirs
+}
diff --git a/games-emulation/fceux/metadata.xml b/games-emulation/fceux/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-emulation/fceux/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>