summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-01 16:41:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-01 16:41:45 +0000
commit4a4af7d575d88a153fb5670492e4007531590f47 (patch)
tree25fdda5e920fb679c8fde2a9e1ff9dc3a62620d4 /games-puzzle/sgt-puzzles
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-4a4af7d575d88a153fb5670492e4007531590f47.tar.gz
gentoo-2-4a4af7d575d88a153fb5670492e4007531590f47.tar.bz2
gentoo-2-4a4af7d575d88a153fb5670492e4007531590f47.zip
version bump with patch from Denilson (bug #301789)
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/sgt-puzzles')
-rw-r--r--games-puzzle/sgt-puzzles/ChangeLog10
-rw-r--r--games-puzzle/sgt-puzzles/files/sgt-puzzles-8906-gentoo.patch22
-rw-r--r--games-puzzle/sgt-puzzles/sgt-puzzles-8906.ebuild68
3 files changed, 98 insertions, 2 deletions
diff --git a/games-puzzle/sgt-puzzles/ChangeLog b/games-puzzle/sgt-puzzles/ChangeLog
index de8195679c7d..5aff49f15249 100644
--- a/games-puzzle/sgt-puzzles/ChangeLog
+++ b/games-puzzle/sgt-puzzles/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/sgt-puzzles
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/ChangeLog,v 1.2 2009/09/11 12:02:01 tupone Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/ChangeLog,v 1.3 2010/04/01 16:41:45 mr_bones_ Exp $
+
+*sgt-puzzles-8906 (01 Apr 2010)
+
+ 01 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +sgt-puzzles-8906.ebuild, +files/sgt-puzzles-8906-gentoo.patch:
+ version bump with patch from Denilson (bug #301789)
11 Sep 2009; Tupone Alfredo <tupone@gentoo.org>
+files/sgt-puzzles-8605-gentoo.patch, sgt-puzzles-8605.ebuild:
diff --git a/games-puzzle/sgt-puzzles/files/sgt-puzzles-8906-gentoo.patch b/games-puzzle/sgt-puzzles/files/sgt-puzzles-8906-gentoo.patch
new file mode 100644
index 000000000000..31e7f796a611
--- /dev/null
+++ b/games-puzzle/sgt-puzzles/files/sgt-puzzles-8906-gentoo.patch
@@ -0,0 +1,22 @@
+--- mkfiles.pl.old 2010-03-07 11:14:11.000000000 -0300
++++ mkfiles.pl 2010-03-07 11:24:20.000000000 -0300
+@@ -1110,8 +1110,8 @@
+ "\n".
+ &splitline("CFLAGS := -O2 -Wall -Werror -ansi -pedantic -g " .
+ (join " ", map {"-I$dirpfx$_"} @srcdirs) .
+- " `\$(GTK_CONFIG) --cflags` \$(CFLAGS)")."\n".
+- "XLIBS = `\$(GTK_CONFIG) --libs`\n".
++ " `pkg-config gtk+-2.0 --cflags` \$(CFLAGS)")."\n".
++ "XLIBS = `pkg-config gtk+-2.0 --libs`\n".
+ "ULIBS =#\n".
+ "INSTALL=install\n",
+ "INSTALL_PROGRAM=\$(INSTALL)\n",
+@@ -1130,7 +1130,7 @@
+ $objstr = &objects($p, "X.o", undef, undef);
+ print &splitline($prog . ": " . $objstr), "\n";
+ $libstr = &objects($p, undef, undef, "-lX");
+- print &splitline("\t\$(CC) -o \$@ $objstr $libstr \$(${type}LIBS)", 69),
++ print &splitline("\t\$(CC) \$(LDFLAGS) -o \$@ $objstr $libstr \$(${type}LIBS)", 69),
+ "\n\n";
+ }
+ foreach $d (&deps("X.o", undef, $dirpfx, "/")) {
diff --git a/games-puzzle/sgt-puzzles/sgt-puzzles-8906.ebuild b/games-puzzle/sgt-puzzles/sgt-puzzles-8906.ebuild
new file mode 100644
index 000000000000..d8641844e6df
--- /dev/null
+++ b/games-puzzle/sgt-puzzles/sgt-puzzles-8906.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/sgt-puzzles-8906.ebuild,v 1.1 2010/04/01 16:41:45 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+if [[ ${PV} == "99999999" ]] ; then
+ ESVN_REPO_URI="svn://svn.tartarus.org/sgt/puzzles/trunk"
+ inherit subversion
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-r${PV}.tar.gz"
+ S=${WORKDIR}/puzzles-r${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Simon Tatham's Portable Puzzle Collection"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=app-doc/halibut-1.0 )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ ./mkfiles.pl
+ sed -i \
+ -e 's:= -O2 -Wall -Werror -ansi -pedantic -g:= $(CPPFLAGS):' \
+ -e '/LDFLAGS/s:=:=$(LDFLAGS) :' \
+ Makefile || die
+}
+
+src_compile() {
+ emake || die
+ if use doc ; then
+ halibut --text --html --info --pdf --ps puzzles.but
+ fi
+}
+
+src_install() {
+ dodir "${GAMES_BINDIR}"
+ emake DESTDIR="${D}" gamesdir="${GAMES_BINDIR}" install || die
+ dodoc README HACKING
+
+ local file name
+ for file in *.R ; do
+ [[ ${file} == "nullgame.R" ]] && continue
+ name=$(sed -n 's/^[a-z]*\.exe://p' "${file}")
+ file=${file%.R}
+ newicon icons/${file}-48d24.png ${PN}-${file}.png || die
+ make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}" "${PN}-${file}"
+ done
+
+ dodoc puzzles.txt puzzles.chm
+ if use doc ; then
+ dohtml *.html
+ doinfo puzzles.info
+ dodoc puzzles.pdf puzzles.ps
+ fi
+
+ prepgamesdirs
+}