summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-02-23 20:35:56 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-02-23 20:35:56 +0000
commitd28326355adc764ba0570cdfa59587688bf03ef5 (patch)
tree24940b74d24bc0c21498b2ac6bca9966021c0413 /games-strategy/wesnoth
parentVersion bump. Dropped old. (diff)
downloadgentoo-2-d28326355adc764ba0570cdfa59587688bf03ef5.tar.gz
gentoo-2-d28326355adc764ba0570cdfa59587688bf03ef5.tar.bz2
gentoo-2-d28326355adc764ba0570cdfa59587688bf03ef5.zip
force rev bump and disable python support to address security risk (CVE-2009-0367)
(Portage version: 2.1.6.7/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog11
-rw-r--r--games-strategy/wesnoth/files/no-python.patch22
-rw-r--r--games-strategy/wesnoth/wesnoth-1.4.4-r1.ebuild (renamed from games-strategy/wesnoth/wesnoth-1.4.4.ebuild)12
-rw-r--r--games-strategy/wesnoth/wesnoth-1.4.7-r1.ebuild (renamed from games-strategy/wesnoth/wesnoth-1.4.7.ebuild)9
4 files changed, 44 insertions, 10 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 84206fc752b8..ecb79d61b85b 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.137 2009/01/25 22:27:26 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.138 2009/02/23 20:35:55 mr_bones_ Exp $
+
+*wesnoth-1.4.7-r1 (23 Feb 2009)
+*wesnoth-1.4.4-r1 (23 Feb 2009)
+
+ 23 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/03_A_Haunting_in_Winter.cfg, -wesnoth-1.4.4.ebuild,
+ +wesnoth-1.4.4-r1.ebuild, -wesnoth-1.4.7.ebuild, +wesnoth-1.4.7-r1.ebuild:
+ force rev bump and disable python support to address security risk
+ (CVE-2009-0367)
25 Jan 2009; Markus Meier <maekke@gentoo.org> wesnoth-1.4.7.ebuild:
amd64/x86 stable, bug #255394
diff --git a/games-strategy/wesnoth/files/no-python.patch b/games-strategy/wesnoth/files/no-python.patch
new file mode 100644
index 000000000000..f40ebaf5b84e
--- /dev/null
+++ b/games-strategy/wesnoth/files/no-python.patch
@@ -0,0 +1,22 @@
+--- data/campaigns/Descent_Into_Darkness/scenarios/03_A_Haunting_in_Winter.cfg 2009/02/22 14:24:56 33012
++++ data/campaigns/Descent_Into_Darkness/scenarios/03_A_Haunting_in_Winter.cfg 2009/02/22 14:52:51 33013
+@@ -92,10 +92,16 @@
+ no_leader=yes
+ fog=no
+ shroud=no
+- # kamikaze.py heads straight for the leader of side 1 and attacks
+ [ai]
+- ai_algorithm=python_ai
+- python_script="../campaigns/Descent_Into_Darkness/ais/kamikaze.py"
++ aggression=4.0
++ caution=0.0
++ grouping=no
++ simple_targetting=yes
++ village_value=0
++ [target]
++ id=Malin Keshar
++ value=100
++ [/target]
+ [/ai]
+ [/side]
+
diff --git a/games-strategy/wesnoth/wesnoth-1.4.4.ebuild b/games-strategy/wesnoth/wesnoth-1.4.4-r1.ebuild
index f86d420ce978..afe9ea45a3c5 100644
--- a/games-strategy/wesnoth/wesnoth-1.4.4.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.4.4-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.4.4.ebuild,v 1.6 2008/08/24 13:06:20 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.4.4-r1.ebuild,v 1.1 2009/02/23 20:35:55 mr_bones_ Exp $
inherit eutils toolchain-funcs flag-o-matic games
@@ -21,8 +21,8 @@ RDEPEND=">=media-libs/libsdl-1.2.7
x11-libs/libX11
>=media-libs/sdl-mixer-1.2
>=media-libs/sdl-image-1.2
- dev-lang/python
>=media-libs/freetype-2 )
+ dev-lang/python
nls? ( virtual/libintl )"
# the configure script is broken and checks for freetype even if
# it won't be used. until it's either patched out or upstream fixes
@@ -53,6 +53,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
+ cd "${S}"
if use dedicated || use server ; then
sed \
-e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
@@ -63,12 +64,12 @@ src_unpack() {
|| die "sed failed"
fi
if ! use nls ; then
- cd "${S}"
sed -i \
-e '/^MAN_LANG/d' \
doc/man/Makefile.in \
|| die "sed failed"
fi
+ epatch "${FILESDIR}"/no-python.patch
}
src_compile() {
@@ -92,7 +93,7 @@ src_compile() {
--with-icondir=/usr/share/icons \
--with-desktopdir=/usr/share/applications \
--docdir=/usr/share/doc/${PF} \
- --enable-python-install \
+ --disable-python \
$(use_enable lite) \
$(use_enable static) \
$(use_enable editor) \
@@ -107,6 +108,7 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
+ rm -fr "${D}${GAMES_DATADIR}"/wesnoth/data/{ais,campaigns/Descent_Into_Darkness/ais}
dodoc changelog
if use dedicated || use server; then
keepdir "${GAMES_STATEDIR}/run/wesnothd"
diff --git a/games-strategy/wesnoth/wesnoth-1.4.7.ebuild b/games-strategy/wesnoth/wesnoth-1.4.7-r1.ebuild
index d2a5a38ca09f..c6674c195e75 100644
--- a/games-strategy/wesnoth/wesnoth-1.4.7.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.4.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.4.7.ebuild,v 1.6 2009/01/25 22:27:26 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.4.7-r1.ebuild,v 1.1 2009/02/23 20:35:55 mr_bones_ Exp $
EAPI=2
inherit eutils toolchain-funcs flag-o-matic games
@@ -22,8 +22,8 @@ RDEPEND=">=media-libs/libsdl-1.2.7[X]
x11-libs/libX11
>=media-libs/sdl-mixer-1.2[vorbis]
>=media-libs/sdl-image-1.2[png,jpeg]
- dev-lang/python
>=media-libs/freetype-2 )
+ dev-lang/python
nls? ( virtual/libintl )"
# the configure script is broken and checks for freetype even if
# it won't be used. until it's either patched out or upstream fixes
@@ -62,12 +62,12 @@ src_prepare() {
|| die "sed failed"
fi
if ! use nls ; then
- cd "${S}"
sed -i \
-e '/^MAN_LANG/d' \
doc/man/Makefile.in \
|| die "sed failed"
fi
+ epatch "${FILESDIR}"/no-python.patch
}
src_configure() {
@@ -91,7 +91,7 @@ src_configure() {
--with-icondir=/usr/share/icons \
--with-desktopdir=/usr/share/applications \
--docdir=/usr/share/doc/${PF} \
- --enable-python-install \
+ --disable-python \
$(use_enable smallgui) \
$(use_enable tinygui) \
$(use_enable lite) \
@@ -106,6 +106,7 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
+ rm -fr "${D}${GAMES_DATADIR}"/wesnoth/data/{ais,campaigns/Descent_Into_Darkness/ais}
dodoc changelog
if use dedicated || use server; then
keepdir "${GAMES_STATEDIR}/run/wesnothd"