summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-02-13 16:56:54 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-02-13 16:56:54 +0000
commitb5a1b37154b402191ef2c9f22dc11154555a3b9e (patch)
treea88545e45e855655bcfc83789ffd67e3ba268f52 /gnome-base/oaf
parentNew version. Removed gnome-libs dependency because it really shouldn't be th... (diff)
downloadgentoo-2-b5a1b37154b402191ef2c9f22dc11154555a3b9e.tar.gz
gentoo-2-b5a1b37154b402191ef2c9f22dc11154555a3b9e.tar.bz2
gentoo-2-b5a1b37154b402191ef2c9f22dc11154555a3b9e.zip
New version.
Diffstat (limited to 'gnome-base/oaf')
-rw-r--r--gnome-base/oaf/files/digest-oaf-0.6.81
-rw-r--r--gnome-base/oaf/oaf-0.6.8.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/gnome-base/oaf/files/digest-oaf-0.6.8 b/gnome-base/oaf/files/digest-oaf-0.6.8
new file mode 100644
index 000000000000..b4ee3fa36030
--- /dev/null
+++ b/gnome-base/oaf/files/digest-oaf-0.6.8
@@ -0,0 +1 @@
+MD5 d1a7cd8cd87b78fe049c225d4f0a7f1e oaf-0.6.8.tar.gz 550965
diff --git a/gnome-base/oaf/oaf-0.6.8.ebuild b/gnome-base/oaf/oaf-0.6.8.ebuild
new file mode 100644
index 000000000000..bec57a967feb
--- /dev/null
+++ b/gnome-base/oaf/oaf-0.6.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/oaf/oaf-0.6.8.ebuild,v 1.1 2002/02/13 16:54:16 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Object Activation Framework for GNOME"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+
+RDEPEND="virtual/glibc
+ >=dev-libs/popt-1.5
+ >=gnome-base/ORBit-0.5.10-r1
+ >=dev-libs/libxml-1.8.15"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/perl-5
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ cp -a configure configure.orig
+ sed -e "s:perl5\.00404:perl5.6.1:" configure.orig > configure
+ rm configure.orig
+}
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+pkg_postinst() {
+ ldconfig -r ${ROOT}
+}