summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Klimaszewski <steev@gentoo.org>2008-02-02 07:17:20 +0000
committerStephen Klimaszewski <steev@gentoo.org>2008-02-02 07:17:20 +0000
commit4f0c5d0add259ca39036dac61ccd0e123c8f65e1 (patch)
tree3bee675f1cb721d1e0b16da9c54f0efa01bc0441 /gnome-extra/nm-applet
parentgnome-base/gnome:mono needs tomboy which is missing ppc support (diff)
downloadgentoo-2-4f0c5d0add259ca39036dac61ccd0e123c8f65e1.tar.gz
gentoo-2-4f0c5d0add259ca39036dac61ccd0e123c8f65e1.tar.bz2
gentoo-2-4f0c5d0add259ca39036dac61ccd0e123c8f65e1.zip
Fix quoting issues in 0.6.5, add a bump to work with the new nm snapshot I just added. Includes a spiffy new wireless network editor so you no longer have to putz around with gconf.
(Portage version: 2.1.4.1)
Diffstat (limited to 'gnome-extra/nm-applet')
-rw-r--r--gnome-extra/nm-applet/ChangeLog12
-rw-r--r--gnome-extra/nm-applet/nm-applet-0.6.5.ebuild8
-rw-r--r--gnome-extra/nm-applet/nm-applet-0.6.5_p20080131.ebuild63
3 files changed, 77 insertions, 6 deletions
diff --git a/gnome-extra/nm-applet/ChangeLog b/gnome-extra/nm-applet/ChangeLog
index 3462e1d33252..2517efcdaad0 100644
--- a/gnome-extra/nm-applet/ChangeLog
+++ b/gnome-extra/nm-applet/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-extra/nm-applet
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nm-applet/ChangeLog,v 1.9 2007/12/25 14:26:40 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nm-applet/ChangeLog,v 1.10 2008/02/02 07:17:20 steev Exp $
+
+*nm-applet-0.6.5_p20080131 (02 Feb 2008)
+
+ 02 Feb 2008; Steev Klimaszewski <steev@gentoo.org> nm-applet-0.6.5.ebuild,
+ +nm-applet-0.6.5_p20080131.ebuild:
+ Fix quoting issues in 0.6.5, add a bump to work with the new snapshot just
+ added for networkmanager. Includes a spiffy new wireless network editor so
+ you no longer have to putz around in gconf.
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing metalgod from metadata.xml as per #99350.
diff --git a/gnome-extra/nm-applet/nm-applet-0.6.5.ebuild b/gnome-extra/nm-applet/nm-applet-0.6.5.ebuild
index 7a17ef868517..284486254846 100644
--- a/gnome-extra/nm-applet/nm-applet-0.6.5.ebuild
+++ b/gnome-extra/nm-applet/nm-applet-0.6.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nm-applet/nm-applet-0.6.5.ebuild,v 1.7 2007/08/28 14:39:57 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nm-applet/nm-applet-0.6.5.ebuild,v 1.8 2008/02/02 07:17:20 steev Exp $
inherit gnome2 eutils
@@ -48,8 +48,8 @@ S=${WORKDIR}/${PN}-${MY_PV}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-0.6.5-confchanges.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.6.5-confchanges.patch"
}
pkg_postinst() {
diff --git a/gnome-extra/nm-applet/nm-applet-0.6.5_p20080131.ebuild b/gnome-extra/nm-applet/nm-applet-0.6.5_p20080131.ebuild
new file mode 100644
index 000000000000..766cf756a9e3
--- /dev/null
+++ b/gnome-extra/nm-applet/nm-applet-0.6.5_p20080131.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nm-applet/nm-applet-0.6.5_p20080131.ebuild,v 1.1 2008/02/02 07:17:20 steev Exp $
+
+inherit gnome2 eutils
+
+MY_PV=${PV/_*/}
+
+DESCRIPTION="Gnome applet for NetworkManager."
+HOMEPAGE="http://people.redhat.com/dcbw/NetworkManager/"
+#SRC_URI="http://ftp.gnome.org/pub/gnome/sources/network-manager-applet/0.6/network-manager-applet-0.6.5.tar.gz"
+SRC_URI="http://steev.net/files/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc libnotify"
+
+RDEPEND=">=sys-apps/dbus-0.60
+ >=sys-apps/hal-0.5
+ sys-apps/iproute2
+ >=dev-libs/libnl-1.1
+ >=net-misc/dhcdbd-1.4
+ >=net-misc/networkmanager-0.6.5_p20080130
+ >=net-wireless/wireless-tools-28_pre9
+ >=net-wireless/wpa_supplicant-0.4.8
+ >=dev-libs/glib-2.10
+ notify? ( >=x11-libs/libnotify-0.4.3 )
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/libglade-2
+ >=gnome-base/gnome-keyring-0.4
+ >=gnome-base/gnome-panel-2
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnomeui-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
+USE_DESTDIR="1"
+
+G2CONF="${G2CONF} \
+ --disable-more-warnings \
+ --localstatedir=/var \
+ --with-dbus-sys=/etc/dbus-1/system.d \
+ $(use_with libnotify notify)"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.6.5-confchanges.patch"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog "Your user needs to be in the plugdev group in order to use this"
+ elog "package. If it doesn't start in Gnome for you automatically after"
+ elog 'you log back in, simply run "nm-applet --sm-disable"'
+ elog "You also need the notification area applet on your panel for"
+ elog "this to show up."
+}