summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-06-10 22:45:26 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-06-10 22:45:26 +0000
commit450d508ea7f4898abc1b5d0778f3bf62689e5d94 (patch)
tree3cf64341865b7a60dbdc04903c86db6215006c54 /kde-base/kdeadmin
parentversion bump (diff)
downloadgentoo-2-450d508ea7f4898abc1b5d0778f3bf62689e5d94.tar.gz
gentoo-2-450d508ea7f4898abc1b5d0778f3bf62689e5d94.tar.bz2
gentoo-2-450d508ea7f4898abc1b5d0778f3bf62689e5d94.zip
Version bump
Diffstat (limited to 'kde-base/kdeadmin')
-rw-r--r--kde-base/kdeadmin/ChangeLog7
-rw-r--r--kde-base/kdeadmin/files/digest-kdeadmin-3.2.31
-rw-r--r--kde-base/kdeadmin/kdeadmin-3.2.3.ebuild29
3 files changed, 36 insertions, 1 deletions
diff --git a/kde-base/kdeadmin/ChangeLog b/kde-base/kdeadmin/ChangeLog
index 82c1f097bb0b..90c9941a345f 100644
--- a/kde-base/kdeadmin/ChangeLog
+++ b/kde-base/kdeadmin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdeadmin
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/ChangeLog,v 1.81 2004/06/03 23:50:16 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/ChangeLog,v 1.82 2004/06/10 22:42:58 caleb Exp $
+
+*kdeadmin-3.2.3 (10 Jun 2004)
+
+ 10 Jun 2004; Caleb Tennis <caleb@gentoo.org> +kdeadmin-3.2.3.ebuild:
+ Version bump
03 Jun 2004; Aron Griffis <agriffis@gentoo.org> kdeadmin-3.1.5.ebuild:
Fix use invocation
diff --git a/kde-base/kdeadmin/files/digest-kdeadmin-3.2.3 b/kde-base/kdeadmin/files/digest-kdeadmin-3.2.3
new file mode 100644
index 000000000000..33e55b55cf11
--- /dev/null
+++ b/kde-base/kdeadmin/files/digest-kdeadmin-3.2.3
@@ -0,0 +1 @@
+MD5 52cac3afb5ae527f7d65cdd27937ecf4 kdeadmin-3.2.3.tar.bz2 1551138
diff --git a/kde-base/kdeadmin/kdeadmin-3.2.3.ebuild b/kde-base/kdeadmin/kdeadmin-3.2.3.ebuild
new file mode 100644
index 000000000000..013afb03d442
--- /dev/null
+++ b/kde-base/kdeadmin/kdeadmin-3.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/kdeadmin-3.2.3.ebuild,v 1.1 2004/06/10 22:42:58 caleb Exp $
+
+inherit kde-dist
+
+DESCRIPTION="KDE administration tools (user manager, etc.)"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64"
+IUSE="pam"
+
+DEPEND="~kde-base/kdebase-${PV}
+ pam? ( >=sys-libs/pam-0.72 )"
+
+myconf="$myconf --without-rpm"
+DO_NOT_COMPILE="$DO_NOT_COMPILE kpackage ksysv"
+
+# we only want to compile the lilo config module on x86, but there we want to make sure it's
+# always compiled to ensure consistent behaviour of the package across both lilo and grub systems,
+# because configure when left to its own devices will build lilo-config or not basd on whether
+# lilo is present in the path.
+# so, we make configure build it by removing the configure.in.in file that checks for
+# lilo's presense
+src_unpack() {
+ kde_src_unpack
+ use x86 && echo > ${S}/lilo-config/configure.in.in
+}
+
+# TODO: add nis support