summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-09-03 19:04:59 +0000
committerChris Reffett <creffett@gentoo.org>2013-09-03 19:04:59 +0000
commita7d39b161d3ea87618db515020379fc2be385858 (patch)
tree3fd47e295f81d71610e045a95b9b7a70e5373756 /kde-base/ksystemlog
parentAdd systemd support (#466084) (diff)
downloadgentoo-2-a7d39b161d3ea87618db515020379fc2be385858.tar.gz
gentoo-2-a7d39b161d3ea87618db515020379fc2be385858.tar.bz2
gentoo-2-a7d39b161d3ea87618db515020379fc2be385858.zip
Bump KDE to 4.1.1
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/ksystemlog')
-rw-r--r--kde-base/ksystemlog/ChangeLog7
-rw-r--r--kde-base/ksystemlog/ksystemlog-4.11.1.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/kde-base/ksystemlog/ChangeLog b/kde-base/ksystemlog/ChangeLog
index edb3373703cc..99c812e6378f 100644
--- a/kde-base/ksystemlog/ChangeLog
+++ b/kde-base/ksystemlog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksystemlog
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.170 2013/08/14 20:23:48 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.171 2013/09/03 19:04:37 creffett Exp $
+
+*ksystemlog-4.11.1 (03 Sep 2013)
+
+ 03 Sep 2013; Chris Reffett <creffett@gentoo.org> +ksystemlog-4.11.1.ebuild:
+ Bump KDE to 4.1.1
*ksystemlog-4.11.0 (14 Aug 2013)
diff --git a/kde-base/ksystemlog/ksystemlog-4.11.1.ebuild b/kde-base/ksystemlog/ksystemlog-4.11.1.ebuild
new file mode 100644
index 000000000000..19ecd5a85cb7
--- /dev/null
+++ b/kde-base/ksystemlog/ksystemlog-4.11.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ksystemlog-4.11.1.ebuild,v 1.1 2013/09/03 19:04:37 creffett Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+DESCRIPTION="KDE system log viewer"
+HOMEPAGE="http://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug test"
+
+RESTRICT=test
+# bug 378101
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}