summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-05-30 16:16:20 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-05-30 16:16:20 +0000
commit2f05fb7b7b420dbd6b44c54884c52284aaa6146a (patch)
treee24e01069929bd3103f68cc33adc3a6697d95ee1 /mail-client/balsa
parentAdded ~x86 keyword based on user testing by Alois Schmid <alois.schmid@gmx.de... (diff)
downloadgentoo-2-2f05fb7b7b420dbd6b44c54884c52284aaa6146a.tar.gz
gentoo-2-2f05fb7b7b420dbd6b44c54884c52284aaa6146a.tar.bz2
gentoo-2-2f05fb7b7b420dbd6b44c54884c52284aaa6146a.zip
bump to 2.3.16
(Portage version: 2.1.2.7)
Diffstat (limited to 'mail-client/balsa')
-rw-r--r--mail-client/balsa/ChangeLog23
-rw-r--r--mail-client/balsa/balsa-2.3.16.ebuild90
-rw-r--r--mail-client/balsa/files/digest-balsa-2.3.163
3 files changed, 115 insertions, 1 deletions
diff --git a/mail-client/balsa/ChangeLog b/mail-client/balsa/ChangeLog
index 5e350c0ea347..71e59a704458 100644
--- a/mail-client/balsa/ChangeLog
+++ b/mail-client/balsa/ChangeLog
@@ -1,6 +1,27 @@
# ChangeLog for mail-client/balsa
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/ChangeLog,v 1.48 2007/05/30 15:38:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/ChangeLog,v 1.49 2007/05/30 16:16:20 dang Exp $
+
+ 30 May 2007; Daniel Gryniewicz <dang@gentoo.org> +balsa-2.3.16.ebuild:
+ bump to 2.3.16
+
+*balsa-2.3.16 (30 May 2007)
+
+ 30 May 2007; Daniel Gryniewicz <dang@gentoo.org> +balsa-2.3.16.ebuild:
+ Bump to 2.3.16
+ - fix message threading regression.
+ - reorganize "Identity" dialog.
+ - code cleanup.
+ - Use GtkPrint infrastructure if available.
+ - handle LDAP referrals.
+ - nicer citation marks.
+ - initial libnotify support.
+ - IMAP BINARY support.
+ - deferred population of the mailbox index.
+ - client-side IMAP sorting.
+ - be compatible with recent gtk2 releases.
+ - mailbox tabs reorderable with d&d.
+ - enhanced mailto: URL handling.
30 May 2007; Raúl Porcel <armin76@gentoo.org> balsa-2.3.13.ebuild:
alpha stable wrt #164844
diff --git a/mail-client/balsa/balsa-2.3.16.ebuild b/mail-client/balsa/balsa-2.3.16.ebuild
new file mode 100644
index 000000000000..0f541c75f9e4
--- /dev/null
+++ b/mail-client/balsa/balsa-2.3.16.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/balsa-2.3.16.ebuild,v 1.1 2007/05/30 16:16:20 dang Exp $
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="Email client for GNOME"
+HOMEPAGE="http://balsa.gnome.org"
+SRC_URI="http://balsa.gnome.org/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+# Doesn't currently build with -gnome
+IUSE="crypt doc gtkhtml gtkspell kerberos ldap libnotify pcre sqlite ssl xface"
+
+RDEPEND=">=dev-libs/glib-2.0
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/gmime-2.1.9
+ >=net-libs/libesmtp-1.0.3
+ >=gnome-base/orbit-2
+ >=gnome-base/libbonobo-2.0
+ x11-themes/hicolor-icon-theme
+ sys-devel/libtool
+ sys-devel/gettext
+ net-mail/mailbase
+ crypt? ( >=app-crypt/gpgme-1.0 )
+ >=gnome-base/libgnome-2.0
+ >=gnome-base/libgnomeui-2.0
+ >=gnome-base/gnome-vfs-2.0
+ >=x11-libs/gtksourceview-1.6.1
+ gtkhtml? ( gnome-extra/gtkhtml )
+ sqlite? ( >=dev-db/sqlite-2.8 )
+ libnotify? ( x11-libs/libnotify )
+ gtkspell? ( =app-text/gtkspell-2* )
+ !gtkspell? ( virtual/aspell-dict )
+ kerberos? ( app-crypt/mit-krb5 )
+ ldap? ( net-nds/openldap )
+ pcre? ( >=dev-libs/libpcre-5.0 )
+ ssl? ( dev-libs/openssl )
+ xface? ( >=media-libs/compface-1.5.1 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ >=app-text/scrollkeeper-0.1.4
+ doc? ( dev-util/gtk-doc )"
+
+DOCS="AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO docs/*"
+USE_DESTDIR="1"
+
+pkg_setup() {
+ # threads are currently broken with gpgme
+ G2CONF="--disable-threads"
+
+ if use xface ; then
+ G2CONF="${G2CONF} --with-compface"
+ else
+ G2CONF="${G2CONF} --without-compface"
+ fi
+
+ if use crypt ; then
+ G2CONF="${G2CONF} --with-gpgme=gpgme-config"
+ else
+ G2CONF="${G2CONF} --without-gpgme"
+ fi
+
+# if use gnome ; then
+ G2CONF="${G2CONF} --with-gtksourceview"
+# else
+# G2CONF="${G2CONF} --without-gtksourceview"
+# fi
+
+ if use gtkhtml ; then
+ G2CONF="${G2CONF} --with-gtkhtml=2"
+ else
+ G2CONF="${G2CONF} --without-gtkhtml"
+ fi
+
+ G2CONF="${G2CONF} \
+ $(use_with gtkspell) \
+ $(use_with kerberos gss) \
+ $(use_with ldap) \
+ $(use_enable pcre) \
+ $(use_with sqlite) \
+ $(use_with ssl)"
+}
+
+src_install() {
+ gnome2_src_install scrollkeeper_localstate_dir=${D}/var/lib/scrollkeeper/
+}
diff --git a/mail-client/balsa/files/digest-balsa-2.3.16 b/mail-client/balsa/files/digest-balsa-2.3.16
new file mode 100644
index 000000000000..9a1d2c917971
--- /dev/null
+++ b/mail-client/balsa/files/digest-balsa-2.3.16
@@ -0,0 +1,3 @@
+MD5 c2919b9d30b8df9f917740230212435b balsa-2.3.16.tar.bz2 2550609
+RMD160 c087541520d80c2ac6d26426e2ba6dcce0f54bd6 balsa-2.3.16.tar.bz2 2550609
+SHA256 ddd58f9ffc3a147f1256850b09eab964f95a8fc7c625a0a446547baa74c19232 balsa-2.3.16.tar.bz2 2550609