summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-04-08 20:14:39 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-04-08 20:14:39 +0000
commit66084313cfb57a4d6eed7a2eff8cc66082a27130 (patch)
tree1a5d32a4f26da4c24effa1c74d8fb10aae0b300c /mail-filter/dcc
parentStable on amd64, bug #172895. Removed older version in same slot. (diff)
downloadgentoo-2-66084313cfb57a4d6eed7a2eff8cc66082a27130.tar.gz
gentoo-2-66084313cfb57a4d6eed7a2eff8cc66082a27130.tar.bz2
gentoo-2-66084313cfb57a4d6eed7a2eff8cc66082a27130.zip
Version bump.
(Portage version: 2.1.2.3)
Diffstat (limited to 'mail-filter/dcc')
-rw-r--r--mail-filter/dcc/ChangeLog7
-rw-r--r--mail-filter/dcc/dcc-1.3.55.ebuild112
-rw-r--r--mail-filter/dcc/files/digest-dcc-1.3.553
3 files changed, 121 insertions, 1 deletions
diff --git a/mail-filter/dcc/ChangeLog b/mail-filter/dcc/ChangeLog
index 8cbda964af75..1a3241c6d49d 100644
--- a/mail-filter/dcc/ChangeLog
+++ b/mail-filter/dcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/dcc
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dcc/ChangeLog,v 1.38 2007/03/15 18:46:46 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dcc/ChangeLog,v 1.39 2007/04/08 20:14:39 ticho Exp $
+
+*dcc-1.3.55 (08 Apr 2007)
+
+ 08 Apr 2007; Andrej Kacian <ticho@gentoo.org> +dcc-1.3.55.ebuild:
+ Version bump.
15 Mar 2007; Gustavo Zacarias <gustavoz@gentoo.org> dcc-1.3.31.ebuild:
Stable on sparc
diff --git a/mail-filter/dcc/dcc-1.3.55.ebuild b/mail-filter/dcc/dcc-1.3.55.ebuild
new file mode 100644
index 000000000000..5470c7e1ed57
--- /dev/null
+++ b/mail-filter/dcc/dcc-1.3.55.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dcc/dcc-1.3.55.ebuild,v 1.1 2007/04/08 20:14:39 ticho Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Distributed Checksum Clearinghouse"
+HOMEPAGE="http://www.rhyolite.com/anti-spam/dcc/"
+MY_P="dcc-dccd-${PV}"
+SRC_URI="http://www.rhyolite.com/anti-spam/dcc/source/${MY_P}.tar.Z"
+
+LICENSE="DCC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6 rrdtool"
+
+RDEPEND="dev-lang/perl
+ rrdtool? ( net-analyzer/rrdtool )
+ || ( net-misc/wget www-client/fetch net-misc/curl net-ftp/ftp )
+ virtual/libc"
+DEPEND="sys-apps/sed
+ sys-devel/gcc
+ ${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+dcc_cgibin=/var/www/localhost/cgi-bin/dcc
+dcc_homedir=/var/dcc
+dcc_libexec=/usr/sbin
+dcc_man=/usr/share/man
+dcc_rundir=/var/run/dcc
+
+src_compile() {
+ sed -i -e "s:^RRDTOOL=/usr/local/bin/rrdtool:RRDTOOL=/usr/bin/rrdtool:" \
+ misc/dcc-stats-init.in
+ sed -i -e "s:^RRDTOOL=/usr/local/bin/rrdtool:RRDTOOL=/usr/bin/rrdtool:" \
+ misc/dcc-stats-graph.in
+ sed -i -e "s:^RRDTOOL=/usr/local/bin/rrdtool:RRDTOOL=/usr/bin/rrdtool:" \
+ misc/dcc-stats-collect.in
+ sed -i -e "s:@installroot@:${D}:" \
+ cgi-bin/Makefile.in
+
+ local myconf
+ append-ldflags $(bindnow-flags)
+ myconf="${myconf} --homedir=${dcc_homedir}"
+ myconf="${myconf} --libexecdir=${dcc_libexec}"
+ myconf="${myconf} --bindir=/usr/bin"
+ myconf="${myconf} --mandir=/usr/share/man"
+ myconf="${myconf} --with-cgibin=${dcc_cgibin}"
+ myconf="${myconf} --disable-dccm"
+ #myconf="${myconf} --without-cgibin"
+ myconf="${myconf} --with-rundir=/var/run/dcc"
+ myconf="${myconf} `use_enable ipv6 IPv6`"
+ ./configure ${myconf} || die "configure failed!"
+ #make -C homedir
+ emake || die "emake failed!"
+}
+
+moveconf() {
+ for i in $@; do
+ local into=/etc/dcc/
+ local from=/var/dcc/
+ mv ${D}${from}${i} ${D}${into}
+ dosym ${into}${i} ${from}${i}
+ done
+}
+
+src_install() {
+ # stolen from the RPM .spec and modified for gentoo
+ MANOWN=root MANGRP=root export MANOWN MANGRP
+ BINOWN=$MANOWN BINGRP=$MANGRP export BINOWN BINGRP
+ DCC_PROTO_HOMEDIR=${D}${dcc_homedir} export DCC_PROTO_HOMEDIR
+ DCC_CGIBINDIR=${D}${dcc_cgibin} export DCC_CGIBINDIR
+ DCC_SUID=$BINOWN DCC_OWN=$BINOWN DCC_GRP=$BINGRP export DCC_SUID DCC_OWN DCC_GRP
+
+ dodir /etc/cron.daily ${dcc_homedir} ${dcc_cgibin} /usr/bin /usr/sbin /usr/share/man/man{0,8} /etc/dcc
+ keepdir /var/run/dcc /var/log/dcc
+
+ make DESTDIR=${D} DCC_BINDIR=${D}/usr/bin MANDIR=${D}/usr/share/man/man DCC_HOMEDIR=${D}${dcc_homedir} install || die
+
+ einfo "Branding and setting reasonable defaults"
+ sed -e "s/BRAND=\$/BRAND='Gentoo ${PF}'/;" \
+ -e "s/DCCM_LOG_AT=5\$/DCCM_LOG_AT=50/;" \
+ -e "s,DCCM_LOGDIR=log\$,DCCM_LOGDIR=/var/log/dcc,;" \
+ -e "s/DCCM_ARGS=\$/DCCM_ARGS='-SHELO -Smail_host -SSender -SList-ID'/;" \
+ -e "s/DCCIFD_ARGS=\$/DCCIFD_ARGS=\"\$DCCM_ARGS\"/;" \
+ -e 's/DCCIFD_ENABLE=off/DCCIFD_ENABLE=on/' \
+ -i ${D}${dcc_homedir}/dcc_conf
+
+ einfo "Providing cronjob"
+ mv ${D}/usr/bin/cron-dccd ${D}/etc/cron.daily/dccd
+
+ einfo "Putting system code in sbin instead of bin"
+ mv ${D}/usr/bin/{dbclean,dblist,dccd,dccsight,start-dccd,stop-dccd,wlist,newwebuser,stats-get,dccifd,start-grey,start-dccifd,fetch-testmsg-whitelist} ${D}/usr/sbin/ || die "Failed to move apps to sbin"
+
+ statslist="${D}/usr/bin/{dcc-stats-graph,dcc-stats-init,dcc-stats-collect}"
+ if use rrdtool; then
+ einfo "Installing rrdtool interface scripts"
+ eval mv $statslist ${D}/usr/sbin/ || die "Failed to move rrdtool apps"
+ else
+ einfo "Removing rrdtool interface scripts"
+ eval rm -f ${statslist} || die "Failed to clean up rrdtool scripts"
+ fi
+
+ einfo "Cleaning up"
+ rm -f ${D}/usr/bin/{logger,hackmc,na-spam,ng-spam,rcDCC,start-dccm,updatedcc,dns-helper}
+
+ einfo "Placing configuration files into /etc instead of /var/run"
+ moveconf dcc_conf flod grey_flod grey_whitelist ids map.txt whiteclnt whitecommon whitelist
+
+ rmdir ${D}/var/dcc/log/
+}
diff --git a/mail-filter/dcc/files/digest-dcc-1.3.55 b/mail-filter/dcc/files/digest-dcc-1.3.55
new file mode 100644
index 000000000000..b934b21ef4b4
--- /dev/null
+++ b/mail-filter/dcc/files/digest-dcc-1.3.55
@@ -0,0 +1,3 @@
+MD5 703bbeaa0fcb5e89d1e8d84a4b5a0303 dcc-dccd-1.3.55.tar.Z 1457561
+RMD160 8182bdd8f5c96a68ba6989bf37807dfa5aee19b7 dcc-dccd-1.3.55.tar.Z 1457561
+SHA256 9aa82c645b90a1000c6cc812e6df18768885486e053194220e8753d1c45ebb94 dcc-dccd-1.3.55.tar.Z 1457561