summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-07-08 13:04:13 +0000
committerPacho Ramos <pacho@gentoo.org>2011-07-08 13:04:13 +0000
commitfa69719081cbad9235ba8671c8e6b8ad1625ff46 (patch)
treec493e0e8cb32f7d19eaa78322be39eca638c68ca /media-gfx/xsane
parentx86 stable per bug 374001 (diff)
downloadgentoo-2-fa69719081cbad9235ba8671c8e6b8ad1625ff46.tar.gz
gentoo-2-fa69719081cbad9235ba8671c8e6b8ad1625ff46.tar.bz2
gentoo-2-fa69719081cbad9235ba8671c8e6b8ad1625ff46.zip
Version bump and apply a lot of fixes from different distributions, taking this (with printing and graphics herds as backup) as this looks a bit orphan for a long time.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/xsane')
-rw-r--r--media-gfx/xsane/ChangeLog10
-rw-r--r--media-gfx/xsane/metadata.xml14
-rw-r--r--media-gfx/xsane/xsane-0.998.ebuild88
3 files changed, 108 insertions, 4 deletions
diff --git a/media-gfx/xsane/ChangeLog b/media-gfx/xsane/ChangeLog
index 63bb602ad359..56dcfc8dfa27 100644
--- a/media-gfx/xsane/ChangeLog
+++ b/media-gfx/xsane/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/xsane
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/ChangeLog,v 1.85 2011/03/02 10:13:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/ChangeLog,v 1.86 2011/07/08 13:04:13 pacho Exp $
+
+*xsane-0.998 (08 Jul 2011)
+
+ 08 Jul 2011; Pacho Ramos <pacho@gentoo.org> +xsane-0.998.ebuild,
+ metadata.xml:
+ Version bump and apply a lot of fixes from different distributions, taking
+ this (with printing and graphics herds as backup) as this looks a bit orphan
+ for a long time.
02 Mar 2011; Justin Lecher <jlec@gentoo.org> xsane-0.996.ebuild,
xsane-0.997.ebuild:
diff --git a/media-gfx/xsane/metadata.xml b/media-gfx/xsane/metadata.xml
index f924403c63c3..d353fec626d5 100644
--- a/media-gfx/xsane/metadata.xml
+++ b/media-gfx/xsane/metadata.xml
@@ -1,9 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>no-herd</herd>
+<herd>printing</herd>
+<herd>graphics</herd>
<maintainer>
-<email>phosphan@gentoo.org</email>
-<description>Package free for adoption,</description>
+ <email>phosphan@gentoo.org</email>
+ <description>Package free for adoption</description>
</maintainer>
+<maintainer>
+ <email>pacho@gentoo.org</email>
+ <description>Taking care until somebody wants to also help</description>
+</maintainer>
+<use>
+ <flag name='ocr'>Enable support for Optical Character Recognition reader</flag>
+</use>
</pkgmetadata>
diff --git a/media-gfx/xsane/xsane-0.998.ebuild b/media-gfx/xsane/xsane-0.998.ebuild
new file mode 100644
index 000000000000..a46d9dd008c8
--- /dev/null
+++ b/media-gfx/xsane/xsane-0.998.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xsane/xsane-0.998.ebuild,v 1.1 2011/07/08 13:04:13 pacho Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="graphical scanning frontend"
+HOMEPAGE="http://www.xsane.org/"
+SRC_URI="http://www.xsane.org/download/${P}.tar.gz
+ http://dev.gentoo.org/~pacho/xsane/${P}-patches.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls jpeg png tiff gimp lcms ocr"
+
+RDEPEND="media-gfx/sane-backends
+ x11-libs/gtk+:2
+ x11-misc/xdg-utils
+ jpeg? ( virtual/jpeg )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+ gimp? ( media-gfx/gimp )
+ lcms? ( =media-libs/lcms-1* )"
+
+PDEPEND="ocr? ( app-text/gocr )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ export OLDXSANE
+ if has_version '<=media-gfx/xsane-0.93'; then
+ OLDXSANE="yes"
+ else
+ OLDXSANE="no"
+ fi
+}
+
+src_prepare() {
+ # Apply multiple fixes from different distributions
+ epatch "${WORKDIR}/${P}-patches"/*.patch
+}
+
+src_configure() {
+ local extraCPPflags
+ if use lcms; then
+ extraCPPflags="-I /usr/include/lcms"
+ fi
+ CPPFLAGS="${CPPFLAGS} ${extraCPPflags}" econf --enable-gtk2 \
+ $(use_enable nls) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable tiff) \
+ $(use_enable gimp) \
+ $(use_enable lcms)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc xsane.*
+
+ # link xsane so it is seen as a plugin in gimp
+ if use gimp; then
+ local plugindir
+ if [ -x /usr/bin/gimptool ]; then
+ plugindir="$(gimptool --gimpplugindir)/plug-ins"
+ elif [ -x /usr/bin/gimptool-2.0 ]; then
+ plugindir="$(gimptool-2.0 --gimpplugindir)/plug-ins"
+ else
+ die "Can't find GIMP plugin directory."
+ fi
+ dodir "${plugindir}"
+ dosym /usr/bin/xsane "${plugindir}"
+ fi
+
+ newicon src/xsane-48x48.png ${PN}.png
+}
+
+pkg_postinst() {
+ if [ x${OLDXSANE} = 'xyes' ]; then
+ ewarn "If you are upgrading from <=xsane-0.93, please make sure to"
+ ewarn "remove ~/.sane/xsane/xsane.rc _before_ you start xsane for"
+ ewarn "the first time."
+ fi
+}