summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-22 14:37:06 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-22 14:37:06 +0000
commit2b21bc5e60bfbdcda2e2e171a3109da4d2905f1f (patch)
tree581474cf26a837595c43021bc503fc295434e865 /media-libs/atlas-c++
parentadded 3dfx's GPL (diff)
downloadgentoo-2-2b21bc5e60bfbdcda2e2e171a3109da4d2905f1f.tar.gz
gentoo-2-2b21bc5e60bfbdcda2e2e171a3109da4d2905f1f.tar.bz2
gentoo-2-2b21bc5e60bfbdcda2e2e171a3109da4d2905f1f.zip
repoman'd
Diffstat (limited to 'media-libs/atlas-c++')
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.4.4.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/media-libs/atlas-c++/atlas-c++-0.4.4.ebuild b/media-libs/atlas-c++/atlas-c++-0.4.4.ebuild
index 2d9f08089bad..8d98b87881c4 100644
--- a/media-libs/atlas-c++/atlas-c++-0.4.4.ebuild
+++ b/media-libs/atlas-c++/atlas-c++-0.4.4.ebuild
@@ -1,18 +1,23 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.4.4.ebuild,v 1.3 2002/07/11 06:30:38 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.4.4.ebuild,v 1.4 2002/07/22 14:37:05 seemant Exp $
-S="${WORKDIR}/Atlas-C++-${PV}"
-SRC_URI="ftp://victor.worldforge.org/pub/worldforge/libs/Atlas-C++/Atlas-C++-0.4.4.tar.bz2"
+MY_PN="Atlas-C++"
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
HOMEPAGE="http://www.worldforge.net"
+SRC_URI="ftp://victor.worldforge.org/pub/worldforge/libs/${MY_PN}/${MY_P}.tar.bz2"
+
SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="x86"
+
DEPEND="virtual/glibc
- ( <dev-libs/libsigc++-1.1.0
- >=dev-libs/libsigc++-1.0.4-r1 )"
+ =dev-libs/libsigc++-1.0*"
src_compile() {
- ./configure --host=${CHOST} --prefix=/usr || die
+ econf || die
emake || die
}
@@ -21,4 +26,5 @@ src_install() {
make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog NEWS README ROADMAP THANKS TODO
}