summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-29 23:41:16 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-29 23:41:16 +0000
commit9812a48804eee7d28944303fc64755166f9192c1 (patch)
tree64e3b033ac6f45820593f802541c7390363ed90d /media-libs/gle
parentStable on SPARC wrt bug #149358. (diff)
downloadgentoo-2-9812a48804eee7d28944303fc64755166f9192c1.tar.gz
gentoo-2-9812a48804eee7d28944303fc64755166f9192c1.tar.bz2
gentoo-2-9812a48804eee7d28944303fc64755166f9192c1.zip
Fix autotools dependencies. Closes bug #150142.
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'media-libs/gle')
-rw-r--r--media-libs/gle/ChangeLog5
-rw-r--r--media-libs/gle/gle-3.1.0-r1.ebuild12
2 files changed, 14 insertions, 3 deletions
diff --git a/media-libs/gle/ChangeLog b/media-libs/gle/ChangeLog
index 6cb75609372f..cc6fbbd6a483 100644
--- a/media-libs/gle/ChangeLog
+++ b/media-libs/gle/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/gle
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/ChangeLog,v 1.24 2006/09/13 17:52:19 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/ChangeLog,v 1.25 2006/10/29 23:41:16 flameeyes Exp $
+
+ 29 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> gle-3.1.0-r1.ebuild:
+ Fix autotools dependencies. Closes bug #150142.
06 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> gle-3.1.0-r1.ebuild:
Add ~x86-fbsd keyword.
diff --git a/media-libs/gle/gle-3.1.0-r1.ebuild b/media-libs/gle/gle-3.1.0-r1.ebuild
index 1deb59a05089..c2acc6b024f9 100644
--- a/media-libs/gle/gle-3.1.0-r1.ebuild
+++ b/media-libs/gle/gle-3.1.0-r1.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/gle-3.1.0-r1.ebuild,v 1.2 2006/09/06 20:42:48 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/gle-3.1.0-r1.ebuild,v 1.3 2006/10/29 23:41:16 flameeyes Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.4"
inherit autotools multilib
@@ -20,7 +23,10 @@ DEPEND="virtual/opengl
virtual/glut
app-admin/eselect-opengl"
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
# Replace inclusion of malloc.h with stdlib.h as needed by Mac OS X and
# FreeBSD. See bug #130340.
sed -i -e 's:malloc.h:stdlib.h:g' src/*
@@ -28,7 +34,9 @@ src_compile() {
# Don't build binary examples as they never get installed. See bug 141859.
sed -i -e 's:examples::' Makefile.am
eautoreconf
+}
+src_compile() {
econf --with-x \
--x-libraries=/usr/$(get_libdir)/opengl/xorg-x11 \
|| die "econf failed."