summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-29 09:39:06 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-29 09:39:06 +0000
commit9f647881ab3fac7474b2e3d7abf46e54b2fb3ed6 (patch)
treeb13f0b10f978004403a9e7a79fdfc0b63f2a7da4 /media-libs/paragui
parentAdded missing expat dependency (diff)
downloadgentoo-2-9f647881ab3fac7474b2e3d7abf46e54b2fb3ed6.tar.gz
gentoo-2-9f647881ab3fac7474b2e3d7abf46e54b2fb3ed6.tar.bz2
gentoo-2-9f647881ab3fac7474b2e3d7abf46e54b2fb3ed6.zip
Fix for gcc-4.3, bug #229961. Thanks to Petr Behan <petr.behan@seznam.cz>.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'media-libs/paragui')
-rw-r--r--media-libs/paragui/ChangeLog6
-rw-r--r--media-libs/paragui/files/paragui-1.1.8-gcc43.patch27
-rw-r--r--media-libs/paragui/paragui-1.1.8.ebuild6
3 files changed, 36 insertions, 3 deletions
diff --git a/media-libs/paragui/ChangeLog b/media-libs/paragui/ChangeLog
index ccf1ff79f55c..6e181f08c66a 100644
--- a/media-libs/paragui/ChangeLog
+++ b/media-libs/paragui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/paragui
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/paragui/ChangeLog,v 1.29 2008/01/15 08:42:13 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/paragui/ChangeLog,v 1.30 2008/06/29 09:39:05 loki_val Exp $
+
+ 29 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/paragui-1.1.8-gcc43.patch, paragui-1.1.8.ebuild:
+ Fix for gcc-4.3, bug #229961. Thanks to Petr Behan <petr.behan@seznam.cz>.
15 Jan 2008; Tristan Heaven <nyhm@gentoo.org>
files/paragui-1.1.8-asneeded.patch, paragui-1.1.8.ebuild:
diff --git a/media-libs/paragui/files/paragui-1.1.8-gcc43.patch b/media-libs/paragui/files/paragui-1.1.8-gcc43.patch
new file mode 100644
index 000000000000..d47e2e5d956b
--- /dev/null
+++ b/media-libs/paragui/files/paragui-1.1.8-gcc43.patch
@@ -0,0 +1,27 @@
+--- include/paragui.h.old 2004-04-17 22:39:07.000000000 +0200
++++ include/paragui.h 2008-06-29 00:58:45.000000000 +0200
+@@ -65,6 +65,13 @@
+ #include "paraconfig_gnu.h"
+ #endif
+
++#if PG_VERSIONNUM(__GNUC__, __GNUC_MINOR__, 0) >= PG_VERSIONNUM(4, 3, 0)
++#undef HAVE_HASH_MAP
++#ifndef HAVE_EXT_HASH_MAP
++#define HAVE_EXT_HASH_MAP
++#endif
++#endif
++
+ //
+ // STL map / hash_map
+ //
+--- src/core/pgfilearchive.cpp.old 2004-03-13 14:45:44.000000000 +0100
++++ src/core/pgfilearchive.cpp 2008-06-29 00:59:27.000000000 +0200
+@@ -100,7 +101,7 @@
+ const char* sep = GetDirSeparator();
+ std::string::size_type pos = 0, incr;
+ newpath = new std::string(path);
+- incr = std::strlen(sep);
++ incr = strlen(sep);
+ if(incr == 1 && sep[0] == '/')
+ return newpath;
+
diff --git a/media-libs/paragui/paragui-1.1.8.ebuild b/media-libs/paragui/paragui-1.1.8.ebuild
index d70f43c718bc..76487272af05 100644
--- a/media-libs/paragui/paragui-1.1.8.ebuild
+++ b/media-libs/paragui/paragui-1.1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/paragui/paragui-1.1.8.ebuild,v 1.10 2008/01/15 08:42:13 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/paragui/paragui-1.1.8.ebuild,v 1.11 2008/06/29 09:39:05 loki_val Exp $
inherit autotools eutils
@@ -30,7 +30,9 @@ src_unpack() {
cd "${S}"
epatch \
"${FILESDIR}"/${P}-header.patch \
- "${FILESDIR}"/${P}-asneeded.patch
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+
eautoreconf
}