summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-11-22 22:48:17 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-11-22 22:48:17 +0000
commit7005cfb618fe356adc5d7d000250f210d03333ca (patch)
tree1d84b510ff365171ef57eebff824f678b806f1fd /media-plugins/audacious-plugins
parentRemoved old versions. (diff)
downloadgentoo-2-7005cfb618fe356adc5d7d000250f210d03333ca.tar.gz
gentoo-2-7005cfb618fe356adc5d7d000250f210d03333ca.tar.bz2
gentoo-2-7005cfb618fe356adc5d7d000250f210d03333ca.zip
1.2.3 is defective as far as wavpack goes, pull and bump to 1.2.4 which actually works. Thanks for Diego Petteno <flameeyes@gentoo.org> for quickly identifying the issue.
(Portage version: 2.1.2_rc2-r1)
Diffstat (limited to 'media-plugins/audacious-plugins')
-rw-r--r--media-plugins/audacious-plugins/ChangeLog13
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-1.2.4.ebuild100
-rw-r--r--media-plugins/audacious-plugins/files/digest-audacious-plugins-1.2.43
3 files changed, 115 insertions, 1 deletions
diff --git a/media-plugins/audacious-plugins/ChangeLog b/media-plugins/audacious-plugins/ChangeLog
index 4278812eb0ba..61d0cdedddc3 100644
--- a/media-plugins/audacious-plugins/ChangeLog
+++ b/media-plugins/audacious-plugins/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for media-plugins/audacious-plugins
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.16 2006/11/22 18:12:52 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.17 2006/11/22 22:48:17 chainsaw Exp $
+
+*audacious-plugins-1.2.4 (22 Nov 2006)
+
+ 22 Nov 2006; Tony Vroon <chainsaw@gentoo.org>
+ -audacious-plugins-1.2.3.ebuild, +audacious-plugins-1.2.4.ebuild:
+ Alright then, as mr. Petteno already suggested in bug #155961, some patching
+ to the wavpack plugin made sure it actually worked with the 4.31 release in
+ portage. nenolod developed against wavpack SVN, which has extern C
+ protection in the headers. No such luxuries in older releases. Although I
+ believe the technical term is a brown paper bag release, I thought it was
+ more <voice=homer>Ah crap</voice>.
*audacious-plugins-1.2.3 (22 Nov 2006)
diff --git a/media-plugins/audacious-plugins/audacious-plugins-1.2.4.ebuild b/media-plugins/audacious-plugins/audacious-plugins-1.2.4.ebuild
new file mode 100644
index 000000000000..ad3cd387defc
--- /dev/null
+++ b/media-plugins/audacious-plugins/audacious-plugins-1.2.4.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/audacious-plugins-1.2.4.ebuild,v 1.1 2006/11/22 22:48:17 chainsaw Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://audacious-media-player.org/release/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="aac alsa arts chardet esd flac jack lirc modplug mp3 musepack nls oss sid sndfile timidity vorbis wavpack wma pulseaudio"
+
+RDEPEND="app-arch/unzip
+ dev-libs/libxml2
+ net-misc/curl
+ >=media-sound/audacious-1.2.1
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.1
+ >=dev-cpp/libbinio-1.4
+ media-libs/taglib
+ alsa? ( >=media-libs/alsa-lib-1.0.9_rc2 )
+ arts? ( kde-base/arts )
+ esd? ( >=media-sound/esound-0.2.30 )
+ flac? ( >=media-libs/libvorbis-1.0
+ || ( ~media-libs/flac-1.1.2
+ ~media-libs/flac-1.1.3 )
+ )
+ jack? ( >=media-libs/bio2jack-0.4
+ media-libs/libsamplerate
+ media-sound/jack-audio-connection-kit )
+ lirc? ( app-misc/lirc )
+ modplug? ( media-libs/libmodplug )
+ musepack? ( media-libs/libmpcdec )
+ sid? ( media-libs/libsidplay )
+ sndfile? ( media-libs/libsndfile )
+ timidity? ( media-sound/timidity++ )
+ vorbis? ( >=media-libs/libvorbis-1.0
+ >=media-libs/libogg-1.0 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
+ wavpack? ( >=media-sound/wavpack-4.31 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+mp3_warning() {
+ if ! useq mp3 ; then
+ echo
+ ewarn "MP3 support is now optional, you may want to enable the mp3 USE-flag"
+ echo
+ fi
+}
+
+src_compile() {
+ mp3_warning
+
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+ # Bug #86689
+ is-flag "-O*" || append-flags -O
+
+ econf \
+ --with-dev-dsp=/dev/sound/dsp \
+ --with-dev-mixer=/dev/sound/mixer \
+ $(use_enable vorbis) \
+ $(use_enable esd) \
+ $(use_enable mp3) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable flac) \
+ $(use_enable aac) \
+ $(use_enable modplug) \
+ $(use_enable lirc) \
+ $(use_enable sndfile) \
+ $(use_enable wma) \
+ $(use_enable sid) \
+ $(use_enable musepack) \
+ $(use_enable jack) \
+ $(use_enable timidity) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable chardet) \
+ $(use_enable wavpack) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS
+}
+
+pkg_postinst() {
+ mp3_warning
+}
diff --git a/media-plugins/audacious-plugins/files/digest-audacious-plugins-1.2.4 b/media-plugins/audacious-plugins/files/digest-audacious-plugins-1.2.4
new file mode 100644
index 000000000000..0aa19090215d
--- /dev/null
+++ b/media-plugins/audacious-plugins/files/digest-audacious-plugins-1.2.4
@@ -0,0 +1,3 @@
+MD5 c7a9a886c5a26c4e3d55dabbeb79393b audacious-plugins-1.2.4.tgz 2339832
+RMD160 c156f0ab2f06c5714d0545bb1b33cbcb604a1ddc audacious-plugins-1.2.4.tgz 2339832
+SHA256 ea12bcb946a416c09be6cfe29954893d0d010f3f991b06aa45feb8bc63e92f1c audacious-plugins-1.2.4.tgz 2339832